summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-11-09 11:57:25 +0100
committerPacho Ramos <pacho@gentoo.org>2016-11-09 11:59:16 +0100
commit517f783331e1c17e007963be5222369445a9904d (patch)
tree3db29a0de27c2855e2c572f4ad7f8f567f0decf5 /games-simulation
parentpackage.mask drop obsolete entries (diff)
downloadgentoo-517f783331e1c17e007963be5222369445a9904d.tar.gz
gentoo-517f783331e1c17e007963be5222369445a9904d.tar.bz2
gentoo-517f783331e1c17e007963be5222369445a9904d.zip
Remove masked for removal packages
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/corsix-th/Manifest1
-rw-r--r--games-simulation/corsix-th/corsix-th-0.30.ebuild92
-rw-r--r--games-simulation/corsix-th/files/corsix-th-0.30-install.patch40
-rw-r--r--games-simulation/corsix-th/metadata.xml18
4 files changed, 0 insertions, 151 deletions
diff --git a/games-simulation/corsix-th/Manifest b/games-simulation/corsix-th/Manifest
deleted file mode 100644
index 55ea375b4fe6..000000000000
--- a/games-simulation/corsix-th/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST corsix-th-0.30.tar.gz 4345385 SHA256 4947ebdc50b01fde0aca797250d50b9806b9e6f3f4323872fd914f033f4c92e7 SHA512 1afd9d68dd6db82393e454e2c234179029902b701aafe4d2ca76381be195acba55f0ee062ce071a78cf3f5e8762e25452f386276aecc1af816553532b870964a WHIRLPOOL b01a1d72c0408c1d7d7d0a72e55c9b9f0863acfe064c07f4920c3f66bfb29fb0acf0a7e4e1d80e214b2e81d073e070427fbd8fca9cd34e14cda561159a88d4d0
diff --git a/games-simulation/corsix-th/corsix-th-0.30.ebuild b/games-simulation/corsix-th/corsix-th-0.30.ebuild
deleted file mode 100644
index b62d08cd16c5..000000000000
--- a/games-simulation/corsix-th/corsix-th-0.30.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-CMAKE_IN_SOURCE_BUILD=1
-WX_GTK_VER="3.0"
-inherit eutils cmake-utils gnome2-utils wxwidgets games
-
-MY_P="CorsixTH-${PV}-Source"
-
-DESCRIPTION="Open source clone of Theme Hospital"
-HOMEPAGE="https://github.com/CorsixTH/CorsixTH"
-SRC_URI="https://github.com/CorsixTH/CorsixTH/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+ffmpeg mapeditor truetype opengl +sound"
-
-RDEPEND=">=dev-lang/lua-5.1
- media-libs/libsdl[X]
- ffmpeg? ( virtual/ffmpeg )
- mapeditor? ( x11-libs/wxGTK:${WX_GTK_VER}[X] )
- truetype? ( media-libs/freetype:2 )
- opengl? ( virtual/opengl )
- sound? ( media-libs/sdl-mixer )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-S=${WORKDIR}/CorsixTH-${PV}
-
-pkg_setup() {
- games_pkg_setup
-
- if use mapeditor && use !opengl ; then
- eerror "need opengl enabled for mapeditor to work!"
- die "need opengl enabled for mapeditor to work!"
- fi
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-install.patch
-}
-
-src_configure() {
- local mycmakeargs=(
- $(cmake-utils_use_with opengl OPENGL)
- $(cmake-utils_use_with sound AUDIO)
- $(cmake-utils_use_with truetype FREETYPE2)
- $(cmake-utils_use_with ffmpeg MOVIES)
- $(cmake-utils_use_build mapeditor MAPEDITOR)
- -DCMAKE_INSTALL_PREFIX="${GAMES_DATADIR}"
- -DBINDIR="$(games_get_libdir)/${PN}"
- )
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
-}
-
-src_install() {
- cmake-utils_src_install
-
- DOCS="CorsixTH/changelog.txt" cmake-utils_src_install
- games_make_wrapper ${PN} "$(games_get_libdir)/${PN}/CorsixTH" \
- "${GAMES_DATADIR}/CorsixTH"
- games_make_wrapper ${PN}-mapedit "$(games_get_libdir)/${PN}/MapEdit" \
- "${GAMES_DATADIR}/CorsixTH"
- newicon -s scalable CorsixTH/Original_Logo.svg ${PN}.svg
- make_desktop_entry ${PN}
- prepgamesdirs
-}
-
-pkg_preinst() {
- games_pkg_preinst
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- elog "optional dependencies:"
- elog " media-libs/sdl-mixer[timidity] (MIDI sound support)"
-
- games_pkg_postinst
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
-}
diff --git a/games-simulation/corsix-th/files/corsix-th-0.30-install.patch b/games-simulation/corsix-th/files/corsix-th-0.30-install.patch
deleted file mode 100644
index 6c84bb09870f..000000000000
--- a/games-simulation/corsix-th/files/corsix-th-0.30-install.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-From: Julian Ospald <hasufell@gentoo.org>
-Date: Sun Oct 12 21:30:07 UTC 2014
-Subject:
-
---- MapEdit/CMakeLists.txt
-+++ MapEdit/CMakeLists.txt
-@@ -207,5 +207,5 @@
- ENDIF()
-
- ELSE()
-- install(TARGETS MapEdit RUNTIME DESTINATION CorsixTH)
-+ install(TARGETS MapEdit RUNTIME DESTINATION ${BINDIR})
- ENDIF()
---- CorsixTH/CMakeLists.txt
-+++ CorsixTH/CMakeLists.txt
-@@ -223,10 +223,10 @@
- ENDIF()
-
- ELSE()
-- install(TARGETS CorsixTH RUNTIME DESTINATION CorsixTH)
-+ install(TARGETS CorsixTH RUNTIME DESTINATION ${BINDIR})
- install(DIRECTORY Lua Levels DESTINATION CorsixTH PATTERN "*.svn" EXCLUDE)
- install(DIRECTORY Bitmap DESTINATION CorsixTH
- FILES_MATCHING REGEX ".*\\.(tab|pal|dat|png)$"
- PATTERN "*.svn" EXCLUDE)
-- install(FILES CorsixTH.lua LICENSE.txt CorsixTH.ico DESTINATION CorsixTH )
-+ install(FILES CorsixTH.lua CorsixTH.ico DESTINATION CorsixTH )
- ENDIF()
---- CMakeLists.txt
-+++ CMakeLists.txt
-@@ -25,6 +25,9 @@
- SET(CMAKE_OSX_DEPLOYMENT_TARGET 10.5)
- ENDIF()
-
-+# paths
-+set(BINDIR bin CACHE PATH "where to install binaries")
-+
- # Define our options
- OPTION(WITH_OPENGL "Activate OpenGL Renderer" OFF)
- OPTION(WITH_DIRECTX "Activate DirectX Renderer" OFF)
diff --git a/games-simulation/corsix-th/metadata.xml b/games-simulation/corsix-th/metadata.xml
deleted file mode 100644
index 4cefea497b10..000000000000
--- a/games-simulation/corsix-th/metadata.xml
+++ /dev/null
@@ -1,18 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <!-- maintainer-needed -->
- <use>
- <flag name="ffmpeg">Use ffmpeg for playing in-game cutscenes.</flag>
- <flag name="opengl">Use OpenGL for rendering.</flag>
- <flag name="sound">Use SDL mixer for in-game sound.</flag>
- <flag name="mapeditor">Build the map editor (needs opengl enabled!).</flag>
- <flag name="truetype">Use high quality fonts.</flag>
- </use>
- <longdescription>
- CorsixTH aims to reimplement the game engine of Theme Hospital, with the capability of loading assets including graphics and levels from the original game. This means that you will need a purchased copy of Theme Hospital, or a copy of the demo, in order to use CorsixTH.
- </longdescription>
- <upstream>
- <remote-id type="github">CorsixTH/CorsixTH</remote-id>
- </upstream>
-</pkgmetadata>