summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-25 15:13:36 +0000
committerSam James <sam@gentoo.org>2021-03-25 15:22:00 +0000
commit709917098fc4dbec7a65c6e084e2e0f0c0775296 (patch)
treea0945850f49d96b02b83943343518905ad83b572 /games-simulation
parentgames-simulation/singularity: add missing media-libs/sdl-mixer dep (diff)
downloadgentoo-709917098fc4dbec7a65c6e084e2e0f0c0775296.tar.gz
gentoo-709917098fc4dbec7a65c6e084e2e0f0c0775296.tar.bz2
gentoo-709917098fc4dbec7a65c6e084e2e0f0c0775296.zip
games-simulation/singularity: add 1.00
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/singularity/Manifest1
-rw-r--r--games-simulation/singularity/singularity-1.00.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/games-simulation/singularity/Manifest b/games-simulation/singularity/Manifest
index 473099d139a6..b6a2bca09221 100644
--- a/games-simulation/singularity/Manifest
+++ b/games-simulation/singularity/Manifest
@@ -1,2 +1,3 @@
DIST endgame-singularity-music-007.zip 51774799 BLAKE2B 78595b16e422d2312be860686aca9401f6f1eed35fe40dbbc3a3999b1feb5e32aa6d51a66d94c9241aca2b6606bb7135491298b94c8033a1437c2cd7b23f9120 SHA512 ab46e77c833085f0c5b1b46fef72ab807e79ca422ad043ef67a4bf4384cb0177319f21b4bd01496e6c3fc6fe9a2f36ec256e19f0e829ad7bf9f0c5bd38bf0fe5
+DIST singularity-1.00.tar.gz 1944972 BLAKE2B 1ca2b120311a19f175014835930610583e8f605dbda3ca3ca96d7e0da86bddeb4b0a264f50a003aa51e05b86ce971255ffda5f498598dde6be370b9a953eb1d0 SHA512 f3581048c5a535fdbd28d2af1ac596f5396fd712b716931f17de75f8b170f0e226deb2c113023357e21e7de1294e4a632515962df9ee43768baf0fb4bbaa08da
DIST singularity-1.0a1.tar.gz 1927083 BLAKE2B aeed099dd33c135f5b2e21f5e907646f32aaa0879a1b2e1f09c19045499ae52b004a8f52fee72bfe0977805899e4c7cdff6abf36e9fd3604f73cba7e395c265e SHA512 8ce624a50819e0abc04fd81a1d7658eab64ea8325de0a5790ec2a92e5fa6b62cfef8fe705fe8b209194c05927e3cf5adfc6f48934e0a70edf8b251c24084fc25
diff --git a/games-simulation/singularity/singularity-1.00.ebuild b/games-simulation/singularity/singularity-1.00.ebuild
new file mode 100644
index 000000000000..02d8aec65fc7
--- /dev/null
+++ b/games-simulation/singularity/singularity-1.00.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit desktop distutils-r1
+
+MUSIC="endgame-${PN}-music-007"
+DESCRIPTION="Simulation of a true AI. Go from computer to computer, chased by the whole world"
+HOMEPAGE="http://www.emhsoft.com/singularity/ https://github.com/singularity/singularity"
+SRC_URI="https://github.com/singularity/singularity/releases/download/v${PV}/${P/_alpha/a}.tar.gz"
+SRC_URI+=" https://emhsoft.com/singularity/${MUSIC}.zip"
+S="${WORKDIR}/${P/_alpha/a}"
+
+LICENSE="GPL-2 CC-BY-SA-2.5"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+BDEPEND="app-arch/unzip"
+DEPEND="
+ $(python_gen_cond_dep '
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pygame[${PYTHON_USEDEP}]
+ dev-python/polib[${PYTHON_USEDEP}]
+ ')
+"
+# sdl-mixer is used at runtime (through pygame)
+# bug #731702
+RDEPEND="
+ ${DEPEND}
+ media-libs/sdl-mixer[vorbis,wav]
+ !sys-cluster/singularity
+"
+
+src_install() {
+ distutils-r1_src_install
+
+ insinto /usr/share/${PN}/${PN}/music
+ doins "${WORKDIR}"/${MUSIC}/*
+
+ dodoc README.txt TODO
+
+ domenu ${PN}.desktop
+ newicon ${PN}/data/themes/default/images/icon.png ${PN}.png
+}