summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-12-16 21:29:27 -0500
committerMichael Sterrett <mr_bones_@gentoo.org>2015-12-16 21:29:45 -0500
commit33c3827890b9a6a8879d564dc4aeb73604eddfeb (patch)
treed1dde2f6fd51a4887bb4a1dab42db8f1a2616e9f /games-sports/foobillard
parentdev-ruby/rbpdf: add version 1.19.0. (diff)
downloadgentoo-33c3827890b9a6a8879d564dc4aeb73604eddfeb.tar.gz
gentoo-33c3827890b9a6a8879d564dc4aeb73604eddfeb.tar.bz2
gentoo-33c3827890b9a6a8879d564dc4aeb73604eddfeb.zip
better deps and make it work with latest eselect-opengl
Package-Manager: portage-2.2.24
Diffstat (limited to 'games-sports/foobillard')
-rw-r--r--games-sports/foobillard/foobillard-3.0a.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/games-sports/foobillard/foobillard-3.0a.ebuild b/games-sports/foobillard/foobillard-3.0a.ebuild
index babc1d84dc38..360aa076efa7 100644
--- a/games-sports/foobillard/foobillard-3.0a.ebuild
+++ b/games-sports/foobillard/foobillard-3.0a.ebuild
@@ -3,7 +3,7 @@
# $Id$
EAPI=5
-inherit eutils autotools games
+inherit eutils flag-o-matic autotools toolchain-funcs games
DESCRIPTION="8ball, 9ball, snooker and carambol game"
HOMEPAGE="http://foobillard.sourceforge.net/"
@@ -19,10 +19,10 @@ DEPEND="x11-libs/libXaw
virtual/opengl
virtual/glu
>=media-libs/freetype-2.0.9
- media-libs/libpng
- sdl? ( media-libs/libsdl )
+ media-libs/libpng:0
+ sdl? ( media-libs/libsdl[video] )
!sdl? ( media-libs/freeglut )"
-RDEPEND="${DEPEND}"
+RDEPEND=${DEPEND}
src_prepare() {
epatch \
@@ -37,6 +37,7 @@ src_prepare() {
}
src_configure() {
+ use video_cards_nvidia && append-ldflags -L/usr/$(get_libdir)/opengl/nvidia/lib
egamesconf \
--enable-sound \
$(use_enable sdl SDL) \