summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-09-28 15:50:07 -0500
committerAustin English <wizardedit@gentoo.org>2016-09-28 16:13:55 -0500
commit8b2048cf4e520f4557833804ee9ce7b544b8e7dc (patch)
tree40e48423b627cf153617072750ed732d6cffa343 /games-sports/ski
parentgames-sports/gracer: remove deprecated games eclass (diff)
downloadgentoo-8b2048cf4e520f4557833804ee9ce7b544b8e7dc.tar.gz
gentoo-8b2048cf4e520f4557833804ee9ce7b544b8e7dc.tar.bz2
gentoo-8b2048cf4e520f4557833804ee9ce7b544b8e7dc.zip
games-sports/ski: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.3.0
Diffstat (limited to 'games-sports/ski')
-rw-r--r--games-sports/ski/ski-6.9-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/games-sports/ski/ski-6.9-r1.ebuild b/games-sports/ski/ski-6.9-r1.ebuild
new file mode 100644
index 000000000000..b7790670e824
--- /dev/null
+++ b/games-sports/ski/ski-6.9-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+inherit eutils python-single-r1
+
+DESCRIPTION="A simple text-mode skiing game"
+HOMEPAGE="http://www.catb.org/~esr/ski/"
+SRC_URI="http://www.catb.org/~esr/ski/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_install() {
+ dobin ski
+ dodoc NEWS README
+ doman ski.6
+ domenu ski.desktop
+ doicon ski.png
+ python_fix_shebang "${ED}/usr/bin"
+}