summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-sports/trophy
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-sports/trophy')
-rw-r--r--games-sports/trophy/Manifest1
-rw-r--r--games-sports/trophy/metadata.xml8
-rw-r--r--games-sports/trophy/trophy-2.0.3.ebuild42
3 files changed, 51 insertions, 0 deletions
diff --git a/games-sports/trophy/Manifest b/games-sports/trophy/Manifest
new file mode 100644
index 000000000000..2532846e95b9
--- /dev/null
+++ b/games-sports/trophy/Manifest
@@ -0,0 +1 @@
+DIST trophy-2.0.3.tar.gz 14780127 SHA256 1fc8311458f86abeae51d7b47db8f95221bea737ea782786892cc36677a97030 SHA512 40376c2a27f205421189d5fea3dc154492fae8977b62d1150c986be6fe823d0f718b61a51a2febad851fc96cf4e1b408ab9318ab32e32d685966228f51327b06 WHIRLPOOL 7ae116c433808570cec5b122cd31aebb86d26c2b8cc7654f19201160e806ce66f56b12c9587ef1dbb5d693a3f5faec0ddd0a12e93e9625c6ddc294b0390b41e1
diff --git a/games-sports/trophy/metadata.xml b/games-sports/trophy/metadata.xml
new file mode 100644
index 000000000000..d3373e892e54
--- /dev/null
+++ b/games-sports/trophy/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">trophy</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-sports/trophy/trophy-2.0.3.ebuild b/games-sports/trophy/trophy-2.0.3.ebuild
new file mode 100644
index 000000000000..b9f0e467d943
--- /dev/null
+++ b/games-sports/trophy/trophy-2.0.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils gnome2-utils games
+
+DESCRIPTION="2D Racing Game"
+HOMEPAGE="http://trophy.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-games/clanlib:0.8[opengl]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_install() {
+ default
+ doicon -s 72 "${D}${GAMES_DATADIR}"/icons/${PN}.png
+ rm -rf "${D}${GAMES_DATADIR}"/icons
+ domenu "${D}${GAMES_DATADIR}"/applications/${PN}.desktop
+ rm -rf "${D}${GAMES_DATADIR}"/applications
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}