summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-strategy/freecol/freecol-0.10.7.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-strategy/freecol/freecol-0.10.7.ebuild')
-rw-r--r--games-strategy/freecol/freecol-0.10.7.ebuild92
1 files changed, 92 insertions, 0 deletions
diff --git a/games-strategy/freecol/freecol-0.10.7.ebuild b/games-strategy/freecol/freecol-0.10.7.ebuild
new file mode 100644
index 000000000000..e9622e427cb8
--- /dev/null
+++ b/games-strategy/freecol/freecol-0.10.7.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit base eutils java-pkg-2 java-ant-2 games
+
+DESCRIPTION="An open source clone of the game Colonization"
+HOMEPAGE="http://www.freecol.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+COMMON_DEP="dev-java/jsr173
+ dev-java/wstx:3.2
+ dev-java/commons-cli:1
+ dev-java/cortado
+ dev-java/miglayout"
+
+DEPEND=">=virtual/jdk-1.5
+ app-arch/unzip
+ ${COMMON_DEP}"
+RDEPEND=">=virtual/jre-1.5
+ ${COMMON_DEP}"
+
+S=${WORKDIR}/${PN}
+
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+
+java_prepare() {
+ cd jars
+ rm jsr173_1.0_api.jar
+ rm wstx-lgpl-4.0pr1.jar
+ rm commons-cli-1.1.jar
+ rm miglayout-3.7.3.1-swing.jar
+ rm cortado-0.6.0.jar
+ rm jogg-0.0.7.jar
+ rm jorbis-0.0.15.jar
+}
+
+src_prepare() {
+ base_src_prepare
+ java-pkg-2_src_prepare
+}
+
+src_configure() {
+ java-ant-2_src_configure
+}
+
+src_compile() {
+ EANT_BUILD_TARGET=package
+ EANT_EXTRA_ARGS="
+ -Dstax.jar=$(java-pkg_getjars jsr173)
+ -Dwoodstox.jar=$(java-pkg_getjars wstx-3.2)
+ -Dcli.jar=$(java-pkg_getjars commons-cli-1)
+ -Dmiglayout.jar=$(java-pkg_getjars miglayout)
+ -Dcortado.jar=$(java-pkg_getjars cortado)
+ "
+ java-pkg-2_src_compile
+}
+
+src_install() {
+ java-pkg_jarinto "${GAMES_DATADIR}"/${PN}/jars
+ java-pkg_dojar jars/vorbisspi1.0.3.jar
+ java-pkg_dojar jars/tritonus_share.jar
+ java-pkg_jarinto "${GAMES_DATADIR}"/${PN}
+ java-pkg_dojar FreeCol.jar
+ java-pkg_dolauncher ${PN} \
+ -into "${GAMES_PREFIX}" \
+ --pwd "${GAMES_DATADIR}"/${PN} \
+ --jar FreeCol.jar \
+ --java_args -Xmx512M
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r data schema splash.jpg
+ doicon ${PN}.xpm
+ make_desktop_entry ${PN} FreeCol
+ dodoc README
+ prepgamesdirs
+}
+
+pkg_setup() {
+ games_pkg_setup
+ java-pkg-2_pkg_setup
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ java-pkg-2_pkg_preinst
+}