summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-strategy/netherearth
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-strategy/netherearth')
-rw-r--r--games-strategy/netherearth/Manifest2
-rw-r--r--games-strategy/netherearth/files/Makefile20
-rw-r--r--games-strategy/netherearth/files/netherearth-0.52-freeglut.patch18
-rw-r--r--games-strategy/netherearth/files/netherearth-0.52-gentoo-paths.patch139
-rw-r--r--games-strategy/netherearth/files/netherearth-0.52-glibc-212.patch23
-rw-r--r--games-strategy/netherearth/files/netherearth-0.52-ldflags.patch8
-rw-r--r--games-strategy/netherearth/files/netherearth-0.52-linux.patch47
-rw-r--r--games-strategy/netherearth/metadata.xml11
-rw-r--r--games-strategy/netherearth/netherearth-0.52.ebuild81
9 files changed, 349 insertions, 0 deletions
diff --git a/games-strategy/netherearth/Manifest b/games-strategy/netherearth/Manifest
new file mode 100644
index 000000000000..8d50b29f57ae
--- /dev/null
+++ b/games-strategy/netherearth/Manifest
@@ -0,0 +1,2 @@
+DIST netherearth052.zip 872397 SHA256 79d533a56b4939a402edd7665f234e7f462e68b00ea36d9ae110f02a36357caf SHA512 1f2cb3e896ac076c5ed3d346f19d8328b879546c4dc58609251bdbc8fd96b201cbc5dcb400df2a0dd4c717c7be002f83b92acf33f607890fa736b572c72a8cf5 WHIRLPOOL ac0862bfe148b6fbd2f51e559d5b3488b4a4234008566bfecf2153ff82d7bd2decce510deeb0933bc5852da7bc506b624a32e551f7ae32987146644d3c12db85
+DIST sources.zip 75918 SHA256 0d4f80f5d3f73e957ccb7c292dcc830b88cb5624aa086ea3416522a8a66b766f SHA512 8daa9def65f4be8a541df15c69531da84344906e0f3eab2b7e84f8a94e2f3278d2033e37a9edd4b17fc19b1f7fbf3537286a2a2a9877950d19a51a1167487b75 WHIRLPOOL 755d398586edabe01c9fd299b14e6534b42aecf212332bf00fbca87c9a11a2710a5ad1cf750508d26c98aa34dc71cee5d99aaf7fe5952a89346fcf058553b679
diff --git a/games-strategy/netherearth/files/Makefile b/games-strategy/netherearth/files/Makefile
new file mode 100644
index 000000000000..07c671a10e31
--- /dev/null
+++ b/games-strategy/netherearth/files/Makefile
@@ -0,0 +1,20 @@
+# ls *.cpp
+#
+#3dobject-ase.cpp construction.cpp maps.cpp netherdebug.cpp radar.cpp
+#3dobject.cpp enemy_ai.cpp menu.cpp nethersave.cpp robot_ai.cpp
+#bitmap.cpp glprintf.cpp myglutaux.cpp particles.cpp robots.cpp
+#bullet.cpp main.cpp nether.cpp piece3dobject.cpp shadow3dobject.cpp
+#cmc.cpp mainmenu.cpp nethercycle.cpp quaternion.cpp vector.cpp
+
+
+SOURCES = 3dobject-ase.cpp 3dobject.cpp cmc.cpp nether.cpp piece3dobject.cpp vector.cpp bitmap.cpp bullet.cpp glprintf.cpp main.cpp mainmenu.cpp maps.cpp menu.cpp myglutaux.cpp nethercycle.cpp netherdebug.cpp nethersave.cpp particles.cpp construction.cpp quaternion.cpp radar.cpp enemy_ai.cpp robot_ai.cpp robots.cpp shadow3dobject.cpp
+OBJECTS = $(SOURCES:.cpp=.o)
+TARGET = nether_earth
+
+.cpp.o:
+ g++ ${CXXFLAGS} -c $< -o $@
+
+all: $(TARGET)
+
+$(TARGET): $(OBJECTS)
+ g++ $(OBJECTS) -o $(TARGET) -lGL -lGLU -lglut -lSDL -lSDL_mixer -lpthread
diff --git a/games-strategy/netherearth/files/netherearth-0.52-freeglut.patch b/games-strategy/netherearth/files/netherearth-0.52-freeglut.patch
new file mode 100644
index 000000000000..0fc147f0b7aa
--- /dev/null
+++ b/games-strategy/netherearth/files/netherearth-0.52-freeglut.patch
@@ -0,0 +1,18 @@
+--- main.cpp
++++ main.cpp
+@@ -8,6 +8,7 @@
+
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <GL/glut.h>
+ #include "SDL/SDL.h"
+ #include "SDL/SDL_mixer.h"
+
+@@ -144,6 +145,7 @@
+ bool quit = false;
+
+ load_configuration();
++ glutInit(&argc, argv);
+
+ screen_sfc = initialization((fullscreen ? SDL_FULLSCREEN : 0));
+ if (screen_sfc==0) return 0;
diff --git a/games-strategy/netherearth/files/netherearth-0.52-gentoo-paths.patch b/games-strategy/netherearth/files/netherearth-0.52-gentoo-paths.patch
new file mode 100644
index 000000000000..25f99be50fab
--- /dev/null
+++ b/games-strategy/netherearth/files/netherearth-0.52-gentoo-paths.patch
@@ -0,0 +1,139 @@
+diff -ud ../NetherEarth_v0.51-linsrc.orig/3dobject-ase.cpp ./3dobject-ase.cpp
+--- ../NetherEarth_v0.51-linsrc.orig/3dobject-ase.cpp 2002-10-26 00:00:00.000000000 +0300
++++ ./3dobject-ase.cpp 2004-04-16 21:42:55.000000000 +0300
+@@ -34,7 +34,7 @@
+ char buffer[256];
+ FILE *fp;
+
+- fp=fopen(file,"r+");
++ fp=fopen(file,"r");
+ if (fp==NULL) return false;
+
+ /* Look for the materials: */
+diff -ud ../NetherEarth_v0.51-linsrc.orig/3dobject.cpp ./3dobject.cpp
+--- ../NetherEarth_v0.51-linsrc.orig/3dobject.cpp 2004-01-06 20:49:00.000000000 +0200
++++ ./3dobject.cpp 2004-04-16 21:43:44.000000000 +0300
+@@ -74,7 +74,7 @@
+
+ int *smooth;
+
+- fp=fopen(file,"r+");
++ fp=fopen(file,"r");
+ if (fp==NULL) return false;
+
+ /* Importar un fichero .ASC de 3DStudio */
+diff -ud ../NetherEarth_v0.51-linsrc.orig/bitmap.cpp ./bitmap.cpp
+--- ../NetherEarth_v0.51-linsrc.orig/bitmap.cpp 2004-01-06 20:49:00.000000000 +0200
++++ ./bitmap.cpp 2004-04-16 21:45:13.000000000 +0300
+@@ -14,7 +14,7 @@
+ g=0;
+ b=0;
+
+- fp=fopen(file,"rb+");
++ fp=fopen(file,"rb");
+ if (fp==NULL) return;
+
+ /* Tag: */
+diff -ud ../NetherEarth_v0.51-linsrc.orig/mainmenu.cpp ./mainmenu.cpp
+--- ../NetherEarth_v0.51-linsrc.orig/mainmenu.cpp 2004-01-06 20:50:00.000000000 +0200
++++ ./mainmenu.cpp 2004-04-16 21:14:14.000000000 +0300
+@@ -6,6 +6,9 @@
+ #include <dirent.h>
+ #endif
+
++#include <stdlib.h>
++#include <fcntl.h>
++#include <unistd.h>
+ #include "string.h"
+ #include "stdio.h"
+ #include "math.h"
+@@ -483,8 +486,10 @@
+ {
+ int v;
+ FILE *fp;
++ char cfg_path[300];
+
+- fp=fopen("nether.cfg","r");
++ sprintf(cfg_path, "%s/.netherearth/nether.cfg", getenv("HOME"));
++ fp=fopen(cfg_path,"r");
+ if (fp==0) return;
+
+ if (2!=fscanf(fp,"%i %i",&SCREEN_X,&SCREEN_Y)) return;
+@@ -510,8 +515,12 @@
+ void save_configuration(void)
+ {
+ FILE *fp;
++ char cfg_path[300];
+
+- fp=fopen("nether.cfg","w");
++ sprintf(cfg_path, "%s/.netherearth", getenv("HOME"));
++ mkdir(cfg_path, 0755);
++ sprintf(cfg_path, "%s/.netherearth/nether.cfg", getenv("HOME"));
++ fp=fopen(cfg_path,"w");
+ if (fp==0) return;
+
+ fprintf(fp,"%i %i\n",SCREEN_X,SCREEN_Y);
+diff -ud ../NetherEarth_v0.51-linsrc.orig/nether.cpp ./nether.cpp
+--- ../NetherEarth_v0.51-linsrc.orig/nether.cpp 2004-01-06 21:03:00.000000000 +0200
++++ ./nether.cpp 2004-04-16 20:54:54.000000000 +0300
+@@ -1203,7 +1203,7 @@
+ if (option_menu==(i+1)) glColor3f(1.0,0.0,0.0);
+ else glColor3f(0.5,0.5,1.0);
+ glTranslatef(0,-2,0);
+- sprintf(filename,"savedgame%i.txt",i);
++ sprintf(filename,"%s/.netherearth/savedgame%i.txt", getenv("HOME"), i);
+ fp=fopen(filename,"r");
+ if (fp==0) {
+ scaledglprintf(0.01,0.01,"SLOT%i - EMPTY",i+1);
+@@ -1232,7 +1232,7 @@
+ if (option_menu==(i+1)) glColor3f(1.0,0.0,0.0);
+ else glColor3f(0.5,0.5,1.0);
+ glTranslatef(0,-2,0);
+- sprintf(filename,"savedgame%i.txt",i);
++ sprintf(filename,"%s/.netherearth/savedgame%i.txt", getenv("HOME"), i);
+ fp=fopen(filename,"r");
+ if (fp==0) {
+ scaledglprintf(0.01,0.01,"SLOT%i - EMPTY",i+1);
+@@ -1291,7 +1291,7 @@
+ case 4:
+ {
+ char filename[80];
+- sprintf(filename,"savedgame%i.txt",option_menu-1);
++ sprintf(filename,"%s/.netherearth/savedgame%i.txt", getenv("HOME"), option_menu-1);
+ save_game(filename);
+ //save_debug_report("debugreport.txt");
+ game_state=STATE_PAUSE;
+@@ -1326,7 +1326,7 @@
+ case 4:
+ {
+ char filename[80];
+- sprintf(filename,"savedgame%i.txt",option_menu-1);
++ sprintf(filename,"%s/.netherearth/savedgame%i.txt", getenv("HOME"), option_menu-1);
+ killmenu(act_menu);
+ load_game(filename);
+ newmenu(act_menu);
+diff -ud ../NetherEarth_v0.51-linsrc.orig/nethersave.cpp ./nethersave.cpp
+--- ../NetherEarth_v0.51-linsrc.orig/nethersave.cpp 2003-09-17 00:00:00.000000000 +0300
++++ ./nethersave.cpp 2004-04-16 21:23:04.000000000 +0300
+@@ -2,6 +2,10 @@
+ #include "windows.h"
+ #endif
+
++#include <stdlib.h>
++#include <sys/types.h>
++#include <fcntl.h>
++#include <unistd.h>
+ #include "string.h"
+ #include "stdio.h"
+ #include "math.h"
+@@ -40,7 +44,10 @@
+ ROBOT *r;
+ BULLET *bul;
+ EXPLOSION *e;
++ char tmp_path[300];
+
++ sprintf(tmp_path, "%s/.netherearth", getenv("HOME"));
++ mkdir(tmp_path, 0755);
+ fp=fopen(filename,"w");
+ if (fp==0) return false;
+
diff --git a/games-strategy/netherearth/files/netherearth-0.52-glibc-212.patch b/games-strategy/netherearth/files/netherearth-0.52-glibc-212.patch
new file mode 100644
index 000000000000..813f963db4c8
--- /dev/null
+++ b/games-strategy/netherearth/files/netherearth-0.52-glibc-212.patch
@@ -0,0 +1,23 @@
+http://bugs.gentoo.org/335137
+
+--- sources/mainmenu.cpp
++++ sources/mainmenu.cpp
+@@ -3,6 +3,7 @@
+ #else
+ #include <stddef.h>
+ #include <sys/types.h>
++#include <sys/stat.h>
+ #include <dirent.h>
+ #endif
+
+--- sources/nethersave.cpp
++++ sources/nethersave.cpp
+@@ -1,5 +1,8 @@
+ #ifdef _WIN32
+ #include "windows.h"
++#else
++#include <sys/types.h>
++#include <sys/stat.h>
+ #endif
+
+ #include "string.h"
diff --git a/games-strategy/netherearth/files/netherearth-0.52-ldflags.patch b/games-strategy/netherearth/files/netherearth-0.52-ldflags.patch
new file mode 100644
index 000000000000..6b7ed3a8989c
--- /dev/null
+++ b/games-strategy/netherearth/files/netherearth-0.52-ldflags.patch
@@ -0,0 +1,8 @@
+--- Makefile.old 2010-10-12 09:30:19.000000000 +0200
++++ Makefile 2010-10-12 09:30:38.000000000 +0200
+@@ -17,4 +17,4 @@
+ all: $(TARGET)
+
+ $(TARGET): $(OBJECTS)
+- g++ $(OBJECTS) -o $(TARGET) -lGL -lGLU -lglut -lSDL -lSDL_mixer -lpthread
++ g++ $(LDFLAGS) $(OBJECTS) -o $(TARGET) -lGL -lGLU -lglut -lSDL -lSDL_mixer -lpthread
diff --git a/games-strategy/netherearth/files/netherearth-0.52-linux.patch b/games-strategy/netherearth/files/netherearth-0.52-linux.patch
new file mode 100644
index 000000000000..6c4c0d1e9733
--- /dev/null
+++ b/games-strategy/netherearth/files/netherearth-0.52-linux.patch
@@ -0,0 +1,47 @@
+diff -burN sources/glprintf.cpp sources-linux/glprintf.cpp
+--- sources/glprintf.cpp 2002-10-26 00:17:00.000000000 +0200
++++ sources-linux/glprintf.cpp 2005-06-18 18:22:54.000000000 +0200
+@@ -3,6 +3,7 @@
+ #endif
+ #include "GL/gl.h"
+
++#include "string.h"
+ #include "stdio.h"
+ #include "stdarg.h"
+ #include "GL/gl.h"
+diff -burN sources/list.h sources-linux/list.h
+--- sources/list.h 2002-10-27 12:17:00.000000000 +0100
++++ sources-linux/list.h 2005-06-18 18:21:34.000000000 +0200
+@@ -1,6 +1,9 @@
+ #ifndef GENERIC_LIST
+ #define GENERIC_LIST
+
++
++#include "stdlib.h"
++
+ /*
+ Funciones para LISTAS:
+
+diff -burN sources/maps.cpp sources-linux/maps.cpp
+--- sources/maps.cpp 2005-05-05 23:42:00.000000000 +0200
++++ sources-linux/maps.cpp 2005-06-18 18:23:05.000000000 +0200
+@@ -3,6 +3,7 @@
+ #endif
+
+ #include "stdio.h"
++#include "string.h"
+
+ #include "GL/gl.h"
+ #include "GL/glu.h"
+diff -burN sources/myglutaux.cpp sources-linux/myglutaux.cpp
+--- sources/myglutaux.cpp 2002-10-26 00:17:00.000000000 +0200
++++ sources-linux/myglutaux.cpp 2005-06-18 18:23:29.000000000 +0200
+@@ -5,6 +5,8 @@
+ #include <GL/gl.h>
+ #include "GL/glut.h"
+
++#include "string.h"
++#include "stdlib.h"
+ #include "stdio.h"
+ #include "math.h"
+ #include "vector.h"
diff --git a/games-strategy/netherearth/metadata.xml b/games-strategy/netherearth/metadata.xml
new file mode 100644
index 000000000000..7c5a4830d79e
--- /dev/null
+++ b/games-strategy/netherearth/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <longdescription lang="en">
+ Nether Earth was the very first real time strategy game. It worked on a
+ SPECTRUM machine, and only needed 48KB of RAM to work!! It has all the
+ typical elements of strategy games: resources, factories, combat units,
+ etc.
+ </longdescription>
+</pkgmetadata>
diff --git a/games-strategy/netherearth/netherearth-0.52.ebuild b/games-strategy/netherearth/netherearth-0.52.ebuild
new file mode 100644
index 000000000000..ef93d435739b
--- /dev/null
+++ b/games-strategy/netherearth/netherearth-0.52.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+MY_PV="${PV/./}"
+DESCRIPTION="A remake of the SPECTRUM game Nether Earth"
+HOMEPAGE="http://www.braingames.getput.com/nether/"
+SRC_URI="http://www.braingames.getput.com/nether/sources.zip
+ http://www.braingames.getput.com/nether/${PN}${MY_PV}.zip"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+RESTRICT="mirror bindist"
+
+RDEPEND=">=media-libs/libsdl-1.2.6-r3
+ >=media-libs/sdl-mixer-1.2.5-r1
+ media-libs/freeglut"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/sources
+
+data=../nether\ earth\ v${PV}
+
+src_unpack() {
+ unzip -LL "${DISTDIR}/${PN}${MY_PV}.zip" >/dev/null || die
+ unzip -LL "${DISTDIR}/sources.zip" >/dev/null || die
+}
+
+src_prepare() {
+ DATA_DIR=${GAMES_DATADIR}/${PN}
+
+ cp "${FILESDIR}/Makefile" . || die
+
+ # Fix compilation errors/warnings
+ epatch "${FILESDIR}"/${P}-linux.patch
+
+ epatch "${FILESDIR}"/${P}-freeglut.patch \
+ "${FILESDIR}"/${P}-glibc-212.patch \
+ "${FILESDIR}"/${P}-ldflags.patch
+
+ # Modify dirs and some fopen() permissions
+ epatch "${FILESDIR}/${P}-gentoo-paths.patch"
+ sed -i \
+ -e "s:models:${DATA_DIR}/models:" \
+ -e "s:textures:${DATA_DIR}/textures:" \
+ -e "s:maps/\*:${DATA_DIR}/maps/\*:" \
+ -e "s:\./maps:${DATA_DIR}/maps:" \
+ mainmenu.cpp || die
+ sed -i \
+ -e "s:models:${DATA_DIR}/models:g" \
+ -e "s:textures:${DATA_DIR}/textures:" \
+ -e "s:sound/:${DATA_DIR}/sound/:" \
+ nether.cpp || die
+ sed -i -e "s:maps:${DATA_DIR}/maps:" \
+ main.cpp || die
+ sed -i -e "s:textures/:${DATA_DIR}/textures/:" \
+ myglutaux.cpp || die
+
+ cd "${data}"
+ rm textures/thumbs.db
+}
+
+src_install() {
+ dogamesbin nether_earth
+
+ cd "${data}"
+
+ # Install all game data
+ insinto "${DATA_DIR}"
+ doins -r maps models sound textures
+
+ dodoc readme.txt
+
+ prepgamesdirs
+}