summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-09-24 16:42:19 +0200
committerMichał Górny <mgorny@gentoo.org>2019-09-24 16:42:40 +0200
commit79f6eb179a0a8f0a2fb611d5cf7aafe8e27dd58e (patch)
tree75304679b4b2ef82c318e31e67c6b2df542fba3f /games-strategy
parentprofiles: Drop masks for removed packages. (diff)
downloadgentoo-79f6eb179a0a8f0a2fb611d5cf7aafe8e27dd58e.tar.gz
gentoo-79f6eb179a0a8f0a2fb611d5cf7aafe8e27dd58e.tar.bz2
gentoo-79f6eb179a0a8f0a2fb611d5cf7aafe8e27dd58e.zip
games-strategy/colobot: Workaround the Ninja build problem
Call po4a early in order to provide files required for manpage builds. Those files are normally provided implicitly by dependant target call but that is not good enough for Ninja. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/colobot/colobot-0.1.12.ebuild16
-rw-r--r--games-strategy/colobot/colobot-9999.ebuild18
2 files changed, 27 insertions, 7 deletions
diff --git a/games-strategy/colobot/colobot-0.1.12.ebuild b/games-strategy/colobot/colobot-0.1.12.ebuild
index 3c3762f61521..1611ef4a1d61 100644
--- a/games-strategy/colobot/colobot-0.1.12.ebuild
+++ b/games-strategy/colobot/colobot-0.1.12.ebuild
@@ -3,8 +3,6 @@
EAPI=7
-# upstream CMakeLists.txt are buggy
-CMAKE_MAKEFILE_GENERATOR=emake
inherit cmake-utils desktop xdg-utils
DESCRIPTION="Colobot is an educational real-time strategy video game featuring 3D graphics"
@@ -18,6 +16,11 @@ KEYWORDS="~amd64"
IUSE="devbuild doc +openal test tools"
RESTRICT="!test? ( test )"
+# perl for pod2man
+BDEPEND="
+ app-text/po4a
+ dev-lang/perl
+ sys-devel/gettext"
DEPEND="
dev-games/physfs
dev-libs/boost:=
@@ -30,11 +33,18 @@ DEPEND="
media-libs/sdl2-image
media-libs/sdl2-ttf
media-sound/vorbis-tools
- sys-devel/gettext
openal? ( media-libs/openal )"
RDEPEND="${DEPEND}
games-strategy/colobot-data"
+src_prepare() {
+ cmake-utils_src_prepare
+
+ # we need to call it explicitly to help Ninja figure out the deps
+ cd desktop || die
+ po4a po4a.cfg || die
+}
+
src_configure() {
local mycmakeargs=(
-DDEV_BUILD=$(usex devbuild)
diff --git a/games-strategy/colobot/colobot-9999.ebuild b/games-strategy/colobot/colobot-9999.ebuild
index b4179756b903..49d5ea90727e 100644
--- a/games-strategy/colobot/colobot-9999.ebuild
+++ b/games-strategy/colobot/colobot-9999.ebuild
@@ -3,8 +3,6 @@
EAPI=7
-# upstream CMakeLists.txt are buggy
-CMAKE_MAKEFILE_GENERATOR=emake
inherit cmake-utils desktop git-r3 xdg-utils
DESCRIPTION="Colobot is an educational real-time strategy video game featuring 3D graphics"
@@ -12,12 +10,17 @@ HOMEPAGE="https://colobot.info/"
EGIT_REPO_URI="https://github.com/colobot/colobot"
EGIT_SUBMODULES=()
-LICENSE="GPL-3"
+LICENSE="GPL-3+"
SLOT="0"
KEYWORDS=""
IUSE="devbuild doc +openal test tools"
RESTRICT="!test? ( test )"
+# perl for pod2man
+BDEPEND="
+ app-text/po4a
+ dev-lang/perl
+ sys-devel/gettext"
DEPEND="
dev-games/physfs
dev-libs/boost:=
@@ -30,11 +33,18 @@ DEPEND="
media-libs/sdl2-image
media-libs/sdl2-ttf
media-sound/vorbis-tools
- sys-devel/gettext
openal? ( media-libs/openal )"
RDEPEND="${DEPEND}
games-strategy/colobot-data"
+src_prepare() {
+ cmake-utils_src_prepare
+
+ # we need to call it explicitly to help Ninja figure out the deps
+ cd desktop || die
+ po4a po4a.cfg || die
+}
+
src_configure() {
local mycmakeargs=(
-DDEV_BUILD=$(usex devbuild)