summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-08 10:41:32 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-08 10:56:13 +0200
commitc0ca36d4f1cf789b394dec437723b0a7774cc79d (patch)
tree91bbae0d02e8d960e10c7625cf154de7db8b1e6d /games-strategy
parentgames-strategy/colobot-data: Port to cmake.eclass (diff)
downloadgentoo-c0ca36d4f1cf789b394dec437723b0a7774cc79d.tar.gz
gentoo-c0ca36d4f1cf789b394dec437723b0a7774cc79d.tar.bz2
gentoo-c0ca36d4f1cf789b394dec437723b0a7774cc79d.zip
games-strategy/colobot: Port to cmake.eclass
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/colobot/colobot-0.1.12.ebuild6
-rw-r--r--games-strategy/colobot/colobot-9999.ebuild6
2 files changed, 6 insertions, 6 deletions
diff --git a/games-strategy/colobot/colobot-0.1.12.ebuild b/games-strategy/colobot/colobot-0.1.12.ebuild
index 7f53954e4017..89f5010924c0 100644
--- a/games-strategy/colobot/colobot-0.1.12.ebuild
+++ b/games-strategy/colobot/colobot-0.1.12.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils desktop xdg-utils
+inherit cmake desktop xdg-utils
DESCRIPTION="Colobot is an educational real-time strategy video game featuring 3D graphics"
HOMEPAGE="https://colobot.info/"
@@ -43,7 +43,7 @@ PATCHES=(
)
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
# we need to call it explicitly to help Ninja figure out the deps
cd desktop || die
@@ -60,7 +60,7 @@ src_configure() {
-DCOLOBOT_INSTALL_BIN_DIR="${EPREFIX}"/usr/bin
-DCOLOBOT_INSTALL_LIB_DIR="${EPREFIX}"/usr/$(get_libdir)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
pkg_postinst() {
diff --git a/games-strategy/colobot/colobot-9999.ebuild b/games-strategy/colobot/colobot-9999.ebuild
index 49d5ea90727e..83f1bba5279d 100644
--- a/games-strategy/colobot/colobot-9999.ebuild
+++ b/games-strategy/colobot/colobot-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils desktop git-r3 xdg-utils
+inherit cmake desktop git-r3 xdg-utils
DESCRIPTION="Colobot is an educational real-time strategy video game featuring 3D graphics"
HOMEPAGE="https://colobot.info/"
@@ -38,7 +38,7 @@ RDEPEND="${DEPEND}
games-strategy/colobot-data"
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
# we need to call it explicitly to help Ninja figure out the deps
cd desktop || die
@@ -55,7 +55,7 @@ src_configure() {
-DCOLOBOT_INSTALL_BIN_DIR="${EPREFIX}"/usr/bin
-DCOLOBOT_INSTALL_LIB_DIR="${EPREFIX}"/usr/$(get_libdir)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
pkg_postinst() {