summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2021-10-16 15:56:40 +0200
committerIonen Wolkens <ionen@gentoo.org>2021-10-20 23:38:19 -0400
commitdd2c4782fed467879fc5f3a57f902c560920a136 (patch)
tree693e3866578430c3f1ff54cd194dd075e731b471 /games-strategy
parentsys-power/powertop: Stabilize 2.14 ppc, #819069 (diff)
downloadgentoo-dd2c4782fed467879fc5f3a57f902c560920a136.tar.gz
gentoo-dd2c4782fed467879fc5f3a57f902c560920a136.tar.bz2
gentoo-dd2c4782fed467879fc5f3a57f902c560920a136.zip
games-strategy/tornado: EAPI8 bump, minor improvements
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/tornado/tornado-1.4-r3.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/games-strategy/tornado/tornado-1.4-r3.ebuild b/games-strategy/tornado/tornado-1.4-r3.ebuild
new file mode 100644
index 000000000000..082cbe239409
--- /dev/null
+++ b/games-strategy/tornado/tornado-1.4-r3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Clone of a C64 game - destroy the opponent's house"
+HOMEPAGE="https://github.com/kouya/tornado"
+SRC_URI="https://github.com/kouya/tornado/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND="
+ acct-group/gamestat
+ sys-libs/ncurses:=
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-r2-gentoo.patch
+)
+
+src_configure() {
+ if ! use nls; then
+ sed -i \
+ -e '/^all:/s|locales||g' \
+ -e '/^install:/s|install-locale-data||g' \
+ Makefile || die
+ fi
+
+ tc-export CC PKG_CONFIG
+}
+
+src_install() {
+ default
+
+ fowners :gamestat /usr/bin/${PN} /var/games/${PN}.scores
+ fperms g+s /usr/bin/${PN}
+ fperms 660 /var/games/${PN}.scores
+}