summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-10-17 09:57:58 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-10-17 11:04:20 +0200
commit4bd158c8fcf38d600930b36d90dd8afebf130e51 (patch)
treec298df4ee8ac25465090d9b695448d80f9a98477 /games-util/joystick
parentnet-misc/nextcloud-client: version bump to 2.2.4, bug #597104 (diff)
downloadgentoo-4bd158c8fcf38d600930b36d90dd8afebf130e51.tar.gz
gentoo-4bd158c8fcf38d600930b36d90dd8afebf130e51.tar.bz2
gentoo-4bd158c8fcf38d600930b36d90dd8afebf130e51.zip
games-util/joystick: Bump to version 1.6.0
Package-Manager: portage-2.3.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'games-util/joystick')
-rw-r--r--games-util/joystick/Manifest1
-rw-r--r--games-util/joystick/files/joystick-1.6.0-build.patch34
-rw-r--r--games-util/joystick/joystick-1.6.0.ebuild43
3 files changed, 78 insertions, 0 deletions
diff --git a/games-util/joystick/Manifest b/games-util/joystick/Manifest
index 5a7bd1e54c06..15712374afa8 100644
--- a/games-util/joystick/Manifest
+++ b/games-util/joystick/Manifest
@@ -1,2 +1,3 @@
DIST linuxconsoletools-1.4.8.tar.bz2 43964 SHA256 23c4ac595f608e25f472d947c4193233f763f37ae0cf6b48141d33443a4cee6a SHA512 ea3a0baa3f163e10a4c76f58977a96d91d91bddb1a75cea5195b0a631c11ca55e40730aaa0d1965404837595c4a7fd8b75c3dd7785fe0e47ee2c90021341f262 WHIRLPOOL c02960d5e171efef3739f440a903ae9b14bec8b6ab4de2181ea691aa78c870f81b291ac98e313d234778fb59c4be8e53242cb46db019f3dffdbd8f26ddcbb113
DIST linuxconsoletools-1.5.1.tar.bz2 50015 SHA256 0bd07aacea251d63d3d8a458728c7f965f41ae45891d906cefedc3fde0753b1e SHA512 41e306ab8a09c3cf05da683c48628b3ffa73f077375391024b5d2bdc53d3baddcc650fe366dc7a3ec605459440a181013b2eff0921854895ba74cb644d70b5eb WHIRLPOOL ffc06f85125e3f478fa3ded3bbac262fac791314e2548f8ad9dce97167ac0865acf6c4eb5292184eb7725b6145e1438731d5dddb30affcc3cfb4f39de1badd56
+DIST linuxconsoletools-1.6.0.tar.bz2 50563 SHA256 ced2efed00b67b45f82eddc69be07385835d558f658016315ac621fe2eaa8146 SHA512 35ca923cceca729bcbab95dff18682abd0d87a297e70aa8707fbabccde018fef0775a99195af4bf9111ba33210a14c10d1a766f83112cd535930a1ae430c7c75 WHIRLPOOL d7f658e3edc2936cb68df59bf479519bd631606ec93c2d679690aa901b0279812d0ad316d524e4a866360a5c3f7eb10da1bccbd05693b10072b5a18ea4ee273f
diff --git a/games-util/joystick/files/joystick-1.6.0-build.patch b/games-util/joystick/files/joystick-1.6.0-build.patch
new file mode 100644
index 000000000000..fa60ec719917
--- /dev/null
+++ b/games-util/joystick/files/joystick-1.6.0-build.patch
@@ -0,0 +1,34 @@
+--- linuxconsoletools-1.6.0/docs/Makefile
++++ linuxconsoletools-1.6.0/docs/Makefile
+@@ -20,9 +20,13 @@
+ # 02110-1301 USA.
+
+ MANPAGES = inputattach.1 jstest.1 jscal.1 fftest.1 \
+- ffmvforce.1 ffset.1 ffcfstress.1 jscal-store.1 \
++ ffset.1 ffcfstress.1 jscal-store.1 \
+ jscal-restore.1 evdev-joystick.1
+
++ifneq ($(USE_SDL),no)
++MANPAGES += ffmvforce.1
++endif
++
+ PREFIX ?= /usr/local
+
+ install:
+--- linuxconsoletools-1.6.0/utils/Makefile
++++ linuxconsoletools-1.6.0/utils/Makefile
+@@ -27,9 +27,13 @@
+
+ CFLAGS ?= -g -O2 -Wall
+
+-PROGRAMS = inputattach jstest jscal fftest ffmvforce ffset \
++PROGRAMS = inputattach jstest jscal fftest ffset \
+ ffcfstress jscal-restore jscal-store evdev-joystick
+
++ifneq ($(USE_SDL),no)
++PROGRAMS += ffmvforce
++endif
++
+ PREFIX ?= /usr/local
+
+ compile: $(PROGRAMS)
diff --git a/games-util/joystick/joystick-1.6.0.ebuild b/games-util/joystick/joystick-1.6.0.ebuild
new file mode 100644
index 000000000000..7ce51eda084b
--- /dev/null
+++ b/games-util/joystick/joystick-1.6.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils toolchain-funcs
+
+MY_P="linuxconsoletools-${PV}"
+DESCRIPTION="joystick testing utilities"
+HOMEPAGE="https://sourceforge.net/projects/linuxconsole/ http://atrey.karlin.mff.cuni.cz/~vojtech/input/"
+SRC_URI="mirror://sourceforge/linuxconsole/files/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="sdl udev"
+
+DEPEND="sdl? ( media-libs/libsdl:0[video] )
+ !<x11-libs/tslib-1.0-r2"
+RDEPEND="${DEPEND}
+ udev? ( virtual/udev )"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.6.0-build.patch
+ "${FILESDIR}"/${PN}-1.4.8-udev.patch
+)
+
+src_prepare() {
+ default
+
+ export PREFIX=/usr
+ tc-export CC PKG_CONFIG
+ export USE_SDL=$(usex sdl)
+}
+
+src_install() {
+ default
+ if use !udev ; then
+ rm "${D}"/usr/bin/jscal-{re,}store || die
+ fi
+}