summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-04-15 14:58:43 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-04-15 16:54:07 +0200
commit1ff05321a57b352f5d477f8fb8e39f869267ad9f (patch)
tree01ea45eba3d5c97d564bb1ab09694c741ddf14fe /games-util
parentgames-simulation/openttd: Removed old. (diff)
downloadgentoo-1ff05321a57b352f5d477f8fb8e39f869267ad9f.tar.gz
gentoo-1ff05321a57b352f5d477f8fb8e39f869267ad9f.tar.bz2
gentoo-1ff05321a57b352f5d477f8fb8e39f869267ad9f.zip
games-util/lutris: Bump to version 0.5.2.1
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'games-util')
-rw-r--r--games-util/lutris/Manifest1
-rw-r--r--games-util/lutris/lutris-0.5.2.1.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/games-util/lutris/Manifest b/games-util/lutris/Manifest
index 0a1d9fb9ec30..f0ed53d27cb6 100644
--- a/games-util/lutris/Manifest
+++ b/games-util/lutris/Manifest
@@ -1,2 +1,3 @@
DIST lutris_0.5.1.2.tar.xz 1741512 BLAKE2B b6e5d698222d073cf8062235c17b972264a0063632c0e75076c0ac085fe4ada6c5640254c4d346463ca2e0bb60e9e84b189bda7c390b7db374f2fcee605de1c6 SHA512 e6eba2bde00f597d2985923a5151ad1b8cbbcfe69845448d53b1d41d8129b72c3d679894babd56f64a6190e2d2265a924bb93eb1c65b29037214674738481909
+DIST lutris_0.5.2.1.tar.xz 1742968 BLAKE2B 676f5019260714ab5205366f51a5911e0459f353f6debead49fded4bc8c764b0e621a86b98c7663df2cd9fd3c59c23944d516f8991cd455c271b10ef02c485eb SHA512 1aaf69be8bdfb72a427e10c4c73ad06c80ebda59a5dd0bfc6d484240250160770854ad28698d3d60af1e3f19b58ade973ab688c6416169df3a4c6ab3c0981301
DIST lutris_0.5.2.tar.xz 1742940 BLAKE2B 2fa8a0534c50e02457285e1e1e0ecfe39607ba68b6a8f0f25be1a5b7b8f0809fc0f048758b80e8305aff22b4034eaf8a2b4e717e37c34f3b78024ea60322fef2 SHA512 d2b22e56031ec25e94eb7cb28157cac65f71638ee24a8bba78f30af778f432c52a78ae2d4134a869aaf5e97d6229107d2b9abc474290b7f15ca3bfa7c8e1f66f
diff --git a/games-util/lutris/lutris-0.5.2.1.ebuild b/games-util/lutris/lutris-0.5.2.1.ebuild
new file mode 100644
index 000000000000..2da144c4dbb7
--- /dev/null
+++ b/games-util/lutris/lutris-0.5.2.1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{4,5,6,7} )
+PYTHON_REQ_USE="sqlite,threads(+)"
+
+inherit distutils-r1 virtualx xdg
+
+DESCRIPTION="An open source gaming platform for GNU/Linux"
+HOMEPAGE="https://lutris.net/"
+
+if [[ ${PV} == *9999* ]] ; then
+ EGIT_REPO_URI="https://github.com/lutris/lutris.git"
+ inherit git-r3
+else
+ SRC_URI="https://lutris.net/releases/${P/-/_}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${PN}"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+BDEPEND="
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+RDEPEND="
+ app-arch/cabextract
+ app-arch/p7zip
+ app-arch/unrar
+ app-arch/unzip
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/python-evdev[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ gnome-base/gnome-desktop[introspection]
+ media-sound/fluid-soundfont
+ net-libs/libsoup
+ net-libs/webkit-gtk:4[introspection]
+ x11-apps/mesa-progs
+ x11-apps/xgamma
+ x11-apps/xrandr
+ x11-libs/gtk+:3[introspection]
+ x11-libs/libnotify
+"
+
+python_install_all() {
+ local DOCS=( AUTHORS README.rst docs/installers.rst )
+ distutils-r1_python_install_all
+}
+
+python_test() {
+ virtx nosetests -v || die
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ # Quote README.rst
+ elog "Lutris installations are fully automated through scripts, which can"
+ elog "be written in either JSON or YAML. The scripting syntax is described"
+ elog "in ${EROOT}/usr/share/doc/${PF}/installers.rst.bz2, and is also"
+ elog "available online at lutris.net."
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+}