summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOursDesCavernes <totocoq@yahoo.fr>2019-01-13 22:41:43 +0100
committerPatrice Clement <monsieurp@gentoo.org>2019-01-17 09:53:54 +0100
commite6932f6e3fc351caa71fef1c1ab7f2e51a6e9c20 (patch)
tree2cb2abe47c8217f8b9a34acd81a3efd0d327d00c /games-util
parentapp-misc/mosquitto: version bump to 1.5.5. (diff)
downloadgentoo-e6932f6e3fc351caa71fef1c1ab7f2e51a6e9c20.tar.gz
gentoo-e6932f6e3fc351caa71fef1c1ab7f2e51a6e9c20.tar.bz2
gentoo-e6932f6e3fc351caa71fef1c1ab7f2e51a6e9c20.zip
games-util/springlobby: version bump to 0.267.
Signed-off-by: Thomas Coquelin <totocoq@yahoo.fr> Closes: https://bugs.gentoo.org/673848 Package-Manager: Portage-2.3.51, Repoman-2.3.11 Closes: https://github.com/gentoo/gentoo/pull/10830 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'games-util')
-rw-r--r--games-util/springlobby/Manifest1
-rw-r--r--games-util/springlobby/springlobby-0.267.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/games-util/springlobby/Manifest b/games-util/springlobby/Manifest
index bf0204143ef8..87dde623bbe7 100644
--- a/games-util/springlobby/Manifest
+++ b/games-util/springlobby/Manifest
@@ -1 +1,2 @@
DIST springlobby-0.266.tar.bz2 2642384 BLAKE2B 93444df4e139a657dc5d87b0ea9e796bd025259663693de9dcb04760ee611674546170813d71406e94aa456834cc96c8bc811ee5cf65b0bd0199cf66b4a51a50 SHA512 dc1a5e408515cb82004bf66bc014ebdd451eaea07d3543094cec494beb6d87165bdc0ac3672d6474a13d1918b1405507ee97ead05b9f1663789416b072aa6d6b
+DIST springlobby-0.267.tar.bz2 2642229 BLAKE2B 591eddda344ea4ce4ed7cad433bd7d46c7b2e727d7f97c07541cc00c6991fb1a9a62e8980f6a0249e6a509e475fe300aeb040ff1886f2da77b176b52d196db90 SHA512 6127bd7377f9a843b23df6dae7a07af1122f6ec5fa13cd8d16c0c7a3cc84e1f7af2fb7df929f904ee0b4e3abf12ae1e525ffb39b2afa0215433209054cf0de5f
diff --git a/games-util/springlobby/springlobby-0.267.ebuild b/games-util/springlobby/springlobby-0.267.ebuild
new file mode 100644
index 000000000000..cd52d8460241
--- /dev/null
+++ b/games-util/springlobby/springlobby-0.267.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+WX_GTK_VER="3.0"
+inherit cmake-utils gnome2-utils wxwidgets
+
+DESCRIPTION="The official lobby client for SpringRTS community games"
+HOMEPAGE="https://springlobby.info"
+SRC_URI="https://www.springlobby.info/tarballs/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +libnotify +nls +sound"
+
+RDEPEND="
+ >=dev-libs/boost-1.35:=
+ dev-libs/openssl:0=
+ net-misc/curl
+ sys-libs/zlib[minizip]
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libXext
+ x11-libs/wxGTK:${WX_GTK_VER}[X]
+ libnotify? ( x11-libs/libnotify )
+ sound? ( media-libs/alure
+ media-libs/openal
+ )
+"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+"
+
+src_configure() {
+ setup-wxwidgets
+ local mycmakeargs=(
+ -DOPTION_NOTIFY=$(usex libnotify)
+ -DOPTION_SOUND=$(usex sound)
+ -DOPTION_TRANSLATION_SUPPORT=$(usex nls)
+ -DAUX_VERSION="(Gentoo,${ARCH})"
+ )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}