summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /gnome-base/gnome-menus/gnome-menus-3.10.1-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'gnome-base/gnome-menus/gnome-menus-3.10.1-r1.ebuild')
-rw-r--r--gnome-base/gnome-menus/gnome-menus-3.10.1-r1.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/gnome-base/gnome-menus/gnome-menus-3.10.1-r1.ebuild b/gnome-base/gnome-menus/gnome-menus-3.10.1-r1.ebuild
new file mode 100644
index 000000000000..3c28a21659b4
--- /dev/null
+++ b/gnome-base/gnome-menus/gnome-menus-3.10.1-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit eutils gnome2
+
+DESCRIPTION="Library for the Desktop Menu fd.o specification"
+HOMEPAGE="https://git.gnome.org/browse/gnome-menus"
+SRC_URI="${SRC_URI}
+ http://dev.gentoo.org/~tetromino/distfiles/${PN}/${PN}-3.10.1-patches.tar.xz"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="3"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ppc ~ppc64 ~sh ~sparc x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+
+IUSE="debug +introspection test"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.29.15:2
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
+"
+# Older versions of slot 0 install the menu editor and the desktop directories
+
+RDEPEND="${COMMON_DEPEND}
+ !<gnome-base/gnome-menus-3.0.1-r1:0
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.40
+ sys-devel/gettext
+ virtual/pkgconfig
+ test? ( dev-libs/gjs )
+"
+
+src_prepare() {
+ # Don't show KDE standalone settings desktop files in GNOME others menu
+ epatch "${FILESDIR}/${PN}-3.8.0-ignore_kde_standalone.patch"
+
+ # Fixes for crashes and memory leaks from upstream git master
+ epatch ../"${PN}-3.10.1-patches"/*.patch
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog HACKING NEWS README"
+
+ # Do NOT compile with --disable-debug/--enable-debug=no
+ # It disables api usage checks
+ gnome2_src_configure \
+ $(usex debug --enable-debug=yes --enable-debug=minimum) \
+ $(use_enable introspection) \
+ --disable-static
+}