summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Konotopov <ykonotopov@gnome.org>2018-02-05 00:10:03 +0400
committerPatrice Clement <monsieurp@gentoo.org>2018-02-17 16:26:09 +0100
commit3848050dd44e0c16763ab62bdb9c2cf8e0bb569d (patch)
tree2e7189e36ab06a25bd9668381d2aae6f98ddc986 /gnome-extra
parentgnome-extra/chrome-gnome-shell: drop old. (diff)
downloadgentoo-3848050dd44e0c16763ab62bdb9c2cf8e0bb569d.tar.gz
gentoo-3848050dd44e0c16763ab62bdb9c2cf8e0bb569d.tar.bz2
gentoo-3848050dd44e0c16763ab62bdb9c2cf8e0bb569d.zip
gnome-extra/chrome-gnome-shell: version bump.
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/chrome-gnome-shell/Manifest1
-rw-r--r--gnome-extra/chrome-gnome-shell/chrome-gnome-shell-10.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/gnome-extra/chrome-gnome-shell/Manifest b/gnome-extra/chrome-gnome-shell/Manifest
index 138c6e028b70..ea2790636d55 100644
--- a/gnome-extra/chrome-gnome-shell/Manifest
+++ b/gnome-extra/chrome-gnome-shell/Manifest
@@ -1,2 +1,3 @@
+DIST chrome-gnome-shell-10.tar.xz 158972 BLAKE2B fe4df942f885aee40d5c5e01dcd127a9deb46aeb57765336c91a7a9c56f7c953eb36d822ffa821300b99e3d765c1b162767fc5debc24e42a16bddb1404796c9c SHA512 cf0d108c3fb57deb4926a4cf043dd64d776eda4c01ec595a1472c6c45726b8460381b9bd7cb1b43d7a5bd8a585be0d1b648c720a2f0a7a377c133b8750e76cd6
DIST chrome-gnome-shell-8.tar.xz 143224 BLAKE2B 9dcb94f7dcc263c6cc332c476bd652b0ea62443ffb154f67ba869ddc970e892a28ef96be13732d49dfbf5c3db9c4c8fed18918359f240e6b1b6218fa3a2bd462 SHA512 61acd4b0564892667bd1468430ddfff4c0cfbe92b573d8b7e4c5448c25266bd0ee6e89e9bebe08553de4f9661ceeea46f5af38d980051491c40ed7deb24e3277
DIST chrome-gnome-shell-9.tar.xz 151984 BLAKE2B 884906a308d864893664f499172c130b6ab7cc3ae7a5746f7430f3d779f43320de723c9757fc4c8a9328704b2b5c40c8a829d74280ac78d4f09e000f593c3805 SHA512 b9b5f913a74bdfa641ce35c62f15aa1ceff37e6e0fef43c127ff8ba31933ba2d9c93ee50809b013336ec63ae1020d4e1cacd56d9a86204e1ba4c0bd1d8ed50cf
diff --git a/gnome-extra/chrome-gnome-shell/chrome-gnome-shell-10.ebuild b/gnome-extra/chrome-gnome-shell/chrome-gnome-shell-10.ebuild
new file mode 100644
index 000000000000..09548f73bbc3
--- /dev/null
+++ b/gnome-extra/chrome-gnome-shell/chrome-gnome-shell-10.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit cmake-utils python-single-r1
+
+DESCRIPTION="GNOME Shell integration for Chrome/Chromium, Firefox, Vivaldi, Opera browsers"
+HOMEPAGE="https://wiki.gnome.org/Projects/GnomeShellIntegrationForChrome"
+SRC_URI="mirror://gnome/sources/${PN}/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ app-misc/jq
+ sys-apps/coreutils
+"
+RDEPEND="${PYTHON_DEPS}
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ gnome-base/gnome-shell
+"
+
+src_configure() {
+ local mycmakeargs=( -DBUILD_EXTENSION=OFF )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ elog "Please note that this package provides native messaging connector only."
+ elog "You can install browser extension using link provided at"
+ elog "https://extensions.gnome.org website."
+}