summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUwe Scholz <uwescholz@src.gnome.org>2017-10-08 18:49:20 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-10-28 00:48:32 +0200
commit680bf7fcbbde95deec30a85e37d156e0bdc04fc2 (patch)
tree63120edde732695cf970d3a878b1ed30cf956e47 /gnome-extra
parentgnome-extra/gnome-commander: clean up old. (diff)
downloadgentoo-680bf7fcbbde95deec30a85e37d156e0bdc04fc2.tar.gz
gentoo-680bf7fcbbde95deec30a85e37d156e0bdc04fc2.tar.bz2
gentoo-680bf7fcbbde95deec30a85e37d156e0bdc04fc2.zip
gnome-extra/gnome-commander: version bump to 1.6.4 and 1.8.0.
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-commander/Manifest2
-rw-r--r--gnome-extra/gnome-commander/gnome-commander-1.6.4.ebuild70
-rw-r--r--gnome-extra/gnome-commander/gnome-commander-1.8.0.ebuild69
3 files changed, 141 insertions, 0 deletions
diff --git a/gnome-extra/gnome-commander/Manifest b/gnome-extra/gnome-commander/Manifest
index 753bf5016aaa..55522f1d952c 100644
--- a/gnome-extra/gnome-commander/Manifest
+++ b/gnome-extra/gnome-commander/Manifest
@@ -1,2 +1,4 @@
DIST gnome-commander-1.6.1.tar.xz 6550308 SHA256 9f796c65b17e7d3a125e8298638d16d3b0ba7ea155371d7b8d413e7f8b4aeee0 SHA512 717e8bb560c6c7e6505cfee1d9ab12f7b3d5c2f8131b9eaf8b15e13aa71dad85574b14ae6f3a42dae42d8a6a291d33cd71db5a4155184bec4f66e3db8b2daab0 WHIRLPOOL 7569ec3bf275754022a19830871bde6139363c1a3d2e1792cff678cee79674d7a6022ba8fa678f9e48a79bebcf36acfd08c75db4f9e3c457e668a2e68c88c1f0
DIST gnome-commander-1.6.3.tar.xz 6653164 SHA256 9ac8b0041b0b2648252d461776e2be65e87f2fc52b027815c8c93c9b448f7cb5 SHA512 92f138c3cff1b88b967340f945bfa58c5840fb3db806943b4d4eb87211fea10de01a8a365de6ca2b18cb0503bd850e758c3a37fe604b5402481c03e953e94dd3 WHIRLPOOL 6f907a807b0a72e09456216f734b5a10213498c1d06d9b08a0d783035fa83433d8c8959f8c4946ce9ddba0aa2435cc742a8cb038a2d1679ae2c72a1539137307
+DIST gnome-commander-1.6.4.tar.xz 6678752 SHA256 d1c5de5245a4852f8aa86e5283530674ec3fc3a5312bd89305c9934718b90b3d SHA512 00fcf86025b69a38e68b2c69977ffe54e8b00028176163ce746824a73faed55eeff2fe37eea2e191fd0e7fc1901e2ed701938c3fdfabe9e9b8bdaaec152df0e0 WHIRLPOOL b42e6d1ea2b7eb0d7d51c9f4c9686f62761c0aecea04e71a2580f3dbf3bdd3f292345b621570e8d0f59af3aef7833f4550d577c057be131fe99aa0c96be1700b
+DIST gnome-commander-1.8.0.tar.xz 7433656 SHA256 d0e73077fe22ae1e00d93f0112e0e019cf40b15419dfa82e51c9d5f30849946b SHA512 0023528301812431bffde4c0d314d07d2399d450604bf88426078cfbeed5ee286f16ad0037f85c2b281e9037fd0c622aa92a4a5be055c198d9bdbd3d211c197d WHIRLPOOL ae31ba7cd24c8cab4c3ec991005ac89ef3852f503d7312998ee4ee2e73e7afc5fc7f62cf4edae58e3a2ea6f9ca1f3882ffb287e87c24964a096dd1177266dc0f \ No newline at end of file
diff --git a/gnome-extra/gnome-commander/gnome-commander-1.6.4.ebuild b/gnome-extra/gnome-commander/gnome-commander-1.6.4.ebuild
new file mode 100644
index 000000000000..b6b77a79acf5
--- /dev/null
+++ b/gnome-extra/gnome-commander/gnome-commander-1.6.4.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2 python-single-r1
+
+DESCRIPTION="A graphical, full featured, twin-panel file manager"
+HOMEPAGE="http://gcmd.github.io/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="chm exif gsf pdf python taglib samba test +unique"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ app-text/gnome-doc-utils
+ >=dev-libs/glib-2.44.0:2
+ unique? ( >=dev-libs/libunique-0.9.3:1 )
+ gnome-base/gnome-keyring
+ >=gnome-base/gnome-vfs-2.0.0
+ >=gnome-base/libgnome-2.0.0
+ >=gnome-base/libgnomeui-2.4.0
+ >=x11-libs/gtk+-2.8.0:2
+ chm? ( dev-libs/chmlib )
+ exif? ( >=media-gfx/exiv2-0.14 )
+ gsf? ( >=gnome-extra/libgsf-1.12.0 )
+ samba? ( >=gnome-base/gnome-vfs-2.0.0[samba] )
+ pdf? ( >=app-text/poppler-0.18 )
+ python? (
+ ${PYTHON_DEPS}
+ >=dev-python/gnome-vfs-python-2.0.0
+ )
+ taglib? ( >=media-libs/taglib-1.4 )
+"
+DEPEND="
+ ${RDEPEND}
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.35.0
+ sys-devel/gettext
+ virtual/pkgconfig
+ test? ( >=dev-cpp/gtest-1.7.0 )
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable python) \
+ $(use_with chm libchm) \
+ $(use_with exif exiv2) \
+ $(use_with gsf libgsf) \
+ $(use_with pdf poppler) \
+ $(use_with samba) \
+ $(use_with taglib) \
+ $(use_with unique)
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ has_version dev-util/meld || elog "You need dev-util/meld to synchronize files and directories."
+ has_version gnome-extra/yelp || elog "You need gnome-extra/yelp to view the docs."
+}
diff --git a/gnome-extra/gnome-commander/gnome-commander-1.8.0.ebuild b/gnome-extra/gnome-commander/gnome-commander-1.8.0.ebuild
new file mode 100644
index 000000000000..f384e8bbb34e
--- /dev/null
+++ b/gnome-extra/gnome-commander/gnome-commander-1.8.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4} )
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2 python-single-r1
+
+DESCRIPTION="A graphical, full featured, twin-panel file manager"
+HOMEPAGE="http://gcmd.github.io/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="chm exif gsf pdf python taglib samba test +unique"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ app-text/yelp-tools
+ >=dev-libs/glib-2.44.0:2
+ unique? ( >=dev-libs/libunique-0.9.3:1 )
+ gnome-base/gnome-keyring
+ >=gnome-base/gnome-vfs-2.0.0
+ >=gnome-base/libgnome-2.0.0
+ >=gnome-base/libgnomeui-2.4.0
+ >=x11-libs/gtk+-2.18.0:2
+ chm? ( dev-libs/chmlib )
+ exif? ( >=media-gfx/exiv2-0.14 )
+ gsf? ( >=gnome-extra/libgsf-1.12.0 )
+ samba? ( >=gnome-base/gnome-vfs-2.0.0[samba] )
+ pdf? ( >=app-text/poppler-0.18 )
+ python? (
+ ${PYTHON_DEPS}
+ >=dev-python/gnome-vfs-python-2.0.0
+ )
+ taglib? ( >=media-libs/taglib-1.4 )
+"
+DEPEND="
+ ${RDEPEND}
+ dev-util/gtk-doc-am
+ sys-devel/gettext
+ virtual/pkgconfig
+ test? ( >=dev-cpp/gtest-1.7.0 )
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable python) \
+ $(use_with chm libchm) \
+ $(use_with exif exiv2) \
+ $(use_with gsf libgsf) \
+ $(use_with pdf poppler) \
+ $(use_with samba) \
+ $(use_with taglib) \
+ $(use_with unique)
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ has_version dev-util/meld || elog "You need dev-util/meld to synchronize files and directories."
+ has_version gnome-extra/yelp || elog "You need gnome-extra/yelp to view the docs."
+}