summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-09-20 18:39:58 +0200
committerPacho Ramos <pacho@gentoo.org>2015-09-20 18:41:05 +0200
commit6ca488ec8bd4ee7a1279c8b3feb854c89ca4f9f7 (patch)
tree96540025457273100e97b77e4442fadf9182fb1e /gnome-extra
parentnet-nds/openldap: add libressl support (diff)
downloadgentoo-6ca488ec8bd4ee7a1279c8b3feb854c89ca4f9f7.tar.gz
gentoo-6ca488ec8bd4ee7a1279c8b3feb854c89ca4f9f7.tar.bz2
gentoo-6ca488ec8bd4ee7a1279c8b3feb854c89ca4f9f7.zip
gnome-extra/gnome-documents: Version bump
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-documents/Manifest1
-rw-r--r--gnome-extra/gnome-documents/gnome-documents-3.16.4.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/gnome-extra/gnome-documents/Manifest b/gnome-extra/gnome-documents/Manifest
index 666e2406a064..dd5a79effcf5 100644
--- a/gnome-extra/gnome-documents/Manifest
+++ b/gnome-extra/gnome-documents/Manifest
@@ -1,3 +1,4 @@
DIST gnome-documents-3.14.3.tar.xz 718680 SHA256 478faba571fb8924043a74c04efa76f9beeed93618383f8771a78d53687ed5cf SHA512 41afb559a2aff1d5f8cc6b123dcfa0bacd16cee3ab7d133ca67b0109cab350ac20f69f84ec57c380ec42a0f9533a26b73240b04b308f39ab5c7dc8e18be14ac0 WHIRLPOOL ef6471e461052b76644f0324068460d3e738f5e1c9fc0f3aaa59feab0e9689e057c8f5ba5df758340539a47f40c5566334834ea39e137b2c9453f6669ac25202
DIST gnome-documents-3.16.2.tar.xz 2276600 SHA256 ba7230f0f7bd83932e03b1c06c6b67a46f9bc2dd2a93d0193c402d60323ff4a3 SHA512 bb2b9a92a3ed62408227c6213fc68d1c7a1d953d30758dbc88814ce37c50dd870306f901671d2f43417f533527011d93bec6615cbae8de662d806c154c7b837a WHIRLPOOL 319beaa931ca2cbdd257c710f4d37e943fe838b9451200e43155a88fc58237f47d6c5da81338e3e9c6c8b1bfd0ade3dca42beb999dbf15a76a17af22daa2c743
DIST gnome-documents-3.16.3.tar.xz 2280484 SHA256 4ea2ee08421fc0d43e4daa5937f008fced477f06666c6862fe0b87fc756d633d SHA512 dadcff3e8df1d481fc80573bf4a501eb91bece367e31977c0af1754b294dc032760c182739b19e7d358cf0f9d707782f0b26124eae4dba05f72805d0d303b683 WHIRLPOOL b930d53d3df3cff2ce55b0cf4a050e686c07a3157b51ebc76bcdc146b5ba6a95922655b1ca4175f5d3220f6989b5e68c2a29f92d17735b6d2bd9489dba4edac0
+DIST gnome-documents-3.16.4.tar.xz 2282220 SHA256 f3c5374dc8be3fae77141251809b3defac5827e400f713c9a3a0b1e95e5fb895 SHA512 1f0c0344603418e6b2449f880db17ac69a4b16bf79bbb027e7a041707cecf5b8981ec7adb39783f94ac11fe1fafce8ce02f28a0b4d5f4f6a06080c2d0e23f3a0 WHIRLPOOL f94c1cb6923c16409195919c8d342bfb65c98f0117f66bf6446229e058f8dedaf5352bd6113d724880d45cd483d01acd312460a56d41ef8d84791a35125d1829
diff --git a/gnome-extra/gnome-documents/gnome-documents-3.16.4.ebuild b/gnome-extra/gnome-documents/gnome-documents-3.16.4.ebuild
new file mode 100644
index 000000000000..0d473281f20a
--- /dev/null
+++ b/gnome-extra/gnome-documents/gnome-documents-3.16.4.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="A document manager application for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Documents"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+# Need gdk-pixbuf-2.25 for gdk_pixbuf_get_pixels_with_length
+COMMON_DEPEND="
+ >=app-misc/tracker-1:=
+ >=app-text/evince-3.13.3[introspection]
+ dev-libs/gjs
+ >=dev-libs/glib-2.39.3:2
+ >=dev-libs/gobject-introspection-1.31.6:=
+ >=dev-libs/libgdata-0.13.3:=[gnome,introspection]
+ gnome-base/gnome-desktop:3=
+ >=media-libs/clutter-1.10:1.0
+ >=media-libs/clutter-gtk-1.3.2:1.0[introspection]
+ >=net-libs/gnome-online-accounts-3.2.0
+ >=net-libs/libsoup-2.41.3:2.4
+ >=net-libs/libzapojit-0.0.2
+ >=net-libs/webkit-gtk-2.6:4
+ >=x11-libs/gdk-pixbuf-2.25:2[introspection]
+ >=x11-libs/gtk+-3.15.5:3[introspection]
+ x11-libs/pango[introspection]
+"
+RDEPEND="${COMMON_DEPEND}
+ media-libs/clutter[introspection]
+ net-misc/gnome-online-miners
+ sys-apps/dbus
+ x11-themes/gnome-icon-theme-symbolic
+"
+DEPEND="${COMMON_DEPEND}
+ dev-libs/libxslt
+ >=dev-util/intltool-0.50.1
+ dev-util/itstool
+ virtual/pkgconfig
+
+ app-text/yelp-tools
+"
+# eautoreconf requires yelp-tools
+
+src_prepare() {
+ # https://bugzilla.gnome.org/show_bug.cgi?id=750334
+ epatch "${FILESDIR}"/${PN}-3.16.2-parallel-make.patch
+ eautoreconf
+ gnome2_src_prepare
+}