summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKristian Fiskerstrand <k_f@gentoo.org>2017-11-28 20:55:52 +0100
committerKristian Fiskerstrand <k_f@gentoo.org>2017-11-28 20:59:36 +0100
commit7d7c516bbf527767b3f529d2a7df35c38feb9c1a (patch)
tree06450e3e9302f285e7254686e90bdebc35d71f27 /gnome-extra
parentgnome-extra/cinnamon-screensaver: Add xinerama use flag (diff)
downloadgentoo-7d7c516bbf527767b3f529d2a7df35c38feb9c1a.tar.gz
gentoo-7d7c516bbf527767b3f529d2a7df35c38feb9c1a.tar.bz2
gentoo-7d7c516bbf527767b3f529d2a7df35c38feb9c1a.zip
gnome-extra/cinnamon-settings-daemon: Remove optional dep on upower-pm-utils
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/cinnamon-settings-daemon/cinnamon-settings-daemon-3.6.1-r1.ebuild85
1 files changed, 85 insertions, 0 deletions
diff --git a/gnome-extra/cinnamon-settings-daemon/cinnamon-settings-daemon-3.6.1-r1.ebuild b/gnome-extra/cinnamon-settings-daemon/cinnamon-settings-daemon-3.6.1-r1.ebuild
new file mode 100644
index 000000000000..d0037fe9aaf4
--- /dev/null
+++ b/gnome-extra/cinnamon-settings-daemon/cinnamon-settings-daemon-3.6.1-r1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+
+inherit autotools eutils gnome2 virtualx
+
+DESCRIPTION="Cinnamon's settings daemon"
+HOMEPAGE="http://cinnamon.linuxmint.com/"
+SRC_URI="https://github.com/linuxmint/cinnamon-settings-daemon/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+colord cups input_devices_wacom smartcard systemd"
+RESTRICT=test
+
+# udev is non-optional since lots of plugins, not just gudev, pull it in
+RDEPEND="
+ >=dev-libs/glib-2.38:2
+ >=gnome-base/libgnomekbd-3.6
+ >=gnome-base/librsvg-2.36.2
+ >=gnome-extra/cinnamon-desktop-2.8.0:0=
+ media-libs/fontconfig
+ >=media-libs/lcms-2.2:2
+ media-libs/libcanberra:0=[gtk3]
+ sys-apps/dbus
+ >=sys-auth/polkit-0.97
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.9.10:3
+ >=x11-libs/libnotify-0.7.3:0=
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libxklavier
+ virtual/libgudev:=
+ >=sys-power/upower-0.9.11
+
+ colord? ( >=x11-misc/colord-0.1.27:= )
+ cups? ( >=net-print/cups-1.4[dbus] )
+ input_devices_wacom? (
+ >=dev-libs/libwacom-0.7
+ x11-drivers/xf86-input-wacom
+ x11-libs/libXtst )
+ smartcard? ( >=dev-libs/nss-3.11.2 )
+ systemd? ( sys-apps/systemd:0= )
+ !systemd? ( sys-auth/elogind:0= )
+"
+DEPEND="${RDEPEND}
+ dev-libs/libxml2:2
+ >=dev-util/intltool-0.37.1
+ x11-proto/kbproto
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # make colord and wacom optional
+ eapply "${FILESDIR}"/${PN}-3.0.1-optional.patch
+
+ # Disable broken test
+ sed -e '/g_test_add_func ("\/color\/edid/d' \
+ -i plugins/color/gcm-self-test.c || die
+
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # no point in disabling gudev since other plugins pull it in
+ gnome2_src_configure \
+ --disable-static \
+ --enable-gudev \
+ --enable-polkit \
+ --enable-logind \
+ $(use_enable colord color) \
+ $(use_enable cups) \
+ $(use_enable smartcard smartcard-support) \
+ $(use_enable input_devices_wacom wacom)
+}
+
+src_test() {
+ virtx emake check
+}