summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2017-02-05 21:22:29 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2017-02-05 21:23:40 +0100
commit6ff3c8772047e1dc4bc4e8261b6623f3681cc21c (patch)
tree91e0c93a95a4f656b904c485d0e00bb49b0c2c1b /gnustep-apps/sogo/sogo-3.0.2.ebuild
parentgnustep-apps/sogo: 3.2.6a bump (diff)
downloadgentoo-6ff3c8772047e1dc4bc4e8261b6623f3681cc21c.tar.gz
gentoo-6ff3c8772047e1dc4bc4e8261b6623f3681cc21c.tar.bz2
gentoo-6ff3c8772047e1dc4bc4e8261b6623f3681cc21c.zip
gnustep-apps/sogo: drop old
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'gnustep-apps/sogo/sogo-3.0.2.ebuild')
-rw-r--r--gnustep-apps/sogo/sogo-3.0.2.ebuild101
1 files changed, 0 insertions, 101 deletions
diff --git a/gnustep-apps/sogo/sogo-3.0.2.ebuild b/gnustep-apps/sogo/sogo-3.0.2.ebuild
deleted file mode 100644
index 87a7d6f1f727..000000000000
--- a/gnustep-apps/sogo/sogo-3.0.2.ebuild
+++ /dev/null
@@ -1,101 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-
-inherit gnustep-2 user vcs-snapshot
-
-DESCRIPTION="Groupware server built around OpenGroupware.org and the SOPE application server"
-HOMEPAGE="http://www.sogo.nu"
-SRC_URI="https://github.com/inverse-inc/sogo/archive/SOGo-${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="gnutls libressl +ssl"
-
-RDEPEND="
- dev-libs/libmemcached
- net-misc/curl
- net-misc/memcached
- >=gnustep-libs/sope-${PV}[ldap]
- gnutls? ( net-libs/gnutls:= )
- !gnutls? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:= )
- )
-"
-DEPEND="${RDEPEND}
- >=gnustep-base/gnustep-make-2.6.3"
-
-pkg_pretend() {
- if use ssl && use gnutls && use libressl ; then
- ewarn "You have enabled both gnutls and libressl, but only"
- ewarn "one provider can be active. Using gnutls!"
- fi
-}
-
-pkg_setup() {
- enewuser sogo -1 /bin/bash /var/lib/sogo
-}
-
-src_prepare() {
- gnustep-base_src_prepare
- sed -e "s/validateArgs$//" -i configure \
- || die "GNUstep.conf sed failed"
-
- default
-}
-
-src_configure() {
- local ssl_provider
- if use ssl ; then
- if use gnutls ; then
- ssl_provider=gnutls
- else
- ssl_provider=ssl
- fi
- else
- ssl_provider=none
- fi
-
- egnustep_env
-
- ./configure \
- --disable-strip \
- --prefix=/usr \
- --with-ssl="${ssl_provider}" \
- $(use_enable debug) \
- || die "configure failed"
-}
-
-src_install() {
- gnustep-base_src_install
-
- newconfd "${FILESDIR}"/sogod.confd sogod
- newinitd "${FILESDIR}"/sogod.initd sogod
-
- insinto /etc/logrotate.d
- newins Scripts/logrotate sogo
- newdoc Apache/SOGo.conf SOGo-Apache.conf
-
- insinto /etc/sogo
- doins Scripts/sogo.conf
-
- insinto /etc/cron.d
- newins Scripts/sogo.cron sogo
- keepdir /var/log/sogo
-
- fowners sogo:sogo /var/log/sogo
- fowners -R root:sogo /etc/sogo
-}
-
-pkg_postinst() {
- gnustep-base_pkg_postinst
- elog "SOGo documentation is available online at:"
- elog "http://www.sogo.nu/downloads/documentation.html"
- elog
- elog "Apache sample configuration file is available in:"
- elog "/usr/share/doc/${PF}"
-}