summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-06-30 15:08:24 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-06-30 15:08:41 -0500
commit641e996d14880a2590024f7c3669b6ed1dc7d5e7 (patch)
tree81dc9cbd74556cbda0fc881b95f88bcfa8c624ad /gui-wm/sway
parentmail-client/trojita: Drop 0.7-r4 (diff)
downloadgentoo-641e996d14880a2590024f7c3669b6ed1dc7d5e7.tar.gz
gentoo-641e996d14880a2590024f7c3669b6ed1dc7d5e7.tar.bz2
gentoo-641e996d14880a2590024f7c3669b6ed1dc7d5e7.zip
gui-wm/sway: 1.4-r2 stable amd64/x86/arm64
Closes: https://bugs.gentoo.org/730274 Package-Manager: Portage-2.3.99, Repoman-2.3.23 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'gui-wm/sway')
-rw-r--r--gui-wm/sway/sway-1.4-r2.ebuild2
-rw-r--r--gui-wm/sway/sway-1.4.ebuild116
2 files changed, 1 insertions, 117 deletions
diff --git a/gui-wm/sway/sway-1.4-r2.ebuild b/gui-wm/sway/sway-1.4-r2.ebuild
index 6c71bb032181..80125677e211 100644
--- a/gui-wm/sway/sway-1.4-r2.ebuild
+++ b/gui-wm/sway/sway-1.4-r2.ebuild
@@ -14,7 +14,7 @@ if [[ ${PV} == 9999 ]]; then
else
MY_PV=${PV/_rc/-rc}
SRC_URI="https://github.com/swaywm/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+ KEYWORDS="amd64 arm64 ~ppc64 x86"
S="${WORKDIR}/${PN}-${MY_PV}"
fi
diff --git a/gui-wm/sway/sway-1.4.ebuild b/gui-wm/sway/sway-1.4.ebuild
deleted file mode 100644
index d0fc53539b7b..000000000000
--- a/gui-wm/sway/sway-1.4.ebuild
+++ /dev/null
@@ -1,116 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit eutils meson
-
-DESCRIPTION="i3-compatible Wayland window manager"
-HOMEPAGE="https://swaywm.org"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/swaywm/${PN}.git"
-else
- MY_PV=${PV/_rc/-rc}
- SRC_URI="https://github.com/swaywm/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 arm64 ~ppc64 x86"
- S="${WORKDIR}/${PN}-${MY_PV}"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="elogind fish-completion +man +swaybar +swaybg +swayidle +swaylock +swaymsg +swaynag systemd tray wallpapers X zsh-completion"
-REQUIRED_USE="?? ( elogind systemd )
- tray? ( || ( elogind systemd ) )"
-
-DEPEND="
- >=dev-libs/json-c-0.13:0=
- >=dev-libs/libinput-1.6.0:0=
- dev-libs/libpcre
- dev-libs/wayland
- x11-libs/cairo
- x11-libs/libxkbcommon
- x11-libs/pango
- x11-libs/pixman
- media-libs/mesa[gles2]
- elogind? ( >=sys-auth/elogind-239 )
- swaybar? ( x11-libs/gdk-pixbuf:2 )
- swaybg? ( gui-apps/swaybg )
- swayidle? ( gui-apps/swayidle )
- swaylock? ( gui-apps/swaylock )
- systemd? ( >=sys-apps/systemd-239 )
- X? ( x11-libs/libxcb:0= )
-"
-if [[ ${PV} == 9999 ]]; then
- DEPEND+="~gui-libs/wlroots-9999:=[elogind=,systemd=,X=]"
-else
- DEPEND+="
- >=gui-libs/wlroots-0.10.0:=[elogind=,systemd=,X=]
- <gui-libs/wlroots-0.11.0:=[elogind=,systemd=,X=]
- "
-fi
-RDEPEND="
- x11-misc/xkeyboard-config
- ${DEPEND}
-"
-BDEPEND="
- >=dev-libs/wayland-protocols-1.14
- virtual/pkgconfig
-"
-if [[ ${PV} == 9999 ]]; then
- BDEPEND+="man? ( ~app-text/scdoc-9999 )"
-else
- BDEPEND+="man? ( >=app-text/scdoc-1.9.3 )"
-fi
-
-src_prepare() {
- default
-
- use swaybar || sed -e "s/subdir('swaybar')//g" -e "/sway-bar.[0-9].scd/d" \
- -e "/completions\/[a-z]\+\/_\?swaybar/d" -i meson.build || die
- use swaymsg || sed -e "s/subdir('swaymsg')//g" -e "/swaymsg.[0-9].scd/d" \
- -e "/completions\/[a-z]\+\/_\?swaymsg/d" -i meson.build || die
- use swaynag || sed -e "s/subdir('swaynag')//g" -e "/swaynag.[0-9].scd/d" \
- -e "/completions\/[a-z]\+\/_\?swaynag/d" -i meson.build || die
-}
-
-src_configure() {
- local emesonargs=(
- -Dman-pages=$(usex man enabled disabled)
- -Dtray=$(usex tray enabled disabled)
- -Dxwayland=$(usex X enabled disabled)
- $(meson_use wallpapers default-wallpaper)
- $(meson_use fish-completion fish-completions)
- $(meson_use zsh-completion zsh-completions)
- "-Dbash-completions=true"
- "-Dwerror=false"
- )
-
- if use swaybar; then
- emesonargs+=("-Dgdk-pixbuf=enabled")
- else
- emesonargs+=("-Dgdk-pixbuf=disabled")
- fi
-
- meson_src_configure
-}
-
-pkg_preinst() {
- if ! use systemd && ! use elogind; then
- fowners root:0 /usr/bin/sway
- fperms 4511 /usr/bin/sway
- fi
-}
-
-pkg_postinst() {
- if ! use systemd && ! use elogind; then
- elog ""
- elog "If you use ConsoleKit2, remember to launch sway using:"
- elog "exec ck-launch-session sway"
- elog ""
- elog "If your system does not set the XDG_RUNTIME_DIR environment"
- elog "variable, you must set it manually to run Sway. See wiki"
- elog "for details: https://wiki.gentoo.org/wiki/Sway"
- fi
-}