summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-04-03 13:25:46 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-04-03 14:02:32 +0200
commit6ab66a4b6fbdb9dae6ee14d9e1a620dcb96da8aa (patch)
tree6af447d96e53bdac9f9ca597278e3d8fb4ca2340 /kde-apps/akonadiconsole
parentkde-apps/akonadi: Fix a regression when updating attributes (diff)
downloadgentoo-6ab66a4b6fbdb9dae6ee14d9e1a620dcb96da8aa.tar.gz
gentoo-6ab66a4b6fbdb9dae6ee14d9e1a620dcb96da8aa.tar.bz2
gentoo-6ab66a4b6fbdb9dae6ee14d9e1a620dcb96da8aa.zip
kde-apps: Ensure rebuild against >=kde-apps/akonadi-18.12.3-r1
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/akonadiconsole')
-rw-r--r--kde-apps/akonadiconsole/akonadiconsole-18.12.3-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/kde-apps/akonadiconsole/akonadiconsole-18.12.3-r1.ebuild b/kde-apps/akonadiconsole/akonadiconsole-18.12.3-r1.ebuild
new file mode 100644
index 000000000000..81c979002689
--- /dev/null
+++ b/kde-apps/akonadiconsole/akonadiconsole-18.12.3-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_HANDBOOK="forceoptional" # FIXME: Check back for doc in release
+inherit kde5
+
+DESCRIPTION="Application for debugging Akonadi Resources"
+LICENSE="GPL-2+ LGPL-2.1+ handbook? ( FDL-1.2+ )"
+HOMEPAGE="https://www.kde.org/"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_kdeapps_dep akonadi '' 18.12.3-r1)
+ $(add_kdeapps_dep akonadi-contacts)
+ $(add_kdeapps_dep akonadi-search)
+ $(add_kdeapps_dep calendarsupport)
+ $(add_kdeapps_dep kcalcore)
+ $(add_kdeapps_dep kcontacts)
+ $(add_kdeapps_dep kmime)
+ $(add_kdeapps_dep libkdepim)
+ $(add_kdeapps_dep messagelib)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtsql)
+ $(add_qt_dep qtwidgets)
+ dev-libs/xapian:=
+"
+RDEPEND="${DEPEND}"