summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-08-15 15:08:36 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-08-15 15:09:32 +0200
commit54d6ee8b4a5a60e7f3f7e1a2068c2ee69f9cd1d9 (patch)
treeb1b36d8867b77df28e956c3f88378ef5518961f9 /kde-apps/ark
parentkde-misc/kio-gdrive: Pin kde-apps/libkgapi version to <19.04.50 (diff)
downloadgentoo-54d6ee8b4a5a60e7f3f7e1a2068c2ee69f9cd1d9.tar.gz
gentoo-54d6ee8b4a5a60e7f3f7e1a2068c2ee69f9cd1d9.tar.bz2
gentoo-54d6ee8b4a5a60e7f3f7e1a2068c2ee69f9cd1d9.zip
kde-apps: Add KDE Applications 19.08.0
Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/ark')
-rw-r--r--kde-apps/ark/Manifest1
-rw-r--r--kde-apps/ark/ark-19.08.0.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/kde-apps/ark/Manifest b/kde-apps/ark/Manifest
index b73f6d0d6fde..080af593f617 100644
--- a/kde-apps/ark/Manifest
+++ b/kde-apps/ark/Manifest
@@ -1 +1,2 @@
DIST ark-19.04.3.tar.xz 2579920 BLAKE2B a8637d4f564fe20aa28035e5c1a09ca8c6803bf6acb9fc82074a8219368f1ff9b45dd88dc1439823e73eb627d2f13269b4cd776480d991c1499e8de1510de14c SHA512 dc41f8daea7c63f93725cd1dada978fde68c7e7c659840014fe3ccc32a8e9e7013f495590cd5344d68001cbba81f527ec368829b4ff1577f71d5de268cd0b459
+DIST ark-19.08.0.tar.xz 2584376 BLAKE2B d123812b3bc0c9a8215fc9cdfafcd4933265f337a18cb85d9837f14396effa2402bb6c114c9e5318086dbc199fcd9a86a01e2e8ef84d10ffce0bb0efd2fe7af2 SHA512 3a594d951e9f8c128e67fa6caa508f67b5831cc553b683acab9ec60254318f4ac2fc30e70a27d93d98f7eddc217fc377dcef7d9f5780728a0ab15843b0400e2e
diff --git a/kde-apps/ark/ark-19.08.0.ebuild b/kde-apps/ark/ark-19.08.0.ebuild
new file mode 100644
index 000000000000..bba063801ed4
--- /dev/null
+++ b/kde-apps/ark/ark-19.08.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="optional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="KDE Archiving tool"
+HOMEPAGE="https://kde.org/applications/utilities/ark
+https://utils.kde.org/projects/ark/"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="bzip2 lzma zip"
+
+BDEPEND="
+ sys-devel/gettext
+"
+RDEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kpty)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ app-arch/libarchive:=[bzip2?,lzma?,zlib]
+ sys-libs/zlib
+ zip? ( >=dev-libs/libzip-1.2.0:= )
+"
+DEPEND="${RDEPEND}
+ $(add_qt_dep qtconcurrent)
+"
+
+# bug #560548, last checked with 16.04.1
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package bzip2 BZip2)
+ $(cmake-utils_use_find_package lzma LibLZMA)
+ $(cmake-utils_use_find_package zip LibZip)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ if ! has_version app-arch/rar; then
+ elog "For creating/extracting rar archives, installing app-arch/rar is required."
+ if ! has_version app-arch/unar && ! has_version app-arch/unrar; then
+ elog "Alternatively, for only extracting rar archives, install app-arch/unar (free) or app-arch/unrar (non-free)."
+ fi
+ fi
+
+ has_version app-arch/p7zip || \
+ elog "For handling 7-Zip archives, install app-arch/p7zip."
+
+ has_version app-arch/lrzip || \
+ elog "For handling lrz archives, install app-arch/lrzip."
+ fi
+}