summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-02-10 14:28:40 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-02-11 23:00:24 +0100
commit8e9254c5dac34b290d80baa283964bf5802d6630 (patch)
treee74c0d8d4491416d64de7802e3937452a509b1f1 /kde-apps/ark
parentkde-frameworks: Add KDE Frameworks 5.43.0 (diff)
downloadgentoo-8e9254c5dac34b290d80baa283964bf5802d6630.tar.gz
gentoo-8e9254c5dac34b290d80baa283964bf5802d6630.tar.bz2
gentoo-8e9254c5dac34b290d80baa283964bf5802d6630.zip
kde-apps: Add KDE Applications 17.12.2
Bug: https://bugs.gentoo.org/642854 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'kde-apps/ark')
-rw-r--r--kde-apps/ark/Manifest1
-rw-r--r--kde-apps/ark/ark-17.12.2.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/kde-apps/ark/Manifest b/kde-apps/ark/Manifest
index 41417cd688b3..807349a6a1b0 100644
--- a/kde-apps/ark/Manifest
+++ b/kde-apps/ark/Manifest
@@ -1,2 +1,3 @@
DIST ark-17.08.3.tar.xz 1966132 BLAKE2B ec17cdd3d9682cbf2f533bb159fcc219c91426997120ac03fa4726123701b6e1d98686cdaa07330e541bd2a1189a920292c13932df824bb9855bc93c38c7c605 SHA512 c28eda02f561391a21723286de2b71b9d985a07edfabd510b690927ac598da7464b56ba6132bb0362a6fd7ddb35d99bcbeb8ef74b801cfbba22f6f6d91262fb8
DIST ark-17.12.1.tar.xz 1970844 BLAKE2B 5f758bd3d555a75e1c50b29292bb28f637184d7b7af9de5193ab24348845135cc6486a196d16320d11b108eb3f7c83eeedf2a0afa46019a8c09b6f1ea9bb104a SHA512 445b98bc1fe6484cb5f2b6fb78a2d33e6d0d1898968fbcea43574567af3b3d8847fe674a2bdb342bf8ca96b862bb2de25b4f06e82715a3d99899d1279b8a9fca
+DIST ark-17.12.2.tar.xz 1970240 BLAKE2B eb402da08903476f1ae14ff3921742a63242a2fbd1eb5702c794a52a5249342751b1a0a943d10a0516a7cb6da3bfd7a1c886d2d23a09c4b79022d96b86486008 SHA512 8b87bb8e96ed1483503ebd26ce505962cafe96b9294dac9dd548a0659c0ff8795cf1e699c86ec2168f761819906d8958cedbe3858e05d50f7cb41a9d780a78af
diff --git a/kde-apps/ark/ark-17.12.2.ebuild b/kde-apps/ark/ark-17.12.2.ebuild
new file mode 100644
index 000000000000..c95527b9545e
--- /dev/null
+++ b/kde-apps/ark/ark-17.12.2.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="optional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="KDE Archiving tool"
+HOMEPAGE="https://www.kde.org/applications/utilities/ark
+https://utils.kde.org/projects/ark/"
+KEYWORDS="~amd64 ~x86"
+IUSE="bzip2 lzma zip zlib"
+
+RDEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kpty)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ app-arch/libarchive:=[bzip2?,lzma?,zlib?]
+ sys-libs/zlib
+ zip? ( >=dev-libs/libzip-1.2.0:= )
+"
+DEPEND="${RDEPEND}
+ $(add_qt_dep qtconcurrent)
+ sys-devel/gettext
+"
+
+# bug #560548, last checked with 16.04.1
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package bzip2 BZip2)
+ $(cmake-utils_use_find_package lzma LibLZMA)
+ $(cmake-utils_use_find_package zip LibZip)
+ $(cmake-utils_use_find_package zlib ZLIB)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ # not a typo, app-arch/unar is a real package
+ if ! has_version app-arch/unar ; then
+ elog "For handling rar archives, install app-arch/unar"
+ fi
+
+ if ! has_version app-arch/p7zip ; then
+ elog "For handling 7-Zip archives, install app-arch/p7zip"
+ fi
+
+ if ! has_version app-arch/lrzip ; then
+ elog "For handling lrz archives, install app-arch/lrzip"
+ fi
+}