summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2017-06-08 23:00:50 +0200
committerJohannes Huber <johu@gentoo.org>2017-06-08 23:00:50 +0200
commitc892d3edb4099fe424a61b0d1aa296132d872ba0 (patch)
treee010db999c552c23e6993bd429516c40db852fe6 /kde-apps/ark
parentkde-frameworks/kdelibs: Version bump 4.14.33 (diff)
downloadgentoo-c892d3edb4099fe424a61b0d1aa296132d872ba0.tar.gz
gentoo-c892d3edb4099fe424a61b0d1aa296132d872ba0.tar.bz2
gentoo-c892d3edb4099fe424a61b0d1aa296132d872ba0.zip
kde-apps: Version bump KDE Applications 17.04.2
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'kde-apps/ark')
-rw-r--r--kde-apps/ark/Manifest1
-rw-r--r--kde-apps/ark/ark-17.04.2.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/kde-apps/ark/Manifest b/kde-apps/ark/Manifest
index af2205565bd2..46a06416021c 100644
--- a/kde-apps/ark/Manifest
+++ b/kde-apps/ark/Manifest
@@ -1,2 +1,3 @@
DIST ark-16.12.3.tar.xz 1348616 SHA256 a0e54892a809d9b805aab95d33060560480a5575df2e8afbd6fc0eb074ee2b60 SHA512 2bb7c80758bc0a3322892b66cbe26dad199661e1bbbf71fb0ccc2bc1bea8dac8f267fc371baf55a4674e5bc67f86fb39587709d12e10e53988fa1a6c0e056956 WHIRLPOOL 35cd9f15f7a04b99b09fce32c6ce3819ed7b7c6e0d2240517ccf942a15622f0f10a19c758c5195c44ba9c5e4a451673073c0cedaad12d9970618867bf17d3126
DIST ark-17.04.1.tar.xz 1886488 SHA256 b642dc57aa1a22e0bc9757d3154a35da3a91bd2917ef03b74e82ee304d9d3223 SHA512 64c09853fc5eea74533220e686f9a01750a55f2dff71a06d30e9db1fb01816f481a710f39407c1b2410d62815816b8ee5cc94bfb39172aca99c70a0a48f8618e WHIRLPOOL 4a6242d27262fd333a4a132041b743cbef788c4efd8de2b2a545b245d9584bf9fa4ef57744b9846be16f33471b43f59944a195b9b454d035a9f570697d34fe9e
+DIST ark-17.04.2.tar.xz 1888212 SHA256 dda9222e3d8bfea83997b46cf4f2f7b9677f9bc16463bf15223273f84eebbe7d SHA512 965b706f677e81e60b4148c1f6a3a2300b84f8298f704c25bea165635f58e878399b1d7adbfa382dbb1545bed2fe898f65083156763efe67b44790033234a621 WHIRLPOOL 2827645b245288b024fdb76eea04f40bffffa5edc09f4f0ff40ea0b0c98b9f50f7bf107edf696000dbaac205134544f5fc3af40e6733e0e64d41229445197b2d
diff --git a/kde-apps/ark/ark-17.04.2.ebuild b/kde-apps/ark/ark-17.04.2.ebuild
new file mode 100644
index 000000000000..3ba7d3c0e61d
--- /dev/null
+++ b/kde-apps/ark/ark-17.04.2.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="optional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="KDE Archiving tool"
+HOMEPAGE="https://www.kde.org/applications/utilities/ark
+https://utils.kde.org/projects/ark"
+KEYWORDS="~amd64 ~x86"
+IUSE="bzip2 lzma zip zlib"
+
+RDEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kpty)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ app-arch/libarchive:=[bzip2?,lzma?,zlib?]
+ zip? ( >=dev-libs/libzip-1.2.0:= )
+"
+DEPEND="${RDEPEND}
+ $(add_qt_dep qtconcurrent)
+ sys-devel/gettext
+"
+
+# bug #560548, last checked with 16.04.1
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package bzip2 BZip2)
+ $(cmake-utils_use_find_package lzma LibLZMA)
+ $(cmake-utils_use_find_package zip LibZip)
+ $(cmake-utils_use_find_package zlib ZLIB)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ # not a typo, app-arch/unar is a real package
+ if ! has_version app-arch/unar ; then
+ elog "For handling rar archives, install app-arch/unar"
+ fi
+
+ if ! has_version app-arch/p7zip ; then
+ elog "For handling 7-Zip archives, install app-arch/p7zip"
+ fi
+
+ if ! has_version app-arch/lrzip ; then
+ elog "For handling lrz archives, install app-arch/lrzip"
+ fi
+}