summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-08-17 20:21:16 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-08-17 20:58:09 +0200
commitc1063afea17a29bb75dbbbf0121fa5c8ad948574 (patch)
treec62ccf9ec787742c39c2afd14ac1198894802629 /kde-apps/calendarjanitor
parentmedia-libs/libqaccessibilityclient: New package (diff)
downloadgentoo-c1063afea17a29bb75dbbbf0121fa5c8ad948574.tar.gz
gentoo-c1063afea17a29bb75dbbbf0121fa5c8ad948574.tar.bz2
gentoo-c1063afea17a29bb75dbbbf0121fa5c8ad948574.zip
kde-apps: Add KDE Applications 17.08.0
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'kde-apps/calendarjanitor')
-rw-r--r--kde-apps/calendarjanitor/Manifest1
-rw-r--r--kde-apps/calendarjanitor/calendarjanitor-17.08.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/kde-apps/calendarjanitor/Manifest b/kde-apps/calendarjanitor/Manifest
index ab9cf0ce962d..9238581a0fd5 100644
--- a/kde-apps/calendarjanitor/Manifest
+++ b/kde-apps/calendarjanitor/Manifest
@@ -1 +1,2 @@
DIST akonadi-calendar-tools-17.04.3.tar.xz 222024 SHA256 9bac14cbd607d9995c34ce650e5bf4315db6ac8c2750eca72d392a4f01daeefb SHA512 49ac47c22ef3da8eb038e11426461456081ff4288bd99eb938dd8b55f5a1010c8c199b7f215290c67b092705833cc801c0964eee9005a2f093bc2f58fd9523bd WHIRLPOOL 0a4f2270f40f8b9a35c1751920600f7dd029ebc166f99e7793a84869a8de4dc175fc58b572ba767254f3da6257cdcb1080954da2c3ee6ad3faf61300337c69b4
+DIST akonadi-calendar-tools-17.08.0.tar.xz 223140 SHA256 605312f9a349363c03154f2d59a67a421f17dd44419f81c8d9524263d76bf5ef SHA512 f88a2cff88f2dbaee4404feb61f987fb42dd28ba0f43d20d908832c593ee86a0de6bed57ce6242d4ffc913b7cd64512227b4c0d258961332744999c09a056289 WHIRLPOOL 173b6a7797505d88b7ad9494874151bcf26016342faa0933ba26bbbed6ca55a0ae844d23080502d026fc7fd5a81742df3c9a362e5a8c3143a62ac4572d230aaa
diff --git a/kde-apps/calendarjanitor/calendarjanitor-17.08.0.ebuild b/kde-apps/calendarjanitor/calendarjanitor-17.08.0.ebuild
new file mode 100644
index 000000000000..8363967d9d1b
--- /dev/null
+++ b/kde-apps/calendarjanitor/calendarjanitor-17.08.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional" # FIXME: Check back for doc in release
+KDE_TEST="false"
+KMNAME="akonadi-calendar-tools"
+inherit kde5
+
+DESCRIPTION="Tool to scan calendar data for buggy instances"
+LICENSE="GPL-2+ handbook? ( FDL-1.2+ )"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep ki18n)
+ $(add_kdeapps_dep akonadi)
+ $(add_kdeapps_dep akonadi-calendar)
+ $(add_kdeapps_dep calendarsupport)
+ $(add_kdeapps_dep kcalcore)
+ $(add_qt_dep qtwidgets)
+"
+RDEPEND="${DEPEND}
+ !kde-apps/kdepim-l10n
+"
+
+src_prepare() {
+ kde5_src_prepare
+
+ cmake_comment_add_subdirectory doc konsolekalendar
+ sed -i -e "/console\.categories/ s/^/#DONT/" CMakeLists.txt || die
+
+ # delete colliding konsolekalendar translations
+ if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ rm -f po/*/konsolekalendar.po || die
+ rm -rf po/*/docs/konsolekalendar || die
+ fi
+}