summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-03-08 19:04:08 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-03-08 19:04:39 +0100
commitd7443e05892e21953f2476002a87f3c0213706bb (patch)
treebdc943e4106bc2c6f20218650cf96563b88f1827 /kde-apps/calendarjanitor
parentsys-fs/zfs: drop old (diff)
downloadgentoo-d7443e05892e21953f2476002a87f3c0213706bb.tar.gz
gentoo-d7443e05892e21953f2476002a87f3c0213706bb.tar.bz2
gentoo-d7443e05892e21953f2476002a87f3c0213706bb.zip
kde-apps: Add KDE Applications 17.12.3
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'kde-apps/calendarjanitor')
-rw-r--r--kde-apps/calendarjanitor/Manifest1
-rw-r--r--kde-apps/calendarjanitor/calendarjanitor-17.12.3.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/kde-apps/calendarjanitor/Manifest b/kde-apps/calendarjanitor/Manifest
index 3173755915d0..c3254015ecaa 100644
--- a/kde-apps/calendarjanitor/Manifest
+++ b/kde-apps/calendarjanitor/Manifest
@@ -1,2 +1,3 @@
DIST akonadi-calendar-tools-17.08.3.tar.xz 223524 BLAKE2B 27b584a5a06c7d5388c4a182f824005e8905b54773dfca8c010faba4d254a73d794ed4b1eebdc516ba7a100d0e3b841f37b4a23e2efeeec6416813c2ed63f949 SHA512 9ff26e19f7fcbedb76698d40f781c4e96f97c6441e5002b3fa0d63b22558563ae8f25f8343b05acc400af2fa5e96b7f96c4fa3a9ffc82cbf5d01cf21e002cd40
DIST akonadi-calendar-tools-17.12.2.tar.xz 223912 BLAKE2B fbe922df2214d62947380794aa1af6cea40da45709644ee419166864254b296440ebfc1f4e14c3ad976fbf350c5b18ada0eb37c9227131fc1b1911d347ba4d93 SHA512 36c89bf4a3bdae29c727ad6cedf580439ffd9aec3ddf190b74a24c53af270ce173ecbbce02f336e4b2c3f3482670d97cd108d27a12a4aac1df14cd31c91fccce
+DIST akonadi-calendar-tools-17.12.3.tar.xz 223424 BLAKE2B 57622ccc637d9a41634d90e764f1c9dfdbe60e7a77d13632397e41222dc1cc5b544f268451132a11f8a3118a9042c701e993eef512ef5ac1df05aeea6bc1d35e SHA512 18c8bc3deb273022543c209410403f7bf7a9b13bcbcf9be601ef011dc9ae6c0335d866d1e696b410fcc4751830cb824a1fe530299ae76fe92e2f785f6886bd11
diff --git a/kde-apps/calendarjanitor/calendarjanitor-17.12.3.ebuild b/kde-apps/calendarjanitor/calendarjanitor-17.12.3.ebuild
new file mode 100644
index 000000000000..026dab8a1418
--- /dev/null
+++ b/kde-apps/calendarjanitor/calendarjanitor-17.12.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional" # FIXME: Check back for doc in release
+KDE_TEST="false"
+KMNAME="akonadi-calendar-tools"
+inherit kde5
+
+DESCRIPTION="Tool to scan calendar data for buggy instances"
+LICENSE="GPL-2+ handbook? ( FDL-1.2+ )"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep ki18n)
+ $(add_kdeapps_dep akonadi)
+ $(add_kdeapps_dep akonadi-calendar)
+ $(add_kdeapps_dep calendarsupport)
+ $(add_kdeapps_dep kcalcore)
+ $(add_qt_dep qtwidgets)
+"
+RDEPEND="${DEPEND}
+ !kde-apps/kdepim-l10n
+"
+
+src_prepare() {
+ kde5_src_prepare
+
+ cmake_comment_add_subdirectory doc konsolekalendar
+ sed -i -e "/console\.categories/ s/^/#DONT/" CMakeLists.txt || die
+
+ # delete colliding konsolekalendar translations
+ if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ rm -f po/*/konsolekalendar.po || die
+ rm -rf po/*/docs/konsolekalendar || die
+ fi
+}