summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-11-18 00:47:36 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-11-18 01:16:45 +0100
commitc49e785e16c43104a9b2e8c2f7df3eaf35c6c57a (patch)
treeb44b6f3618585db30189313419c57e34be42f2b5 /kde-apps/dolphin/files
parentkde-plasma/kwin: Initialize kcrash for xclipboardsync (diff)
downloadgentoo-c49e785e16c43104a9b2e8c2f7df3eaf35c6c57a.tar.gz
gentoo-c49e785e16c43104a9b2e8c2f7df3eaf35c6c57a.tar.bz2
gentoo-c49e785e16c43104a9b2e8c2f7df3eaf35c6c57a.zip
kde-apps/dolphin: Move kcrash link to dolphin app
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/dolphin/files')
-rw-r--r--kde-apps/dolphin/files/dolphin-18.08.3-kcrash-init.patch56
1 files changed, 56 insertions, 0 deletions
diff --git a/kde-apps/dolphin/files/dolphin-18.08.3-kcrash-init.patch b/kde-apps/dolphin/files/dolphin-18.08.3-kcrash-init.patch
new file mode 100644
index 000000000000..cb7923534c3e
--- /dev/null
+++ b/kde-apps/dolphin/files/dolphin-18.08.3-kcrash-init.patch
@@ -0,0 +1,56 @@
+From a4cddf7517dab5f666f1c1ede2a58900f3bc5e53 Mon Sep 17 00:00:00 2001
+From: Harald Sitter <sitter@kde.org>
+Date: Thu, 15 Nov 2018 14:43:57 +0100
+Subject: move kcrash link to dolphin app (which is the effective user)
+
+Summary:
+to successfully use kcrash when linking with as-needed (which is a default
+flag on many linux distros) one also needs to call KCrash::initialize.
+this call happens in the app's main.cpp. as such the kcrash link target
+on the dolphinprivate library doesn't do anything for dolphinprivate but
+only kicks into action for dolphin itself.
+to avoid confusion and make it clear that kcrash is only initialized in the
+application scope the KF5::Crash link target is now on the application
+target, not the library target.
+
+(this makes no difference in the output, kcrash was still correctly linked
+ via dolphinprivate; but only for kdeinit_dolphin, dolphinprivate did
+ not get linked to it with as-needed)
+
+Test Plan: builds; links as expected
+
+Reviewers: elvisangelaccio, #dolphin
+
+Reviewed By: elvisangelaccio, #dolphin
+
+Subscribers: kfm-devel
+
+Tags: #dolphin
+
+Differential Revision: https://phabricator.kde.org/D16896
+---
+ src/CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 4a1f173..d5206be 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -136,7 +136,6 @@ target_link_libraries(
+ dolphinvcs
+ Qt5::Concurrent
+ Qt5::Gui
+- KF5::Crash
+ KF5::I18n
+ KF5::IconThemes
+ KF5::KIOCore
+@@ -301,6 +300,7 @@ kf5_add_kdeinit_executable(dolphin ${dolphin_SRCS})
+ target_link_libraries(kdeinit_dolphin PRIVATE
+ dolphinstatic
+ dolphinprivate
++ KF5::Crash
+ )
+
+ include(DbusInterfaceMacros)
+--
+cgit v0.11.2