summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2017-06-08 23:00:50 +0200
committerJohannes Huber <johu@gentoo.org>2017-06-08 23:00:50 +0200
commitc892d3edb4099fe424a61b0d1aa296132d872ba0 (patch)
treee010db999c552c23e6993bd429516c40db852fe6 /kde-apps/dolphin
parentkde-frameworks/kdelibs: Version bump 4.14.33 (diff)
downloadgentoo-c892d3edb4099fe424a61b0d1aa296132d872ba0.tar.gz
gentoo-c892d3edb4099fe424a61b0d1aa296132d872ba0.tar.bz2
gentoo-c892d3edb4099fe424a61b0d1aa296132d872ba0.zip
kde-apps: Version bump KDE Applications 17.04.2
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'kde-apps/dolphin')
-rw-r--r--kde-apps/dolphin/Manifest1
-rw-r--r--kde-apps/dolphin/dolphin-17.04.2.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/kde-apps/dolphin/Manifest b/kde-apps/dolphin/Manifest
index 27b67024dd27..78acbe72bc65 100644
--- a/kde-apps/dolphin/Manifest
+++ b/kde-apps/dolphin/Manifest
@@ -1,2 +1,3 @@
DIST dolphin-16.12.3.tar.xz 676192 SHA256 62f1392a25692bc7ff0ffba89b1949beba3cba0f78bdf6acdf97ac2897a46578 SHA512 99a6f35678918dffa7a55b453705186a92bf1b69776a7b80ef12553489e258f5776a5d7b2a5dd16cbdb2e6772a2a122fe10e74afb6233e7a939f8f925e1d8736 WHIRLPOOL e606fbb6567f0c67e952ac91e9e54fcb7734a493091cd6441f3ccb8d42739f680ff52c90b004d6ad5d3a97e0f68bb2b031b3d432be38ae20e9a4d8d01ffc5893
DIST dolphin-17.04.1.tar.xz 4713172 SHA256 27ae075eeb5811c4a3b2f64edb7316c17ac114bb1fa7ee866cc04def99352be7 SHA512 10fffef1c498372522c30d0e52ed30ea9271eadf6dd1a400416adb2dc360f5f78605babb6e5336a8376661caffea90b4b1deafcdbbd1ef1ddb3ae2e633da56c6 WHIRLPOOL f0019878016dc232e80d4ab5fe173b2f88bffc3bfe7ba59257548c5f99b8d25a4ce84545a3fa0362fd7bb6adbc0841f24e2d7c455d2ec87e5d2edb05c1b24b19
+DIST dolphin-17.04.2.tar.xz 4707592 SHA256 45ac5454ec6f2e1382ab250be16871a3184804b91f23839a7ec4d8f4b972a0f9 SHA512 28b16a37ec48e02fdd5581241b1505125b55781ac6eaab18c03762ab94f5f35988afa68dbe4ebfcc0b0e13bdcb51538b4e704bf0edc9b54128bc2a7e963015e5 WHIRLPOOL 597cc3118baa2996c328ad61b8164cc362710834976e1294546d750bcf3ac1218f49f08e4443c59b7d3e74205d9eff1b2f0a5762db1d024d3b13e4a6380d1ed0
diff --git a/kde-apps/dolphin/dolphin-17.04.2.ebuild b/kde-apps/dolphin/dolphin-17.04.2.ebuild
new file mode 100644
index 000000000000..6851edf8232c
--- /dev/null
+++ b/kde-apps/dolphin/dolphin-17.04.2.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+FRAMEWORKS_MINIMAL="5.30.0"
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="true"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Plasma filemanager focusing on usability"
+HOMEPAGE="https://dolphin.kde.org https://www.kde.org/applications/system/dolphin"
+KEYWORDS="~amd64 ~x86"
+IUSE="semantic-desktop thumbnail"
+
+DEPEND="
+ $(add_frameworks_dep kbookmarks)
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kinit)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtconcurrent)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ media-libs/phonon[qt5]
+ semantic-desktop? (
+ $(add_frameworks_dep baloo)
+ $(add_frameworks_dep kfilemetadata)
+ $(add_kdeapps_dep baloo-widgets)
+ )
+ !semantic-desktop? (
+ $(add_frameworks_dep kdelibs4support)
+ )
+"
+RDEPEND="${DEPEND}
+ $(add_kdeapps_dep kio-extras)
+ thumbnail? (
+ $(add_kdeapps_dep ffmpegthumbs)
+ $(add_kdeapps_dep thumbnailers)
+ )
+"
+
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package semantic-desktop KF5Baloo)
+ $(cmake-utils_use_find_package semantic-desktop KF5BalooWidgets)
+ $(cmake-utils_use_find_package semantic-desktop KF5FileMetaData)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ if ! has_version "kde-apps/ark:${SLOT}" ; then
+ elog "For compress/extract and other actions, please install kde-apps/ark:${SLOT}"
+ fi
+
+ if ! has_version "kde-apps/kleopatra:${SLOT}" ; then
+ elog "For crypto actions, please install kde-apps/kleopatra:${SLOT}"
+ fi
+}