summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-01-11 17:17:01 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-01-11 18:14:22 +0100
commit85faab2e366afa6293f3c9781866f04631fc6213 (patch)
tree38279f6f2d8718267d122dfac04798f46f87232c /kde-apps/kig
parentprofiles/package.mask: remove obsolete media-radio/wspr entry (diff)
downloadgentoo-85faab2e366afa6293f3c9781866f04631fc6213.tar.gz
gentoo-85faab2e366afa6293f3c9781866f04631fc6213.tar.bz2
gentoo-85faab2e366afa6293f3c9781866f04631fc6213.zip
kde-apps: Add KDE Applications 17.12.1
Package-Manager: Portage-2.3.13, Repoman-2.3.4
Diffstat (limited to 'kde-apps/kig')
-rw-r--r--kde-apps/kig/Manifest1
-rw-r--r--kde-apps/kig/kig-17.12.1.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/kde-apps/kig/Manifest b/kde-apps/kig/Manifest
index 2ff4cefe1649..3d7228af1b48 100644
--- a/kde-apps/kig/Manifest
+++ b/kde-apps/kig/Manifest
@@ -1,2 +1,3 @@
DIST kig-17.08.3.tar.xz 3588344 BLAKE2B 37d0e1536f7eb17eb731ea5411de0edc018d87a92d8a401f9fba5100b8533cd4f6daef3dfa8ca0b7e7f1058cd033872219b6ddfb1a6c5b1be33e72641f123566 SHA512 9ce781ee32697fd69274ed5899bef6a176e9dcb118f2aab7dbebde1b3a974fec4d3bf702dd9bf06caf986f304f66cbfd2300554ff7df469035b07fe426f1c025
DIST kig-17.12.0.tar.xz 3589748 BLAKE2B cd34c7bb36ae46e0c8e6fdbaed8850c5bb8b7d8fd1cedd6ed96dbc99a4fa09a1b95e6c3c5f5cd36d9fb18776a122b9c6161e79d91df8815ec6c570570471f8cf SHA512 196e3a4c2c41acb54f1ce86aaa82eb773aded763c74724346fe24da47b6cb0984816b9a44fdb1c761c990cb3560522ac701513f0d046e25544e3488f61a5c067
+DIST kig-17.12.1.tar.xz 3589748 BLAKE2B 286f728cbfec3f9f59d4bf6d8ee95f2f25fd0ff0ea6bd70b911a1765a3db61732019663d03ced71a499cf6b3e0667bc26c245682058fc8aeae8334f2b8a1fa20 SHA512 635082e00c3ecc41cd50651187d7338a37d4eea686a54e689773cf3160c2577cb8a3414abcf136a4c509431809ae20bd7462b0cd705fef64ea38d2db47dbbf9f
diff --git a/kde-apps/kig/kig-17.12.1.ebuild b/kde-apps/kig/kig-17.12.1.ebuild
new file mode 100644
index 000000000000..7e2644a1fb74
--- /dev/null
+++ b/kde-apps/kig/kig-17.12.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="optional"
+PYTHON_COMPAT=( python2_7 )
+inherit python-single-r1 kde5
+
+DESCRIPTION="KDE Interactive Geometry tool"
+HOMEPAGE="https://www.kde.org/applications/education/kig https://edu.kde.org/kig"
+KEYWORDS="~amd64 ~x86"
+IUSE="geogebra scripting"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtsvg)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ geogebra? ( $(add_qt_dep qtxmlpatterns) )
+ scripting? ( >=dev-libs/boost-1.48:=[python,${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ $(add_frameworks_dep ktexteditor)
+"
+
+PATCHES=( "${FILESDIR}/${PN}-4.12.0-boostpython.patch" )
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ kde5_pkg_setup
+}
+
+src_prepare() {
+ kde5_src_prepare
+ python_fix_shebang .
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package geogebra Qt5XmlPatterns)
+ $(cmake-utils_use_find_package scripting BoostPython)
+ )
+
+ kde5_src_configure
+}