summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-12-14 23:14:45 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-12-14 23:25:03 +0100
commit576fc933c81aa6e526d87290af95e8e898e70ecb (patch)
tree73f9a202bcb454043dbb6b731d9b56ed4c5f49eb /kde-apps/kimap
parentdev-haskell/stack-bin: bump up to 1.6.1 (diff)
downloadgentoo-576fc933c81aa6e526d87290af95e8e898e70ecb.tar.gz
gentoo-576fc933c81aa6e526d87290af95e8e898e70ecb.tar.bz2
gentoo-576fc933c81aa6e526d87290af95e8e898e70ecb.zip
kde-apps: Add KDE Applications 17.12.0
Package-Manager: Portage-2.3.18, Repoman-2.3.6
Diffstat (limited to 'kde-apps/kimap')
-rw-r--r--kde-apps/kimap/Manifest1
-rw-r--r--kde-apps/kimap/kimap-17.12.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/kde-apps/kimap/Manifest b/kde-apps/kimap/Manifest
index 5d8941205992..777061959d37 100644
--- a/kde-apps/kimap/Manifest
+++ b/kde-apps/kimap/Manifest
@@ -1 +1,2 @@
DIST kimap-17.08.3.tar.xz 119852 BLAKE2B 8460886f0be75e53985042e9b0c103b379b5c6821e983f5550ac300e883c702812e808b9affc17b6188c9d5e5e385e2687c95dfb5d30acd3debc9974077192a6 SHA512 2945c19eeb04e4e49a496e33ce29ae0c25d7a2613b5d59c26740bd91d7edec02177fee2965d099f36badc6cdf5507dae54676138d8d68d4a23a5a656153f7041
+DIST kimap-17.12.0.tar.xz 119676 BLAKE2B 67211cce5f8b4e911924b6c8cf4887a23a705d01607f4d9ee415714102317931aa96f0e00c7d3fa5c80349fad6be4b001f0753e92cc2092a8313b39f76269b2b SHA512 6472eb7c28b949a311dbe2c3b67c4f799453dd4c40d2af6f00a24872d891a20b4c0980a2ca9f7184402a2883554ef16baa3ef1c34472c90593cc6f0d144c05a1
diff --git a/kde-apps/kimap/kimap-17.12.0.ebuild b/kde-apps/kimap/kimap-17.12.0.ebuild
new file mode 100644
index 000000000000..fc39c269408e
--- /dev/null
+++ b/kde-apps/kimap/kimap-17.12.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_TEST="forceoptional"
+inherit kde5
+
+DESCRIPTION="Library for interacting with IMAP servers"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# TODO: Convince upstream not to install stuff with tests
+CDEPEND="
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_kdeapps_dep kmime)
+ $(add_qt_dep qtgui)
+ dev-libs/cyrus-sasl
+"
+DEPEND="${CDEPEND}
+ test? ( $(add_qt_dep qttest) )
+"
+RDEPEND="${CDEPEND}
+ !kde-apps/kdepim-l10n
+"
+
+src_test() {
+ # tests cannot be run in parallel #605586
+ local myctestargs=(
+ -j1
+ )
+
+ kde5_src_test
+}