summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-02-07 00:11:27 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-02-07 13:59:58 +0100
commit7f45ce7728de31bb839db16ab19319f026ab0add (patch)
tree460a42bf534d6aa491db847a52a3026e3758c161 /kde-apps/konsolekalendar
parentkde-apps/gwenview: Backport exiv2-0.27 support to 18.08.3 (diff)
downloadgentoo-7f45ce7728de31bb839db16ab19319f026ab0add.tar.gz
gentoo-7f45ce7728de31bb839db16ab19319f026ab0add.tar.bz2
gentoo-7f45ce7728de31bb839db16ab19319f026ab0add.zip
kde-apps: Add KDE Applications 18.12.2
Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/konsolekalendar')
-rw-r--r--kde-apps/konsolekalendar/Manifest1
-rw-r--r--kde-apps/konsolekalendar/konsolekalendar-18.12.2.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/kde-apps/konsolekalendar/Manifest b/kde-apps/konsolekalendar/Manifest
index a42754d51f2f..ee07cecf7b31 100644
--- a/kde-apps/konsolekalendar/Manifest
+++ b/kde-apps/konsolekalendar/Manifest
@@ -1,2 +1,3 @@
DIST akonadi-calendar-tools-18.08.3.tar.xz 225844 BLAKE2B 7c0e6689049a7bd022cc5b9e1201244997b20b944f9e350e71ea0f9cd7954e2e07a3ebf431c455c925f7180880d127ba590debf16ca2544bfa762efad33ac547 SHA512 f858d8eb2b79b999459d04ccf8e8a05c53c7275b6b3cd2f80224da42f280a4d2a4d6738a235c1f3bb4b40e36d605310cda01097678441b5c4a94698fdf42097d
DIST akonadi-calendar-tools-18.12.1.tar.xz 224972 BLAKE2B 069371fa75c1c5c467553fdbc17bb9977a09cc376559ea656f5219ba4911814c0263f157676d289e4064d0afd730c91998cc574a1ce82853f15aba3be904bc38 SHA512 bb9c78c793863a124fdc102a83689550c6d7154fbf3f514cf4fbc3d3cf8a8083d8e4d2f09d55f3b47eda916b2919eab1ee3fd189183080cb45db9802af98445a
+DIST akonadi-calendar-tools-18.12.2.tar.xz 225728 BLAKE2B b20c02c075b2033cb402071d499608848ab20ed47781bf7fc8e63cf3d7a9f1b178358b93eb9e2b0aa07ace3eb5ed3819cc1dff27647990c9da916a78816f68f1 SHA512 9cd784da26f41b83ea5748112c6f932d47fb1008e2353dc5b42ae2fcd55c5f5be4b1a80b31cbe51a9b4fd7baff4155baa8b690eb9dc21a0730e3bd387ce38214
diff --git a/kde-apps/konsolekalendar/konsolekalendar-18.12.2.ebuild b/kde-apps/konsolekalendar/konsolekalendar-18.12.2.ebuild
new file mode 100644
index 000000000000..6fe96d560145
--- /dev/null
+++ b/kde-apps/konsolekalendar/konsolekalendar-18.12.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_HANDBOOK="forceoptional"
+KMNAME="akonadi-calendar-tools"
+inherit kde5
+
+DESCRIPTION="Command line interface to KDE calendars"
+HOMEPAGE+=" https://userbase.kde.org/KonsoleKalendar"
+
+LICENSE="GPL-2+ handbook? ( FDL-1.2+ )"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep ki18n)
+ $(add_kdeapps_dep akonadi)
+ $(add_kdeapps_dep akonadi-calendar)
+ $(add_kdeapps_dep calendarsupport)
+ $(add_kdeapps_dep kcalcore)
+ $(add_kdeapps_dep kcalutils)
+"
+RDEPEND="${DEPEND}
+ !kde-apps/kdepim-l10n
+ !kde-apps/konsolekalendar:4
+"
+
+src_prepare() {
+ kde5_src_prepare
+
+ # delete colliding calendarjanitor translations
+ if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ rm -f po/*/calendarjanitor.po || die
+ fi
+
+ cmake_comment_add_subdirectory calendarjanitor
+}