summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-11-10 20:11:31 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-11-10 22:30:22 +0100
commit3fa6d920893766911f27b7775c0492b409944e6a (patch)
tree108d14d03f0cae1229fb85b03791e4cc3f3a8bb9 /kde-apps/kopete
parentkde-frameworks: Add KDE Frameworks 5.64.0 (diff)
downloadgentoo-3fa6d920893766911f27b7775c0492b409944e6a.tar.gz
gentoo-3fa6d920893766911f27b7775c0492b409944e6a.tar.bz2
gentoo-3fa6d920893766911f27b7775c0492b409944e6a.zip
kde-apps: Add KDE Applications 19.08.3
Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/kopete')
-rw-r--r--kde-apps/kopete/Manifest1
-rw-r--r--kde-apps/kopete/kopete-19.08.3.ebuild183
2 files changed, 184 insertions, 0 deletions
diff --git a/kde-apps/kopete/Manifest b/kde-apps/kopete/Manifest
index 597ab7158f03..20c8c79a0cd5 100644
--- a/kde-apps/kopete/Manifest
+++ b/kde-apps/kopete/Manifest
@@ -1,2 +1,3 @@
DIST kopete-19.04.3.tar.xz 9361392 BLAKE2B def10363b7915b83fa326394275e8901c1509287ae039c12ae488f13d507172ab376fc57003169e61426e6f98b90abcfb8499e39f99b9b607cbc4d007c9e1ae4 SHA512 eeb3aed92512976503abd81454433f3ddcb397ade98dd3b21091eb81dad838c57c07d4d4131e9ce0757d54b51ba5f7d50e553e3d864fc55e0602ab5242b969c2
DIST kopete-19.08.2.tar.xz 9350652 BLAKE2B 0333c8270c178bf65a75286b07c7bf826ced5992523678f75a96ce751e373c5b3acc4829ea65a595fcbf1a5ac37c7bf32cf1f1f1344235a5cd5ef9c8e876efab SHA512 2bbedf09e41e83cd34f6fc8acadf44880750c08ca95ed514dd0718d9ab95aed6198a8179c9df26110338ebe350efd5d557015fabc269b79202da5d4d8fc63f81
+DIST kopete-19.08.3.tar.xz 9367624 BLAKE2B c7f33d5666f1e72c978c48482ec5c0d260310cf4a90e6ed913b6f2130537db3d9356761bab4186183bb5b86c61ca63303da27dfbb7a6386328d2b85bece23e40 SHA512 41bc20909ec15d6b3cd7c975363dae7a4822a6c563cc721dc2c7afc3ec6c71bc2b7fa90d08d36dedff63e0c68443c55a794743ef0d65b85306a472babe0f2c12
diff --git a/kde-apps/kopete/kopete-19.08.3.ebuild b/kde-apps/kopete/kopete-19.08.3.ebuild
new file mode 100644
index 000000000000..b63404fc64ea
--- /dev/null
+++ b/kde-apps/kopete/kopete-19.08.3.ebuild
@@ -0,0 +1,183 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_HANDBOOK="forceoptional"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.60.0
+QTMIN=5.12.3
+inherit ecm kde.org
+
+DESCRIPTION="Multi-protocol IM client based on KDE Frameworks"
+HOMEPAGE="https://userbase.kde.org/Kopete https://kde.org/applications/internet/kopete"
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="ssl v4l"
+
+# Available plugins
+#
+# addbookmarks: NO DEPS
+# alias: NO DEPS (disabled upstream)
+# autoreplace: NO DEPS
+# contactnotes: NO DEPS
+# cryptography: BROKEN (app-crypt/gpgme[cxx,qt5], kde-apps/libkleo:5)
+# highlight: NO DEPS
+# history: NO DEPS
+# latex: virtual/latex as RDEPEND
+# nowlistening: NO DEPS
+# otr: libotr
+# pipes: NO DEPS
+# privacy: NO DEPS
+# statistics: dev-db/sqlite:3
+# texteffect: NO DEPS
+# translator: NO DEPS
+# urlpicpreview: NO DEPS
+# webpresence: libxml2 libxslt
+# NOTE: By default we enable all plugins that don't have any dependencies
+PLUGINS="+addbookmarks +autoreplace +contactnotes +highlight history latex nowlistening
+otr pipes +privacy +statistics +texteffect translator +urlpicpreview webpresence"
+
+# Available protocols
+# gadu: net-libs/libgadu @since 4.3
+# groupwise: app-crypt/qca:2
+# irc: NO DEPS, probably will fail so inform user about it
+# xmpp: net-dns/libidn app-crypt/qca:2 ENABLED BY DEFAULT NETWORK
+# jingle: media-libs/speex net-libs/ortp DISABLED BY UPSTREAM
+# meanwhile: net-libs/meanwhile
+# oscar: NO DEPS
+# telepathy: net-libs/decibel
+# testbed: NO DEPS
+# winpopup: NO DEPS (we're adding samba as RDEPEND so it works)
+# zeroconf (bonjour): NO DEPS
+PROTOCOLS="gadu groupwise jingle meanwhile oscar testbed winpopup +xmpp zeroconf"
+
+# disabled protocols
+# irc: NO DEPS
+# qq: NO DEPS
+# telepathy: net-libs/decibel
+# skype, sms (until fixed)
+
+IUSE="${IUSE} ${PLUGINS} ${PROTOCOLS}"
+
+COMMON_DEPEND="
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcontacts-${KFMIN}:5
+ >=kde-frameworks/kcrash-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/khtml-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/kdelibs4support-${KFMIN}:5
+ >=kde-frameworks/kemoticons-${KFMIN}:5
+ >=kde-frameworks/khtml-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/knotifyconfig-${KFMIN}:5
+ >=kde-frameworks/kparts-${KFMIN}:5
+ >=kde-frameworks/ktexteditor-${KFMIN}:5
+ >=kde-apps/kidentitymanagement-${PVCUT}:5
+ >=kde-apps/libkleo-${PVCUT}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtsql-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ app-crypt/gpgme[cxx,qt5]
+ dev-libs/libpcre
+ media-libs/phonon[qt5(+)]
+ x11-libs/libX11
+ x11-libs/libXScrnSaver
+ gadu? ( >=net-libs/libgadu-1.8.0[threads] )
+ groupwise? ( app-crypt/qca:2[qt5(+)] )
+ jingle? (
+ dev-libs/expat
+ dev-libs/openssl:0=
+ >=media-libs/mediastreamer-2.3.0
+ media-libs/speex
+ net-libs/libsrtp:=
+ net-libs/ortp:=
+ )
+ meanwhile? ( net-libs/meanwhile )
+ otr? ( >=net-libs/libotr-4.0.0 )
+ statistics? ( dev-db/sqlite:3 )
+ v4l? ( media-libs/libv4l )
+ webpresence? (
+ dev-libs/libxml2
+ dev-libs/libxslt
+ )
+ xmpp? (
+ app-crypt/qca:2[qt5(+)]
+ net-dns/libidn:0=
+ sys-libs/zlib:=
+ )
+ zeroconf? (
+ >=kde-frameworks/kdnssd-${KFMIN}:5
+ >=kde-apps/kidentitymanagement-${PVCUT}:5
+ )
+"
+RDEPEND="${COMMON_DEPEND}
+ latex? (
+ || (
+ media-gfx/imagemagick
+ media-gfx/graphicsmagick[imagemagick]
+ )
+ virtual/latex-base
+ )
+ ssl? ( app-crypt/qca:2[ssl] )
+"
+# sms? ( app-mobilephone/smssend )
+# winpopup? ( net-fs/samba )
+DEPEND="${COMMON_DEPEND}
+ x11-base/xorg-proto
+ jingle? ( dev-libs/jsoncpp )
+"
+
+# tests hang, last checked for 4.2.96
+RESTRICT+=" test"
+
+src_configure() {
+ local x x2
+ # Handle common stuff
+ local mycmakeargs=(
+ -DWITH_qq=OFF
+ $(cmake-utils_use_find_package jingle LiboRTP)
+ $(cmake-utils_use_find_package jingle Mediastreamer)
+ $(cmake-utils_use_find_package jingle Speex)
+ -DDISABLE_VIDEOSUPPORT=$(usex !v4l)
+ )
+ # enable protocols
+ for x in ${PROTOCOLS}; do
+ case ${x/+/} in
+ jingle) x2=libjingle ;;
+ xmpp) x2=jabber ;;
+ zeroconf) x2=bonjour ;;
+ *) x2=${x/+/} ;;
+ esac
+ mycmakeargs+=( -DWITH_${x2}=$(usex ${x/+/}) )
+ done
+
+ # disable until fixed:
+ mycmakeargs+=( -DWITH_{cryptography,libjingle,skype,sms}=OFF )
+
+ # enable plugins
+ for x in ${PLUGINS}; do
+ mycmakeargs+=( -DWITH_${x/+/}=$(usex ${x/+/}) )
+ done
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+
+ if ! use ssl; then
+ if use xmpp ; then
+ if ! has_version "app-crypt/qca:2[ssl]" ; then
+ elog "In order to use ssl in xmpp you'll need to"
+ elog "install app-crypt/qca package with USE=ssl."
+ fi
+ fi
+ fi
+}