summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-11-19 20:00:38 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-11-19 20:10:27 +0100
commit96a1879e2c42cecb371dae0c59f91be5cc55c1fb (patch)
treea290e822c036012e940708c9005daa6999583b1d /kde-apps/kopete
parentapp-crypt/pinentry: stable 1.0.0-r2 for ppc, bug #632293 (diff)
downloadgentoo-96a1879e2c42cecb371dae0c59f91be5cc55c1fb.tar.gz
gentoo-96a1879e2c42cecb371dae0c59f91be5cc55c1fb.tar.bz2
gentoo-96a1879e2c42cecb371dae0c59f91be5cc55c1fb.zip
kde-apps/kopete: Import 17.08.3_p20171029 kf5-based snapshot
Tested-by: Nils Freydank <holgersson@posteo.de> Bug: https://bugs.gentoo.org/634138 Package-Manager: Portage-2.3.14, Repoman-2.3.6
Diffstat (limited to 'kde-apps/kopete')
-rw-r--r--kde-apps/kopete/Manifest1
-rw-r--r--kde-apps/kopete/kopete-17.08.3_p20171029.ebuild169
2 files changed, 170 insertions, 0 deletions
diff --git a/kde-apps/kopete/Manifest b/kde-apps/kopete/Manifest
index 3e60e3b07850..e431ffd48727 100644
--- a/kde-apps/kopete/Manifest
+++ b/kde-apps/kopete/Manifest
@@ -1,2 +1,3 @@
DIST kopete-17.04.3.tar.xz 6343664 SHA256 ec48462a464ce9ab724f503813311d9dd3aafc0124972410ac2afe14133be43f SHA512 d9c2ccec7f72e68090cd72632884b86f6b5a9cdd7fd3d23c1dedf3fe0331296d0b750c48050b80f36a58b92815e240983ab2c96eebb18997235c2a22bc4d2b26 WHIRLPOOL 2dffbb43e2eb63aa008ede23322d223436310fc85df4d8d38eec12e6ee7fe3549689beffde4e66ab2a3892ce0433e677f8d913c5ba9d9498264ec2b525815dd3
DIST kopete-17.08.3.tar.xz 6344464 SHA256 f86ccc1ca809c723d1baf2eed745f158337059263555f6fafa23ea200aacafec SHA512 0c069ec3208bb499ea2ffb92ba5a448980a0190b26a579903b126b7e72bf2c61e59c1ebc90065fc478415aed11aee67d7b4ef0f9d240c18a84e14d6163899f25 WHIRLPOOL 19290b3a238a8c39e2d961d28d32cc4f3590c5b31f52f9a6824ad8e4eafbf012017944d41f1531a6e32cf9d8c253eb759bb36798190843c0bb782285c44c5e90
+DIST kopete-17.08.3_p20171029.tar.gz 8004208 SHA256 d990006cc05cde0346d13781e9069db92904c52a73c63d411f44ff0633e01ae4 SHA512 bb70dac4f1336502fb79564e132785d3d6faf01520126441e7cde902b75ae8ac36ae796e0d24318f16e6fffeaa0ec1833a6582731ec734a86fd495dd7252fcb8 WHIRLPOOL e39b5cb909150ba2c2fd907928fe9d1fb71caa8ebcdd299b18860335b6be29b0a02bf7ba980eb39f2603eb3d6c5c952682e1aeca54ca423ec8b0e58e987a835b
diff --git a/kde-apps/kopete/kopete-17.08.3_p20171029.ebuild b/kde-apps/kopete/kopete-17.08.3_p20171029.ebuild
new file mode 100644
index 000000000000..066724406ec8
--- /dev/null
+++ b/kde-apps/kopete/kopete-17.08.3_p20171029.ebuild
@@ -0,0 +1,169 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+COMMIT=d7dbacb483124d5d6a8ad30586ec126c8514a715
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="forceoptional"
+inherit kde5 vcs-snapshot
+
+DESCRIPTION="Multi-protocol IM client based on KDE Frameworks"
+HOMEPAGE="https://kopete.kde.org https://www.kde.org/applications/internet/kopete"
+SRC_URI="https://github.com/KDE/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="ssl v4l"
+
+# tests hang, last checked for 4.2.96
+RESTRICT+=" test"
+
+# Available plugins
+#
+# addbookmarks: NO DEPS
+# alias: NO DEPS (disabled upstream)
+# autoreplace: NO DEPS
+# contactnotes: NO DEPS
+# highlight: NO DEPS
+# history: NO DEPS
+# latex: virtual/latex as RDEPEND
+# nowlistening: NO DEPS
+# otr: libotr
+# pipes: NO DEPS
+# privacy: NO DEPS
+# statistics: dev-db/sqlite:3
+# texteffect: NO DEPS
+# translator: NO DEPS
+# urlpicpreview: NO DEPS
+# webpresence: libxml2 libxslt
+# NOTE: By default we enable all plugins that don't have any dependencies
+PLUGINS="+addbookmarks +autoreplace +contactnotes +highlight history latex nowlistening
+otr pipes +privacy +statistics +texteffect translator +urlpicpreview webpresence"
+
+# Available protocols
+#
+# gadu: net-libs/libgadu @since 4.3
+# groupwise: app-crypt/qca:2
+# irc: NO DEPS, probably will fail so inform user about it
+# xmpp: net-dns/libidn app-crypt/qca:2 ENABLED BY DEFAULT NETWORK
+# meanwhile: net-libs/meanwhile
+# oscar: NO DEPS
+# telepathy: net-libs/decibel
+# testbed: NO DEPS
+# winpopup: NO DEPS (we're adding samba as RDEPEND so it works)
+# yahoo: media-libs/jasper
+# zeroconf (bonjour): NO DEPS
+# DISABLED until fixed: skype sms
+PROTOCOLS="gadu groupwise meanwhile oscar testbed winpopup +xmpp yahoo zeroconf"
+
+# disabled protocols
+# telepathy: net-libs/decibel
+# irc: NO DEPS
+# msn: net-libs/libmsn
+# qq: NO DEPS
+
+IUSE="${IUSE} ${PLUGINS} ${PROTOCOLS}"
+
+COMMONDEPEND="
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep khtml)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep kemoticons)
+ $(add_frameworks_dep khtml)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep knotifyconfig)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep ktexteditor)
+ $(add_kdeapps_dep kcontacts)
+ $(add_kdeapps_dep kidentitymanagement)
+ $(add_kdeapps_dep libkleo)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtsql)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ app-crypt/gpgme[cxx,qt5]
+ dev-libs/libpcre
+ media-libs/phonon[qt5(+)]
+ x11-libs/libX11
+ x11-libs/libXScrnSaver
+ gadu? ( >=net-libs/libgadu-1.8.0[threads] )
+ groupwise? ( app-crypt/qca:2[qt5] )
+ meanwhile? ( net-libs/meanwhile )
+ otr? ( >=net-libs/libotr-4.0.0 )
+ statistics? ( dev-db/sqlite:3 )
+ v4l? ( media-libs/libv4l )
+ webpresence? (
+ dev-libs/libxml2
+ dev-libs/libxslt
+ )
+ xmpp? (
+ app-crypt/qca:2[qt5]
+ net-dns/libidn
+ sys-libs/zlib
+ )
+ yahoo? ( media-libs/jasper )
+ zeroconf? (
+ $(add_frameworks_dep kdnssd)
+ $(add_kdeapps_dep kidentitymanagement)
+ )
+"
+RDEPEND="${COMMONDEPEND}
+ latex? (
+ || (
+ media-gfx/imagemagick
+ media-gfx/graphicsmagick[imagemagick]
+ )
+ virtual/latex-base
+ )
+ ssl? ( app-crypt/qca:2[ssl] )
+"
+DEPEND="${COMMONDEPEND}
+ x11-proto/scrnsaverproto
+"
+
+src_configure() {
+ local x x2
+ # Handle common stuff
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_Libmsn=ON
+ -DWITH_qq=OFF
+ -DDISABLE_VIDEOSUPPORT=$(usex !v4l)
+ )
+ # enable protocols
+ for x in ${PROTOCOLS}; do
+ case ${x/+/} in
+ xmpp) x2=jabber ;;
+ zeroconf) x2=bonjour ;;
+ *) x2=${x/+/} ;;
+ esac
+ mycmakeargs+=( -DWITH_${x2}=$(usex ${x/+/}) )
+ done
+
+ # disable until fixed:
+ mycmakeargs+=( -DWITH_{cryptography,libjingle,skype,sms}=OFF )
+
+ # enable plugins
+ for x in ${PLUGINS}; do
+ mycmakeargs+=( -DWITH_${x/+/}=$(usex ${x/+/}) )
+ done
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ if ! use ssl; then
+ if use xmpp ; then
+ if ! has_version "app-crypt/qca:2[ssl]" ; then
+ elog "In order to use ssl in xmpp you'll need to"
+ elog "install app-crypt/qca package with USE=ssl."
+ fi
+ fi
+ fi
+}