summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-02-07 00:11:27 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-02-07 13:59:58 +0100
commit7f45ce7728de31bb839db16ab19319f026ab0add (patch)
tree460a42bf534d6aa491db847a52a3026e3758c161 /kde-apps/libkgeomap
parentkde-apps/gwenview: Backport exiv2-0.27 support to 18.08.3 (diff)
downloadgentoo-7f45ce7728de31bb839db16ab19319f026ab0add.tar.gz
gentoo-7f45ce7728de31bb839db16ab19319f026ab0add.tar.bz2
gentoo-7f45ce7728de31bb839db16ab19319f026ab0add.zip
kde-apps: Add KDE Applications 18.12.2
Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/libkgeomap')
-rw-r--r--kde-apps/libkgeomap/Manifest1
-rw-r--r--kde-apps/libkgeomap/libkgeomap-18.12.2.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/kde-apps/libkgeomap/Manifest b/kde-apps/libkgeomap/Manifest
index 0d2665b41f1a..3e5f57e1d031 100644
--- a/kde-apps/libkgeomap/Manifest
+++ b/kde-apps/libkgeomap/Manifest
@@ -1,2 +1,3 @@
DIST libkgeomap-18.08.3.tar.xz 150976 BLAKE2B e9e7c85e2c4711fb6a68829644de2e99b47c417f915cf734928da1d93590a2b61faeef4b895d970c403dc40e844274e73204ba4fb00164fb295d13a43cd442e0 SHA512 d7b014085ba2a89d77802202878c58286307c20c25a024d748aa1271b61c7f31ade7e066f02bf44f66fbc6ab85f5cd176e09a21fbca45a3095096b4cee9ca275
DIST libkgeomap-18.12.1.tar.xz 151076 BLAKE2B 5ee1d29254a6ac1b101e639eedeeca5a9b944f4c617eee440789c8086423f49cb1d7d0b9361d1ad1d488a82a97e581c14f228a0f4ccc640f2f6da52a45091b36 SHA512 d63b99e12d6b38fae5d6b73a512242304acd65f0486801a1d881009d2328f8764eb33004d4c90aae435be34650b07cbdb114e1c3d28cbfd6d50351a4c8f3676b
+DIST libkgeomap-18.12.2.tar.xz 151104 BLAKE2B 4e2a029a083140b0c072a0d1a6cd7a91a57e61942535f9ffb61a864f3dd93c70354628518cc833663e939d798236758c1a78f616c229fb409c658535104b63c2 SHA512 fc3f6050176b89c4042c040d63ac95d24dc530b54f550a9c549b97b7cce74613fd1608fbc12247009bc97aa32ef272e11ff210f71b349903350e289fda070288
diff --git a/kde-apps/libkgeomap/libkgeomap-18.12.2.ebuild b/kde-apps/libkgeomap/libkgeomap-18.12.2.ebuild
new file mode 100644
index 000000000000..adcef4fad981
--- /dev/null
+++ b/kde-apps/libkgeomap/libkgeomap-18.12.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_TEST="true"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Wrapper library for world map components as marble, openstreetmap and googlemap"
+HOMEPAGE="https://www.digikam.org/"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_kdeapps_dep marble 'kde' '' '5=')
+ $(add_qt_dep qtconcurrent)
+ $(add_qt_dep qtgui)
+ >=dev-qt/qtwebkit-5.212.0_pre20180120:5
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_KF5KExiv2=true
+ )
+
+ kde5_src_configure
+}