summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-04-18 12:40:20 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-04-18 16:29:37 +0200
commit77996f0bd46af757187d387e251f25fdf21a33f8 (patch)
tree18c9cc45de05d82b4e08b5966b62d51dc802872e /kde-apps/pimcommon
parentwww-client/opera-beta: Old (diff)
downloadgentoo-77996f0bd46af757187d387e251f25fdf21a33f8.tar.gz
gentoo-77996f0bd46af757187d387e251f25fdf21a33f8.tar.bz2
gentoo-77996f0bd46af757187d387e251f25fdf21a33f8.zip
kde-apps: Add KDE Applications 19.04.0
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'kde-apps/pimcommon')
-rw-r--r--kde-apps/pimcommon/Manifest1
-rw-r--r--kde-apps/pimcommon/pimcommon-19.04.0.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/kde-apps/pimcommon/Manifest b/kde-apps/pimcommon/Manifest
index a5773dbc3364..69fca1fc5d2b 100644
--- a/kde-apps/pimcommon/Manifest
+++ b/kde-apps/pimcommon/Manifest
@@ -1 +1,2 @@
DIST pimcommon-18.12.3.tar.xz 295052 BLAKE2B 145329d4fec3b393a1d0b19d54871e9333823e905be491e49f37a5c76b26362100b356780a978a346feb18e27d4422ff77561eb61436683b5c996c335e04f722 SHA512 261c84c206ae9ddea9aff3c0f79436a8c32d060ee018aa7e02c698596a106ba608cacf1198b1b4d0f3df41c301ddeddb6bd6c4e344721ff616d0d0c6dd3fc7f8
+DIST pimcommon-19.04.0.tar.xz 295500 BLAKE2B b3f09607cef5ac110fe4f5c4ff06f1564fdbe33d752639e4ec59905e19b74da2309e6667bad71f4bfeb004942e5f7c2471a716bd389c306364fe0db6b2071fda SHA512 68cbd17e3fcbd9d3a442dd918b93fe01fe4bd935efdec15aa8fecc98b3793701634df02584407d8e5100a382a9d02bad2dc94bed2671d15d863adc8423da8ecb
diff --git a/kde-apps/pimcommon/pimcommon-19.04.0.ebuild b/kde-apps/pimcommon/pimcommon-19.04.0.ebuild
new file mode 100644
index 000000000000..f6917eeb6a78
--- /dev/null
+++ b/kde-apps/pimcommon/pimcommon-19.04.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_DESIGNERPLUGIN="true"
+KDE_TEST="forceoptional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Common PIM libraries"
+LICENSE="GPL-2+ LGPL-2.1+"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="share"
+
+BDEPEND="
+ dev-libs/libxslt
+"
+COMMON_DEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_kdeapps_dep akonadi)
+ $(add_kdeapps_dep akonadi-contacts)
+ $(add_kdeapps_dep kcontacts)
+ $(add_kdeapps_dep kimap)
+ $(add_kdeapps_dep kpimtextedit)
+ $(add_kdeapps_dep libkdepim)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ dev-libs/grantlee:5
+ share? ( $(add_frameworks_dep purpose) )
+"
+DEPEND="${COMMON_DEPEND}
+ $(add_frameworks_dep kiconthemes)
+ test? ( $(add_kdeapps_dep kmime) )
+"
+RDEPEND="${COMMON_DEPEND}
+ !kde-apps/kdepim-common-libs:4
+ !kde-apps/kdepim-l10n
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package share KF5Purpose)
+ )
+
+ kde5_src_configure
+}
+
+src_test() {
+ # bugs 641730, 661330
+ local myctestargs=(
+ -E "(autocorrectiontest|pimcommon-translator-translatortest)"
+ )
+
+ kde5_src_test
+}