summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-09-12 19:02:50 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-09-12 19:02:50 +0200
commit4b320689d35ef7882a004844400070f26557b458 (patch)
tree4765c8dd9c62316c139bfeaf91de4ce99dde244a /kde-apps
parentkde-apps/lskat: Punt bogus dep (diff)
downloadgentoo-4b320689d35ef7882a004844400070f26557b458.tar.gz
gentoo-4b320689d35ef7882a004844400070f26557b458.tar.bz2
gentoo-4b320689d35ef7882a004844400070f26557b458.zip
kde-apps/okular: Drop duplicate patch
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'kde-apps')
-rw-r--r--kde-apps/okular/files/okular-tests.patch112
-rw-r--r--kde-apps/okular/okular-18.04.3-r1.ebuild2
-rw-r--r--kde-apps/okular/okular-18.04.3.ebuild2
3 files changed, 2 insertions, 114 deletions
diff --git a/kde-apps/okular/files/okular-tests.patch b/kde-apps/okular/files/okular-tests.patch
deleted file mode 100644
index 0e2cdaecd4af..000000000000
--- a/kde-apps/okular/files/okular-tests.patch
+++ /dev/null
@@ -1,112 +0,0 @@
-From 5f093fa9798ad30cda115cea573d18296696a0a9 Mon Sep 17 00:00:00 2001
-From: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
-Date: Thu, 12 Oct 2017 14:09:09 +0200
-Subject: [PATCH] Move tests into existing (auto)tests subdirectories
-
----
- generators/chm/CMakeLists.txt | 12 +++---------
- generators/chm/autotests/CMakeLists.txt | 8 ++++++++
- generators/chm/autotests/chmgeneratortest.cpp | 2 +-
- generators/kimgio/CMakeLists.txt | 6 +-----
- generators/kimgio/tests/CMakeLists.txt | 5 +++++
- generators/kimgio/tests/kimgiotest.cpp | 2 +-
- 6 files changed, 19 insertions(+), 16 deletions(-)
- create mode 100644 generators/chm/autotests/CMakeLists.txt
- create mode 100644 generators/kimgio/tests/CMakeLists.txt
-
-diff --git a/generators/chm/CMakeLists.txt b/generators/chm/CMakeLists.txt
-index 9d82b9394..b3a33afe4 100644
---- a/generators/chm/CMakeLists.txt
-+++ b/generators/chm/CMakeLists.txt
-@@ -30,15 +30,9 @@ set(okularGenerator_chmlib_SRCS
- okular_add_generator(okularGenerator_chmlib ${okularGenerator_chmlib_SRCS})
- target_link_libraries(okularGenerator_chmlib okularcore ${CHM_LIBRARY} ${LIBZIP_LIBRARY} KF5::KHtml)
-
--########### autotests ###############
--
--add_definitions( -DKDESRCDIR="${CMAKE_CURRENT_SOURCE_DIR}/" )
--ecm_add_test(autotests/chmgeneratortest.cpp
-- TEST_NAME "chmgeneratortest"
-- LINK_LIBRARIES Qt5::Test KF5::CoreAddons okularcore
--)
--
--target_compile_definitions(chmgeneratortest PRIVATE -DGENERATOR_PATH="$<TARGET_FILE:okularGenerator_chmlib>")
-+if(BUILD_TESTING)
-+ add_subdirectory(autotests)
-+endif()
-
- ########### install files ###############
- install( FILES okularChm.desktop DESTINATION ${KDE_INSTALL_KSERVICES5DIR} )
-diff --git a/generators/chm/autotests/CMakeLists.txt b/generators/chm/autotests/CMakeLists.txt
-new file mode 100644
-index 000000000..59753ca45
---- /dev/null
-+++ b/generators/chm/autotests/CMakeLists.txt
-@@ -0,0 +1,8 @@
-+add_definitions( -DKDESRCDIR="${CMAKE_CURRENT_SOURCE_DIR}/../" )
-+
-+ecm_add_test(chmgeneratortest.cpp
-+ TEST_NAME "chmgeneratortest"
-+ LINK_LIBRARIES Qt5::Test KF5::CoreAddons okularcore
-+)
-+
-+target_compile_definitions(chmgeneratortest PRIVATE -DGENERATOR_PATH="$<TARGET_FILE:okularGenerator_chmlib>")
-diff --git a/generators/chm/autotests/chmgeneratortest.cpp b/generators/chm/autotests/chmgeneratortest.cpp
-index 6b0b8efc7..25fd6631a 100644
---- a/generators/chm/autotests/chmgeneratortest.cpp
-+++ b/generators/chm/autotests/chmgeneratortest.cpp
-@@ -34,7 +34,7 @@ void ChmGeneratorTest::initTestCase()
- {
- Okular::SettingsCore::instance( QStringLiteral("ChmGeneratorTest") );
- m_document = new Okular::Document( 0 );
-- const QString testFile = QStringLiteral(KDESRCDIR "autotests/data/test.chm");
-+ const QString testFile = QStringLiteral(KDESRCDIR "data/test.chm");
- QMimeDatabase db;
- const QMimeType mime = db.mimeTypeForFile( testFile );
- QCOMPARE( m_document->openDocument(testFile, QUrl(), mime), Okular::Document::OpenSuccess );
-diff --git a/generators/kimgio/CMakeLists.txt b/generators/kimgio/CMakeLists.txt
-index b8cac76df..49f893bc1 100644
---- a/generators/kimgio/CMakeLists.txt
-+++ b/generators/kimgio/CMakeLists.txt
-@@ -13,13 +13,9 @@ okular_add_generator(okularGenerator_kimgio generator_kimgio.cpp)
- target_link_libraries(okularGenerator_kimgio okularcore KF5::KExiv2 KF5::I18n)
-
- if(BUILD_TESTING)
-- add_definitions( -DKDESRCDIR="${CMAKE_CURRENT_SOURCE_DIR}/" )
-- set( kimgiotest_SRCS tests/kimgiotest.cpp ${CMAKE_SOURCE_DIR}/ui/pagepainter.cpp ${CMAKE_SOURCE_DIR}/ui/guiutils.cpp ${CMAKE_SOURCE_DIR}/ui/debug_ui.cpp )
-- ecm_add_test(${kimgiotest_SRCS} TEST_NAME "kimgiotest" LINK_LIBRARIES okularcore okularpart Qt5::Svg Qt5::Test)
-- target_compile_definitions(kimgiotest PRIVATE -DGENERATOR_PATH="$<TARGET_FILE:okularGenerator_kimgio>")
-+ add_subdirectory(tests)
- endif()
-
--
- ########### install files ###############
- install( FILES okularKimgio.desktop DESTINATION ${KDE_INSTALL_KSERVICES5DIR} )
- install( PROGRAMS okularApplication_kimgio.desktop org.kde.mobile.okular_kimgio.desktop DESTINATION ${KDE_INSTALL_APPDIR} )
-diff --git a/generators/kimgio/tests/CMakeLists.txt b/generators/kimgio/tests/CMakeLists.txt
-new file mode 100644
-index 000000000..f31bf3fe8
---- /dev/null
-+++ b/generators/kimgio/tests/CMakeLists.txt
-@@ -0,0 +1,5 @@
-+add_definitions( -DKDESRCDIR="${CMAKE_CURRENT_SOURCE_DIR}/../" )
-+
-+set( kimgiotest_SRCS kimgiotest.cpp ${CMAKE_SOURCE_DIR}/ui/pagepainter.cpp ${CMAKE_SOURCE_DIR}/ui/guiutils.cpp ${CMAKE_SOURCE_DIR}/ui/debug_ui.cpp )
-+ecm_add_test(${kimgiotest_SRCS} TEST_NAME "kimgiotest" LINK_LIBRARIES okularcore okularpart Qt5::Svg Qt5::Test)
-+target_compile_definitions(kimgiotest PRIVATE -DGENERATOR_PATH="$<TARGET_FILE:okularGenerator_kimgio>")
-diff --git a/generators/kimgio/tests/kimgiotest.cpp b/generators/kimgio/tests/kimgiotest.cpp
-index b3039a6bb..78608df9d 100644
---- a/generators/kimgio/tests/kimgiotest.cpp
-+++ b/generators/kimgio/tests/kimgiotest.cpp
-@@ -9,7 +9,7 @@
-
-
- #include "../generator_kimgio.h"
--#include "../../settings_core.h"
-+#include "../../../settings_core.h"
-
- #include <core/observer.h>
- #include <core/page.h>
---
-2.14.2
-
diff --git a/kde-apps/okular/okular-18.04.3-r1.ebuild b/kde-apps/okular/okular-18.04.3-r1.ebuild
index 8811b8c2a789..f44e22fdae41 100644
--- a/kde-apps/okular/okular-18.04.3-r1.ebuild
+++ b/kde-apps/okular/okular-18.04.3-r1.ebuild
@@ -65,7 +65,7 @@ RDEPEND="${DEPEND}
"
PATCHES=(
- "${FILESDIR}/${PN}-tests.patch"
+ "${FILESDIR}/${PN}-18.08.0-tests.patch"
"${FILESDIR}/${P}-path-traversal-issue.patch"
)
diff --git a/kde-apps/okular/okular-18.04.3.ebuild b/kde-apps/okular/okular-18.04.3.ebuild
index da9ded78a2b8..2a5d3374704a 100644
--- a/kde-apps/okular/okular-18.04.3.ebuild
+++ b/kde-apps/okular/okular-18.04.3.ebuild
@@ -64,7 +64,7 @@ RDEPEND="${DEPEND}
)
"
-PATCHES=( "${FILESDIR}/${PN}-tests.patch" )
+PATCHES=( "${FILESDIR}/${PN}-18.08.0-tests.patch" )
src_prepare() {
kde5_src_prepare