summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2022-04-23 18:03:06 +0200
committerConrad Kostecki <conikost@gentoo.org>2022-04-25 23:46:12 +0200
commitb99cc32a18130f3d76f3f025a43af9da9d4d6edb (patch)
treed4e6936ffe8d6a11a690028d22ec7bcbe6f26206 /kde-apps
parentapp-crypt/tpm2-tss: remove unused patches (diff)
downloadgentoo-b99cc32a18130f3d76f3f025a43af9da9d4d6edb.tar.gz
gentoo-b99cc32a18130f3d76f3f025a43af9da9d4d6edb.tar.bz2
gentoo-b99cc32a18130f3d76f3f025a43af9da9d4d6edb.zip
kde-apps/dolphin: remove unused patch(es)
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'kde-apps')
-rw-r--r--kde-apps/dolphin/files/dolphin-21.08.1-port-to-KTerminalLauncherJob.patch110
-rw-r--r--kde-apps/dolphin/files/dolphin-21.08.3-fix-ProvidersUrl.patch27
2 files changed, 0 insertions, 137 deletions
diff --git a/kde-apps/dolphin/files/dolphin-21.08.1-port-to-KTerminalLauncherJob.patch b/kde-apps/dolphin/files/dolphin-21.08.1-port-to-KTerminalLauncherJob.patch
deleted file mode 100644
index 2189355de6a5..000000000000
--- a/kde-apps/dolphin/files/dolphin-21.08.1-port-to-KTerminalLauncherJob.patch
+++ /dev/null
@@ -1,110 +0,0 @@
-From 27bfcde4efaf936243fc41e4a61d0cac32105ef6 Mon Sep 17 00:00:00 2001
-From: Nate Graham <nate@kde.org>
-Date: Tue, 31 Aug 2021 09:09:14 -0600
-Subject: [PATCH] Port to KTerminalLauncherJob
-
-Dolphin still uses KToolInvocation::invokeTerminal() which is
-deprecated and requires KInit. However Dolphin was ported away from
-requiring it in other ways, so it is now possible to have Dolphin
-running but not KInit, which breaks the "Open in Terminal"
-functionality.
-
-Using KTerminalLauncherJob fixes this. It was introduced in Frameworks
-5.83, so the CMake dependency version is accordingly increased.
-
-BUG: 441072
-FIXED-IN: 21.12
----
- CMakeLists.txt | 2 +-
- src/dolphinmainwindow.cpp | 14 ++++++++++----
- src/dolphinpart.cpp | 6 ++++--
- 3 files changed, 15 insertions(+), 7 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 7d50205bc..ec87cdecc 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -8,7 +8,7 @@ set (RELEASE_SERVICE_VERSION "${RELEASE_SERVICE_VERSION_MAJOR}.${RELEASE_SERVICE
- project(Dolphin VERSION ${RELEASE_SERVICE_VERSION})
-
- set(QT_MIN_VERSION "5.15.0")
--set(KF5_MIN_VERSION "5.81.0")
-+set(KF5_MIN_VERSION "5.83.0")
-
- set(CMAKE_CXX_STANDARD 17)
- set(CMAKE_CXX_STANDARD_REQUIRED ON)
-diff --git a/src/dolphinmainwindow.cpp b/src/dolphinmainwindow.cpp
-index 62e347032..f3a5e3b4e 100644
---- a/src/dolphinmainwindow.cpp
-+++ b/src/dolphinmainwindow.cpp
-@@ -56,10 +56,10 @@
- #include <KStandardAction>
- #include <KStartupInfo>
- #include <KSycoca>
-+#include <KTerminalLauncherJob>
- #include <KToggleAction>
- #include <KToolBar>
- #include <KToolBarPopupAction>
--#include <KToolInvocation>
- #include <KUrlComboBox>
- #include <KUrlNavigator>
- #include <KWindowSystem>
-@@ -1033,7 +1033,9 @@ void DolphinMainWindow::openTerminal()
- const QUrl url = m_activeViewContainer->url();
-
- if (url.isLocalFile()) {
-- KToolInvocation::invokeTerminal(QString(), {}, url.toLocalFile());
-+ auto job = new KTerminalLauncherJob(QString());
-+ job->setWorkingDirectory(url.toLocalFile());
-+ job->start();
- return;
- }
-
-@@ -1047,14 +1049,18 @@ void DolphinMainWindow::openTerminal()
- statUrl = job->mostLocalUrl();
- }
-
-- KToolInvocation::invokeTerminal(QString(), {}, statUrl.isLocalFile() ? statUrl.toLocalFile() : QDir::homePath());
-+ auto job = new KTerminalLauncherJob(QString());
-+ job->setWorkingDirectory(statUrl.isLocalFile() ? statUrl.toLocalFile() : QDir::homePath());
-+ job->start();
- });
-
- return;
- }
-
- // Nothing worked, just use $HOME
-- KToolInvocation::invokeTerminal(QString(), {}, QDir::homePath());
-+ auto job = new KTerminalLauncherJob(QString());
-+ job->setWorkingDirectory(QDir::homePath());
-+ job->start();
- }
-
- void DolphinMainWindow::editSettings()
-diff --git a/src/dolphinpart.cpp b/src/dolphinpart.cpp
-index 9c551d67a..8d528f418 100644
---- a/src/dolphinpart.cpp
-+++ b/src/dolphinpart.cpp
-@@ -32,7 +32,7 @@
- #include <KPluginFactory>
- #include <KIO/CommandLauncherJob>
- #include <KSharedConfig>
--#include <KToolInvocation>
-+#include <KTerminalLauncherJob>
-
- #include <QActionGroup>
- #include <QApplication>
-@@ -567,7 +567,9 @@ QString DolphinPart::localFilePathOrHome() const
-
- void DolphinPart::slotOpenTerminal()
- {
-- KToolInvocation::invokeTerminal(QString(), {}, localFilePathOrHome());
-+ auto job = new KTerminalLauncherJob(QString());
-+ job->setWorkingDirectory(localFilePathOrHome());
-+ job->start();
- }
-
- void DolphinPart::slotFindFile()
---
-GitLab
-
diff --git a/kde-apps/dolphin/files/dolphin-21.08.3-fix-ProvidersUrl.patch b/kde-apps/dolphin/files/dolphin-21.08.3-fix-ProvidersUrl.patch
deleted file mode 100644
index 74472fd0943d..000000000000
--- a/kde-apps/dolphin/files/dolphin-21.08.3-fix-ProvidersUrl.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From d0898592a17d14fc8d48fc5cba71f3d57f0a1856 Mon Sep 17 00:00:00 2001
-From: Ben Cooksley <bcooksley@kde.org>
-Date: Thu, 30 Dec 2021 07:31:41 +1300
-Subject: [PATCH] Use the CDN based endpoint rather than the legacy endpoint
- which hits our download redirector.
-
-CCMAIL: distributions@kde.org
-
-(cherry picked from commit 694e4e24526c5f55e162ad9288782e7c82cac38f)
----
- src/settings/contextmenu/servicemenu.knsrc | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/settings/contextmenu/servicemenu.knsrc b/src/settings/contextmenu/servicemenu.knsrc
-index 59d459895..4374082c7 100644
---- a/src/settings/contextmenu/servicemenu.knsrc
-+++ b/src/settings/contextmenu/servicemenu.knsrc
-@@ -1,5 +1,5 @@
- [KNewStuff3]
--ProvidersUrl=https://download.kde.org/ocs/providers.xml
-+ProvidersUrl=https://autoconfig.kde.org/ocs/providers.xml
- Categories=Dolphin Service Menus
- TargetDir=servicemenu-download
- Uncompress=never
---
-GitLab
-