summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2016-10-30 13:54:36 +0100
committerJohannes Huber <johu@gentoo.org>2016-10-30 13:55:16 +0100
commite4b662605db25fbc24a21ccc168c398699d61ac5 (patch)
treee41c7ffca2c5678d22f1fa2394736fad0f4f30a6 /kde-apps
parentkde-apps/kdepim-common-libs: Pin app-office/akonadi-server to slot 4 (diff)
downloadgentoo-e4b662605db25fbc24a21ccc168c398699d61ac5.tar.gz
gentoo-e4b662605db25fbc24a21ccc168c398699d61ac5.tar.bz2
gentoo-e4b662605db25fbc24a21ccc168c398699d61ac5.zip
app-office/akonadi-server -> kde-apps/akonadi
Diffstat (limited to 'kde-apps')
-rw-r--r--kde-apps/akonadi/Manifest1
-rw-r--r--kde-apps/akonadi/akonadi-1.13.1_pre20160203-r1.ebuild127
-rw-r--r--kde-apps/akonadi/akonadi-16.08.2.ebuild1
-rw-r--r--kde-apps/akonadi/files/akonadi-1.13.0-mysql56-crash.patch20
-rw-r--r--kde-apps/akonadi/files/akonadi-1.13.1-mysql.conf.patch38
-rw-r--r--kde-apps/akonadiconsole/akonadiconsole-4.14.11_pre20160211.ebuild2
-rw-r--r--kde-apps/kdepim-common-libs/kdepim-common-libs-4.14.11_pre20160211.ebuild2
-rw-r--r--kde-apps/kdepim-runtime/kdepim-runtime-4.14.11_pre20160211.ebuild2
-rw-r--r--kde-apps/kdepimlibs/kdepimlibs-4.14.10-r1.ebuild3
-rw-r--r--kde-apps/kdepimlibs/kdepimlibs-4.14.11_pre20160211-r1.ebuild3
-rw-r--r--kde-apps/kmail/kmail-4.14.11_pre20160211.ebuild6
-rw-r--r--kde-apps/ktnef/ktnef-4.14.11_pre20160211.ebuild2
12 files changed, 195 insertions, 12 deletions
diff --git a/kde-apps/akonadi/Manifest b/kde-apps/akonadi/Manifest
index 14878e44f35..d0fc05054b1 100644
--- a/kde-apps/akonadi/Manifest
+++ b/kde-apps/akonadi/Manifest
@@ -1 +1,2 @@
+DIST akonadi-1.13.1_pre20160203.tar.gz 384556 SHA256 4243b32e529be6aadc38dc4463cb6e7cede9442c05cfc04ba679dde28f37aa96 SHA512 0ef8213f504ad1e500a2c1ce19a7575cd1fd8b7ffc7e5fb0bd2437639d8c458c47bbfea7734fcd3e200136a661331dde32af0b064f0b25d324138ce6e35d15f3 WHIRLPOOL 69eff1889a19f8d5714d7e71a106871172cd25c651ea30046ab81270cf7e46c7a1983cf20fd8d5fd8ad243d70e881be705d57b0b93b54248d086e7b253a4873a
DIST akonadi-16.08.2.tar.xz 1021860 SHA256 e60d64528a10e6484d54850c12866bea6efd891ee9d304f5e4afb424fb502d90 SHA512 7a83f2f9c4396e3e68ec44e7da6f25aa05d2acba63d4e48ffaebea900f803b1bce6b0c76685d8b3a28acb2b5e08b532a67ab8108858ecd2622b821174c5f0cea WHIRLPOOL 3976a119cfd8ae566103580d799db03cfcca51f43f01e303b98abca5743bc4dd23d832f55df52e357492b2d0a8fba3bf5b74daa3b9109437de931e3c3f1ce811
diff --git a/kde-apps/akonadi/akonadi-1.13.1_pre20160203-r1.ebuild b/kde-apps/akonadi/akonadi-1.13.1_pre20160203-r1.ebuild
new file mode 100644
index 00000000000..a4f5fbea7bd
--- /dev/null
+++ b/kde-apps/akonadi/akonadi-1.13.1_pre20160203-r1.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+if [[ ${PV} = *_pre* ]]; then
+ # KDE quickgit https certificate issue
+ # COMMIT_ID="18ed37d89b8185ac15a8bfe245de8a88d17f2c64"
+ # SRC_URI="https://quickgit.kde.org/?p=${PN}.git&a=snapshot&h=${COMMIT_ID}&fmt=tgz -> ${P}.tar.gz"
+ SRC_URI="https://dev.gentoo.org/~johu/distfiles/${P}.tar.gz"
+ S="${WORKDIR}/${PN}"
+else
+ SRC_URI="mirror://kde/stable/${PN}/src/${P}.tar.bz2"
+fi
+inherit cmake-utils
+
+DESCRIPTION="The server part of Akonadi"
+HOMEPAGE="https://pim.kde.org/akonadi"
+
+LICENSE="LGPL-2.1"
+SLOT="4"
+KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="+mysql postgres sqlite test"
+
+REQUIRED_USE="|| ( sqlite mysql postgres )"
+
+CDEPEND="
+ dev-libs/boost:=
+ >=dev-qt/qtcore-4.8.5:4
+ >=dev-qt/qtdbus-4.8.5:4
+ >=dev-qt/qtgui-4.8.5:4
+ >=dev-qt/qtsql-4.8.5:4[mysql?,postgres?]
+ >=dev-qt/qttest-4.8.5:4
+ x11-misc/shared-mime-info
+ sqlite? ( dev-db/sqlite:3 )
+"
+DEPEND="${CDEPEND}
+ dev-libs/libxslt
+ >=dev-util/automoc-0.9.88
+ test? ( sys-apps/dbus )
+"
+RDEPEND="${CDEPEND}
+ mysql? ( virtual/mysql )
+ postgres? ( dev-db/postgresql[server] )
+"
+
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.13.0-mysql56-crash.patch"
+ "${FILESDIR}/${PN}-1.13.1-mysql.conf.patch"
+)
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ [[ $(gcc-major-version) -lt 4 ]] || \
+ ( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 7 ]] ) \
+ && die "Sorry, but gcc-4.6 and earlier won't work (see bug #520102)."
+ fi
+}
+
+pkg_setup() {
+ # Set default storage backend in order: MySQL, SQLite PostgreSQL
+ # reverse driver check to keep the order
+ if use postgres; then
+ DRIVER="QPSQL"
+ AVAILABLE+=" ${DRIVER}"
+ fi
+
+ if use sqlite; then
+ DRIVER="QSQLITE3"
+ AVAILABLE+=" ${DRIVER}"
+ fi
+
+ if use mysql; then
+ DRIVER="QMYSQL"
+ AVAILABLE+=" ${DRIVER}"
+ fi
+
+ # Notify about MySQL is recommend by upstream
+ if use sqlite || has_version "<${CATEGORY}/${P}[sqlite]"; then
+ ewarn
+ ewarn "We strongly recommend you change your Akonadi database backend to MySQL in your"
+ ewarn "user configuration. This is the backend recommended by KDE upstream. PostgreSQL"
+ ewarn "is also known to work very well but requires manual dump and import on major"
+ ewarn "upgrades of the DB."
+ ewarn "You can select the backend in your ~/.config/akonadi/akonadiserverrc."
+ ewarn "Available drivers are:${AVAILABLE}"
+ ewarn
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DINSTALL_QSQLITE_IN_QT_PREFIX=ON
+ -DWITH_SOPRANO=FALSE
+ -DAKONADI_BUILD_TESTS=$(usex test)
+ -DAKONADI_BUILD_QSQLITE=$(usex sqlite)
+ -DQT5_BUILD=OFF
+ )
+
+ cmake-utils_src_configure
+}
+
+src_test() {
+ export $(dbus-launch)
+ cmake-utils_src_test
+}
+
+src_install() {
+ # Who knows, maybe it accidentally fixes our permission issues
+ cat <<-EOF > "${T}"/akonadiserverrc
+[%General]
+Driver=${DRIVER}
+EOF
+ insinto /usr/share/config/akonadi
+ doins "${T}"/akonadiserverrc
+
+ cmake-utils_src_install
+}
+
+pkg_postinst() {
+ elog "${DRIVER} has been set as your default akonadi storage backend."
+ elog "You can override it in your ~/.config/akonadi/akonadiserverrc."
+ elog "Available drivers are: ${AVAILABLE}"
+}
diff --git a/kde-apps/akonadi/akonadi-16.08.2.ebuild b/kde-apps/akonadi/akonadi-16.08.2.ebuild
index 486b50898d9..770f895e8e6 100644
--- a/kde-apps/akonadi/akonadi-16.08.2.ebuild
+++ b/kde-apps/akonadi/akonadi-16.08.2.ebuild
@@ -51,7 +51,6 @@ DEPEND="${COMMON_DEPEND}
RDEPEND="${COMMON_DEPEND}
mysql? ( virtual/mysql )
postgres? ( dev-db/postgresql )
- !app-office/akonadi-server:4
!kde-apps/kdepimlibs
"
diff --git a/kde-apps/akonadi/files/akonadi-1.13.0-mysql56-crash.patch b/kde-apps/akonadi/files/akonadi-1.13.0-mysql56-crash.patch
new file mode 100644
index 00000000000..20496183276
--- /dev/null
+++ b/kde-apps/akonadi/files/akonadi-1.13.0-mysql56-crash.patch
@@ -0,0 +1,20 @@
+diff -aruN akonadi-1.13.0.old/server/src/storage/dbconfigmysql.cpp akonadi-1.13.0/server/src/storage/dbconfigmysql.cpp
+--- akonadi-1.13.0.old/server/src/storage/dbconfigmysql.cpp 2014-08-10 06:38:58.000000000 -0400
++++ akonadi-1.13.0/server/src/storage/dbconfigmysql.cpp 2015-01-08 15:08:36.906134212 -0500
+@@ -76,6 +76,7 @@
+ << QLatin1String( "/usr/local/sbin" )
+ << QLatin1String( "/usr/local/libexec" )
+ << QLatin1String( "/usr/libexec" )
++ << QLatin1String( "/usr/share/mysql/scripts" )
+ << QLatin1String( "/opt/mysql/libexec" )
+ << QLatin1String( "/opt/local/lib/mysql5/bin" )
+ << QLatin1String( "/opt/mysql/sbin" );
+@@ -278,7 +279,7 @@
+ // first run, some MySQL versions need a mysql_install_db run for that
+ const QString confFile = XdgBaseDirs::findResourceFile( "config", QLatin1String( "akonadi/mysql-global.conf" ) );
+ if ( QDir( dataDir ).entryList( QDir::NoDotAndDotDot | QDir::AllEntries ).isEmpty() && !mMysqlInstallDbPath.isEmpty() ) {
+- const QStringList arguments = QStringList() << QString::fromLatin1( "--force" ) << QString::fromLatin1( "--defaults-file=%1" ).arg( confFile ) << QString::fromLatin1( "--datadir=%1/" ).arg( dataDir );
++ const QStringList arguments = QStringList() << QString::fromLatin1( "--force" ) << QString::fromLatin1( "--defaults-file=%1" ).arg( confFile ) << QString::fromLatin1( "--datadir=%1/" ).arg( dataDir ) << QString::fromLatin1( "--basedir=/usr" ) ;
+ QProcess::execute( mMysqlInstallDbPath, arguments );
+ }
+
diff --git a/kde-apps/akonadi/files/akonadi-1.13.1-mysql.conf.patch b/kde-apps/akonadi/files/akonadi-1.13.1-mysql.conf.patch
new file mode 100644
index 00000000000..a090636e725
--- /dev/null
+++ b/kde-apps/akonadi/files/akonadi-1.13.1-mysql.conf.patch
@@ -0,0 +1,38 @@
+From: Daniel Vrátil <dvratil@kde.org>
+Date: Tue, 16 Feb 2016 17:26:22 +0000
+Subject: Drop mysql.conf option removed in MySQL 5.7
+X-Git-Url: http://quickgit.kde.org/?p=akonadi.git&a=commitdiff&h=9a9f7eaa38023f70c6fa85a87359a487ccf7a48c
+---
+Drop mysql.conf option removed in MySQL 5.7
+
+innodb_additional_mem_pool_size option has been deprecated in MySQL 5.6
+and removed in 5.7 so MySQL will no longer start it the option is present
+in mysql.conf.
+
+The option still seems to be supported by MariaDB, but the default value
+we had in the mysql.conf was below the minimum allowed value, so the harm
+in removing the option for MariaDB should be minimal.
+
+If options supported by MySQL and MariaDB begin to diverge more in the future
+we might consider having separate config files for each database.
+
+* 2016-02-21: Adjusted path for 1.13 branch
+---
+
+
+--- a/server/src/storage/mysql-global.conf
++++ b/server/src/storage/mysql-global.conf
+@@ -37,9 +37,9 @@
+ # use InnoDB for transactions and better crash recovery
+ default_storage_engine=innodb
+
+-# memory pool InnoDB uses to store data dictionary information and other internal data structures (default:1M)
+-# Deprecated in MySQL >= 5.6.3
+-innodb_additional_mem_pool_size=1M
++# memory pool InnoDB uses to store data dictionary information and other internal data structures (default:8M)
++# Deprecated in MySQL >= 5.6.3, removed in 5.7 (works in MariaDB)
++# innodb_additional_mem_pool_size=8M
+
+ # memory buffer InnoDB uses to cache data and indexes of its tables (default:128M)
+ # Larger values means less I/O
+
diff --git a/kde-apps/akonadiconsole/akonadiconsole-4.14.11_pre20160211.ebuild b/kde-apps/akonadiconsole/akonadiconsole-4.14.11_pre20160211.ebuild
index 68d714e6872..f1412490b55 100644
--- a/kde-apps/akonadiconsole/akonadiconsole-4.14.11_pre20160211.ebuild
+++ b/kde-apps/akonadiconsole/akonadiconsole-4.14.11_pre20160211.ebuild
@@ -16,9 +16,9 @@ KEYWORDS="amd64 ~arm x86 ~amd64-linux ~x86-linux"
IUSE="debug"
DEPEND="
- >=app-office/akonadi-server-1.12.90:4
$(add_kdeapps_dep kdepimlibs 'akonadi(+)')
$(add_kdeapps_dep kdepim-common-libs)
+ kde-apps/akonadi:4
"
RDEPEND="${DEPEND}"
diff --git a/kde-apps/kdepim-common-libs/kdepim-common-libs-4.14.11_pre20160211.ebuild b/kde-apps/kdepim-common-libs/kdepim-common-libs-4.14.11_pre20160211.ebuild
index fb1eb293186..29545780bb0 100644
--- a/kde-apps/kdepim-common-libs/kdepim-common-libs-4.14.11_pre20160211.ebuild
+++ b/kde-apps/kdepim-common-libs/kdepim-common-libs-4.14.11_pre20160211.ebuild
@@ -21,8 +21,8 @@ DEPEND="
$(add_kdebase_dep baloo '' 4.14.3)
$(add_kdeapps_dep kdepimlibs 'akonadi(+)')
app-crypt/gpgme
- >=app-office/akonadi-server-1.12.90:4
dev-libs/grantlee:0
+ kde-apps/akonadi:4
google? ( net-libs/libkgapi:4 )
"
RDEPEND="${DEPEND}
diff --git a/kde-apps/kdepim-runtime/kdepim-runtime-4.14.11_pre20160211.ebuild b/kde-apps/kdepim-runtime/kdepim-runtime-4.14.11_pre20160211.ebuild
index a1be9143ae0..8abef2016e6 100644
--- a/kde-apps/kdepim-runtime/kdepim-runtime-4.14.11_pre20160211.ebuild
+++ b/kde-apps/kdepim-runtime/kdepim-runtime-4.14.11_pre20160211.ebuild
@@ -21,10 +21,10 @@ RESTRICT="test"
DEPEND="
$(add_kdeapps_dep kdepimlibs 'akonadi(+)' ${PV})
- >=app-office/akonadi-server-1.12.90:4
dev-libs/boost:=
dev-libs/libxml2:2
dev-libs/libxslt
+ kde-apps/akonadi:4
x11-misc/shared-mime-info
google? ( >=net-libs/libkgapi-2.0:4 )
"
diff --git a/kde-apps/kdepimlibs/kdepimlibs-4.14.10-r1.ebuild b/kde-apps/kdepimlibs/kdepimlibs-4.14.10-r1.ebuild
index 8e8d64bb4d7..b9c12d07b55 100644
--- a/kde-apps/kdepimlibs/kdepimlibs-4.14.10-r1.ebuild
+++ b/kde-apps/kdepimlibs/kdepimlibs-4.14.10-r1.ebuild
@@ -18,14 +18,13 @@ IUSE="debug ldap prison"
RESTRICT="test"
DEPEND="
- !kde-misc/akonadi-social-utils
>=app-crypt/gpgme-1.1.6
- >=app-office/akonadi-server-1.12.90:4
>=dev-libs/boost-1.35.0-r5:=
dev-libs/libgpg-error
>=dev-libs/libical-0.48-r2:=
dev-libs/cyrus-sasl
>=dev-libs/qjson-0.8.1
+ kde-apps/akonadi:4
media-libs/phonon[qt4]
x11-misc/shared-mime-info
prison? ( media-libs/prison:4 )
diff --git a/kde-apps/kdepimlibs/kdepimlibs-4.14.11_pre20160211-r1.ebuild b/kde-apps/kdepimlibs/kdepimlibs-4.14.11_pre20160211-r1.ebuild
index 5a445ae864e..20a99308518 100644
--- a/kde-apps/kdepimlibs/kdepimlibs-4.14.11_pre20160211-r1.ebuild
+++ b/kde-apps/kdepimlibs/kdepimlibs-4.14.11_pre20160211-r1.ebuild
@@ -23,12 +23,12 @@ RESTRICT="test"
DEPEND="
>=app-crypt/gpgme-1.1.6
- >=app-office/akonadi-server-1.12.90:4
>=dev-libs/boost-1.35.0-r5:=
dev-libs/libgpg-error
>=dev-libs/libical-0.48-r2:=
dev-libs/cyrus-sasl
>=dev-libs/qjson-0.8.1
+ kde-apps/akonadi:4
media-libs/phonon[qt4]
x11-misc/shared-mime-info
prison? ( media-libs/prison:4 )
@@ -38,7 +38,6 @@ DEPEND="
# bug #418071
RDEPEND="${DEPEND}
!<kde-apps/kdepim-runtime-4.4.11.1-r2:4
- !kde-misc/akonadi-social-utils
"
PATCHES=(
diff --git a/kde-apps/kmail/kmail-4.14.11_pre20160211.ebuild b/kde-apps/kmail/kmail-4.14.11_pre20160211.ebuild
index c920bd79a11..7b526d903cf 100644
--- a/kde-apps/kmail/kmail-4.14.11_pre20160211.ebuild
+++ b/kde-apps/kmail/kmail-4.14.11_pre20160211.ebuild
@@ -97,14 +97,14 @@ pkg_postinst() {
echo
fi
- if has_version "app-office/akonadi-server[sqlite]"; then
+ if has_version "kde-apps/akonadi[sqlite]"; then
ewarn
ewarn "We strongly recommend you set your Akonadi database backend to QMYSQL in your"
ewarn "user configuration. This is the backend recommended by KDE upstream."
ewarn "Reports indicate that kde-apps/kmail-4.10 does not work properly with the sqlite"
ewarn "backend anymore."
- if has_version "app-office/akonadi-server[-mysql]"; then
- ewarn "FOR THAT, YOU WILL HAVE TO RE-BUILD app-office/akonadi-server WITH mysql USEFLAG ENABLED."
+ if has_version "kde-apps/akonadi[-mysql]"; then
+ ewarn "FOR THAT, YOU WILL HAVE TO RE-BUILD kde-apps/akonadi WITH mysql USEFLAG ENABLED."
fi
ewarn "You can select the backend in your ~/.config/akonadi/akonadiserverrc."
ewarn
diff --git a/kde-apps/ktnef/ktnef-4.14.11_pre20160211.ebuild b/kde-apps/ktnef/ktnef-4.14.11_pre20160211.ebuild
index 19285758871..762d023f089 100644
--- a/kde-apps/ktnef/ktnef-4.14.11_pre20160211.ebuild
+++ b/kde-apps/ktnef/ktnef-4.14.11_pre20160211.ebuild
@@ -18,8 +18,8 @@ LICENSE="LGPL-2.1"
IUSE="debug"
DEPEND="
- app-office/akonadi-server:4
$(add_kdeapps_dep kdepimlibs 'akonadi(+)')
+ kde-apps/akonadi:4
"
RDEPEND="${DEPEND}"