summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2015-08-28 03:15:45 +1000
committerMichael Palimaka <kensington@gentoo.org>2015-08-28 03:16:29 +1000
commite7a968fc3b5fbd4281903776ae70ab6d8de51af8 (patch)
tree70744cc644ac398d433b3a5c1cb2845e01500b38 /kde-apps
parentsys-libs/ncurses: Add bridging ebuild to fix slot move for 5/6 -> 0/6 (diff)
downloadgentoo-e7a968fc3b5fbd4281903776ae70ab6d8de51af8.tar.gz
gentoo-e7a968fc3b5fbd4281903776ae70ab6d8de51af8.tar.bz2
gentoo-e7a968fc3b5fbd4281903776ae70ab6d8de51af8.zip
kde-apps/kdebase-runtime-meta: version bump 15.08.0.
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'kde-apps')
-rw-r--r--kde-apps/kdebase-runtime-meta/kdebase-runtime-meta-15.08.0.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/kde-apps/kdebase-runtime-meta/kdebase-runtime-meta-15.08.0.ebuild b/kde-apps/kdebase-runtime-meta/kdebase-runtime-meta-15.08.0.ebuild
new file mode 100644
index 000000000000..0af4baf6a0e0
--- /dev/null
+++ b/kde-apps/kdebase-runtime-meta/kdebase-runtime-meta-15.08.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit kde5-meta-pkg
+
+DESCRIPTION="Merge this to pull in all kdebase-runtime-derived packages"
+KEYWORDS="~amd64 ~x86"
+IUSE="crash-reporter minimal"
+
+RDEPEND="
+ $(add_kdeapps_dep kcmshell)
+ $(add_kdeapps_dep kdebase-data)
+ $(add_kdeapps_dep kdebase-desktoptheme)
+ $(add_kdeapps_dep kdebase-menu)
+ $(add_kdeapps_dep kdebase-menu-icons)
+ $(add_kdeapps_dep kdebugdialog)
+ $(add_kdeapps_dep kdesu)
+ $(add_kdeapps_dep kdontchangethehostname)
+ $(add_kdeapps_dep keditfiletype)
+ $(add_kdeapps_dep kfile)
+ $(add_kdeapps_dep kglobalaccel)
+ $(add_kdeapps_dep kiconfinder)
+ $(add_kdeapps_dep kimgio)
+ $(add_kdeapps_dep kioclient)
+ $(add_kdeapps_dep kmimetypefinder)
+ $(add_kdeapps_dep knewstuff)
+ $(add_kdeapps_dep knotify)
+ $(add_kdeapps_dep kpasswdserver)
+ $(add_kdeapps_dep kquitapp)
+ $(add_kdeapps_dep kreadconfig)
+ $(add_kdeapps_dep kstart)
+ $(add_kdeapps_dep ktimezoned)
+ $(add_kdeapps_dep ktraderclient)
+ $(add_kdeapps_dep kuiserver)
+ $(add_kdeapps_dep kurifilter-plugins)
+ $(add_kdeapps_dep kwalletd)
+ $(add_kdeapps_dep phonon-kde)
+ $(add_kdeapps_dep plasma-runtime)
+ $(add_kdeapps_dep renamedlg-plugins)
+ $(add_kdeapps_dep solid-runtime)
+ crash-reporter? ( $(add_kdeapps_dep drkonqi ) )
+ minimal? ( $(add_kdeapps_dep solid-runtime '-bluetooth') )
+ !minimal? (
+ $(add_kdeapps_dep attica)
+ $(add_kdeapps_dep kcontrol)
+ $(add_kdeapps_dep kdebase-kioslaves)
+ $(add_kdeapps_dep knetattach)
+ )
+"
+REQUIRED_USE="minimal? ( !crash-reporter )"