summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2017-09-09 13:29:10 +0200
committerJohannes Huber <johu@gentoo.org>2017-09-09 13:29:51 +0200
commit449b70581d8bd53212434c5c5b883099333502de (patch)
treecbfac5508f05db31d1c2b685f4e98d89c5a3ddde /kde-frameworks/frameworkintegration
parentx11-misc/compton: Remove desktop-misc maintainership (reverts initial commit). (diff)
downloadgentoo-449b70581d8bd53212434c5c5b883099333502de.tar.gz
gentoo-449b70581d8bd53212434c5c5b883099333502de.tar.bz2
gentoo-449b70581d8bd53212434c5c5b883099333502de.zip
kde-frameworks: Version bump KDE Frameworks 5.38.0
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'kde-frameworks/frameworkintegration')
-rw-r--r--kde-frameworks/frameworkintegration/Manifest1
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.38.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/kde-frameworks/frameworkintegration/Manifest b/kde-frameworks/frameworkintegration/Manifest
index 64b9ec728cfd..5a6378964202 100644
--- a/kde-frameworks/frameworkintegration/Manifest
+++ b/kde-frameworks/frameworkintegration/Manifest
@@ -1,2 +1,3 @@
DIST frameworkintegration-5.34.0.tar.xz 1751972 SHA256 40ac4623c0292442853ac8e905c0282aaa0063c594693beae7c07f69bfc80143 SHA512 ccb9b954471ad423c72f7bc7db5034f902120df78b7b6a48689ea55631bf0c7396a2b06862fa84106212bee470bb2b6f072d2182904c1720d27a1f943fa07bc7 WHIRLPOOL 7a18565103098f63522d0b5b7d9a343c1f5ee2b3526ab8b353943696fe00680afd1433582ea718fae0ee6ee732d898cdb56985ab481575634e751b5add7b3b83
DIST frameworkintegration-5.37.0.tar.xz 1752004 SHA256 aa8ca045ba97899b739077e07a961b9e402520a0abfcee8be90baa85251c9e5d SHA512 ecff45b2d7138621b19b9b276c4a2d7940c156ee81d85789d598178179e524ed6fef014c9d6615b91d2ea9c4c9a058d5009f44899834c541c36301f9ca581dd7 WHIRLPOOL 19d6589c03fb9899b3e823304c159cd345a94735995d27e47463c12c428cfb7c75f243fb174d7f3639baef37723d7407edde3f534c361bab8314037d0698565e
+DIST frameworkintegration-5.38.0.tar.xz 1752696 SHA256 08cb88ef7c7ceb7cd43cbc7f3040daf7128d22bb75f8eb3956d55afd3e1b3670 SHA512 d7a992709c15c3fe6f4fb6ff83c75574748e2b46fd5f20e13b089fb2dbdb721d83e0d62b31230b72dcdf5f747a7a94870619b5b40868fea580c43f109f56ff07 WHIRLPOOL 0b40775a6f87a4061589ea1f9ea588978f90e5d7768c1fdce160521737c3231f95548c2b1955867283f9e754436a5609f1cdb785a247cdf243233ff754c3f15f
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.38.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.38.0.ebuild
new file mode 100644
index 000000000000..5664713979f0
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.38.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="appstream X"
+
+RDEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kpackage)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ appstream? (
+ app-admin/packagekit-qt
+ dev-libs/appstream[qt5]
+ )
+ X? (
+ $(add_qt_dep qtx11extras)
+ x11-libs/libxcb
+ )
+"
+DEPEND="${RDEPEND}"
+
+# requires running kde environment
+RESTRICT+=" test"
+
+src_prepare() {
+ punt_bogus_dep Qt5 DBus
+ kde5_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package appstream AppStreamQt)
+ $(cmake-utils_use_find_package appstream packagekitqt5)
+ $(cmake-utils_use_find_package X XCB)
+ )
+
+ kde5_src_configure
+}