summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-08-11 14:35:16 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-08-11 14:35:16 +0200
commite9e7fbc7f1c7514a10cef7a47b4a940d0676410e (patch)
tree2938f0df53e4ecfd1cfb02fe5b2f9757b497e9cd /kde-frameworks/kauth
parentprofiles: amd64-fbsd: Drop obsolete dev-qt/qtgui[nas] p.use.mask (diff)
downloadgentoo-e9e7fbc7f1c7514a10cef7a47b4a940d0676410e.tar.gz
gentoo-e9e7fbc7f1c7514a10cef7a47b4a940d0676410e.tar.bz2
gentoo-e9e7fbc7f1c7514a10cef7a47b4a940d0676410e.zip
kde-frameworks: Add KDE Frameworks 5.49.0
Package-Manager: Portage-2.3.45, Repoman-2.3.10
Diffstat (limited to 'kde-frameworks/kauth')
-rw-r--r--kde-frameworks/kauth/Manifest1
-rw-r--r--kde-frameworks/kauth/kauth-5.49.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/kde-frameworks/kauth/Manifest b/kde-frameworks/kauth/Manifest
index ea2284b19f81..f4f88fff69ff 100644
--- a/kde-frameworks/kauth/Manifest
+++ b/kde-frameworks/kauth/Manifest
@@ -1,2 +1,3 @@
DIST kauth-5.46.0.tar.xz 84932 BLAKE2B 10a3e1f612f2569894236da4fd7bd8f02259dd9258364dcdde7685691e49789805d3ba8fffd662779cc64a74881bc2ef5907173416d876fb8a321eb903a7139b SHA512 dd94d8923ea7caa1f420d4a906876e1082c1afc97130731f579e6c3e9b377ec9c1abfa1d489ed60c11fff248da455d87a8cde8a581156d61bf6410b8c19d3401
DIST kauth-5.48.0.tar.xz 84920 BLAKE2B a2a800a5bf0c3cfe9c32b4b7b668c8905618a322faefbdce6c56071a40ef4321a913aef2ce034092aabe2769423b69acf874be1582bc5f2f768f4a1e78830145 SHA512 34023dc452ebc0297c2a866b848109d4e34dcd4afccc541e76d98f07b2817b9928bc4ab100eded4f326aa6fa18f6c76cef6723fcd09cd8b56649b7175c1812bb
+DIST kauth-5.49.0.tar.xz 84944 BLAKE2B bfd1ff03ff0477b4b8284c8240d2a64ae682cfe4db61309532363c5da20b08a54d4b95cc47964ea5fff6a2def30df5becbb84570a7f2e2e4b89a1c9ee7478d20 SHA512 123648925dbc6fec8068e3ba9f7703437e3662929d26ba244d0a9f856dd7c991f0c5701aca6644f129ab33a41df8c0ea231fee62967be4afbf76c64f4414acd6
diff --git a/kde-frameworks/kauth/kauth-5.49.0.ebuild b/kde-frameworks/kauth/kauth-5.49.0.ebuild
new file mode 100644
index 000000000000..ee6570cb1d6b
--- /dev/null
+++ b/kde-frameworks/kauth/kauth-5.49.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework to let applications perform actions as a privileged user"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="nls +policykit"
+
+RDEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ policykit? ( sys-auth/polkit-qt[qt5(+)] )
+"
+DEPEND="${RDEPEND}
+ nls? ( $(add_qt_dep linguist-tools) )
+"
+PDEPEND="policykit? ( kde-plasma/polkit-kde-agent )"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package policykit PolkitQt5-1)
+ )
+
+ kde5_src_configure
+}