summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-02-15 03:45:01 +1100
committerMichael Palimaka <kensington@gentoo.org>2016-02-15 03:46:01 +1100
commit308018c879d78532b4deb50754fce3b4baa9aa25 (patch)
treec239383027c2b8c67494d1a43884bb4e979733ac /kde-frameworks/kcrash/kcrash-5.19.0.ebuild
parentkde5-functions.eclass: add_{frameworks,plasma,kdeapps}_dep slot overrides (diff)
downloadgentoo-308018c879d78532b4deb50754fce3b4baa9aa25.tar.gz
gentoo-308018c879d78532b4deb50754fce3b4baa9aa25.tar.bz2
gentoo-308018c879d78532b4deb50754fce3b4baa9aa25.zip
kde-frameworks: version bump 5.19.0
Package-Manager: portage-2.2.27
Diffstat (limited to 'kde-frameworks/kcrash/kcrash-5.19.0.ebuild')
-rw-r--r--kde-frameworks/kcrash/kcrash-5.19.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/kde-frameworks/kcrash/kcrash-5.19.0.ebuild b/kde-frameworks/kcrash/kcrash-5.19.0.ebuild
new file mode 100644
index 000000000000..7979d02c5b7a
--- /dev/null
+++ b/kde-frameworks/kcrash/kcrash-5.19.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework for intercepting and handling application crashes"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="nls X"
+
+# requires running kde environment
+RESTRICT="test"
+
+RDEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_qt_dep qtgui)
+ X? (
+ $(add_qt_dep qtx11extras)
+ x11-libs/libX11
+ )
+"
+DEPEND="${RDEPEND}
+ nls? ( $(add_qt_dep linguist-tools) )
+ test? ( $(add_qt_dep qtwidgets) )
+ X? ( x11-proto/xproto )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package X X11)
+ )
+
+ kde5_src_configure
+}