summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /kde-frameworks/kdesignerplugin
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'kde-frameworks/kdesignerplugin')
-rw-r--r--kde-frameworks/kdesignerplugin/Manifest1
-rw-r--r--kde-frameworks/kdesignerplugin/kdesignerplugin-5.12.0.ebuild54
-rw-r--r--kde-frameworks/kdesignerplugin/metadata.xml9
3 files changed, 64 insertions, 0 deletions
diff --git a/kde-frameworks/kdesignerplugin/Manifest b/kde-frameworks/kdesignerplugin/Manifest
new file mode 100644
index 000000000000..6e83e3d625aa
--- /dev/null
+++ b/kde-frameworks/kdesignerplugin/Manifest
@@ -0,0 +1 @@
+DIST kdesignerplugin-5.12.0.tar.xz 86748 SHA256 af0d7e80fa2c0c815d9a67c3be0999c44f6f43f9fdccdd902fbed6a5b0bbc516 SHA512 dc2bf9530a8c6d0bca1295ce32edea4c3966e949bc52f499da1b15e0cbb0741a1f7d86aa7ca5f02fe357ad86e2f97ecd0bdcf8f9c041fdeb69c4efa573547770 WHIRLPOOL 90b5bbc51122a3b6495c23825ddabf740313a81a09d89a316d38c1d41f0b620ff782488a0b17465e784f5237e9e9e3241e09a8c8b8c48c7b11be3c272e3a8200
diff --git a/kde-frameworks/kdesignerplugin/kdesignerplugin-5.12.0.ebuild b/kde-frameworks/kdesignerplugin/kdesignerplugin-5.12.0.ebuild
new file mode 100644
index 000000000000..f2ddfb7b6e96
--- /dev/null
+++ b/kde-frameworks/kdesignerplugin/kdesignerplugin-5.12.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_TEST="false"
+inherit kde5
+
+DESCRIPTION="Framework providing plugins to use KDE frameworks widgets in QtDesigner"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~x86"
+IUSE="designer nls webkit"
+
+RDEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ designer? (
+ dev-qt/designer:5
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kplotting)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep sonnet)
+ )
+ webkit? (
+ dev-qt/designer:5
+ dev-qt/qtgui:5
+ $(add_frameworks_dep kdewebkit)
+ )
+"
+DEPEND="${RDEPEND}
+ $(add_frameworks_dep kdoctools)
+ nls? ( dev-qt/linguist-tools:5 )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package designer KF5IconThemes)
+ $(cmake-utils_use_find_package designer KF5ItemViews)
+ $(cmake-utils_use_find_package designer KF5KIO)
+ $(cmake-utils_use_find_package designer KF5Plotting)
+ $(cmake-utils_use_find_package designer KF5TextWidgets)
+ $(cmake-utils_use_find_package designer KF5WidgetsAddons)
+ $(cmake-utils_use_find_package webkit KF5WebKit)
+ )
+
+ kde5_src_configure
+}
diff --git a/kde-frameworks/kdesignerplugin/metadata.xml b/kde-frameworks/kdesignerplugin/metadata.xml
new file mode 100644
index 000000000000..0ca133efed73
--- /dev/null
+++ b/kde-frameworks/kdesignerplugin/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+ <use>
+ <flag name="designer">Build KF5 widgets plugin for QtDesigner</flag>
+ <flag name="webkit">Build kdewebkit plugin for QtDesigner</flag>
+ </use>
+</pkgmetadata>