summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-12-03 19:09:26 +0100
committerMichael Palimaka <kensington@gentoo.org>2016-12-05 03:49:16 +1100
commit2ccda80d6f77416f1f7d7f0978692a47e5b64814 (patch)
tree1c42eff6d46ae33bf4073ccb1961e5ec69a595b0 /kde-frameworks/kwallet
parentprofiles: Mask kde-frameworks/kwallet-5.28.0-r1 (diff)
downloadgentoo-2ccda80d6f77416f1f7d7f0978692a47e5b64814.tar.gz
gentoo-2ccda80d6f77416f1f7d7f0978692a47e5b64814.tar.bz2
gentoo-2ccda80d6f77416f1f7d7f0978692a47e5b64814.zip
kde-frameworks/kwallet: Add gpgme[cxx]-enabled version
Package-Manager: portage-2.3.0
Diffstat (limited to 'kde-frameworks/kwallet')
-rw-r--r--kde-frameworks/kwallet/kwallet-5.28.0-r1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/kde-frameworks/kwallet/kwallet-5.28.0-r1.ebuild b/kde-frameworks/kwallet/kwallet-5.28.0-r1.ebuild
new file mode 100644
index 000000000000..8f39077034d2
--- /dev/null
+++ b/kde-frameworks/kwallet/kwallet-5.28.0-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="Framework providing desktop-wide storage for passwords"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="gpg +man"
+
+RDEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ dev-libs/libgcrypt:0=
+ gpg? ( >=app-crypt/gpgme-1.7.1[cxx,qt5] )
+"
+DEPEND="${RDEPEND}
+ man? ( $(add_frameworks_dep kdoctools) )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_KF5Gpgmepp=ON
+ $(cmake-utils_use_find_package gpg Gpgmepp)
+ $(cmake-utils_use_find_package man KF5DocTools)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ if ! has_version "kde-plasma/kwallet-pam" || ! has_version "kde-apps/kwalletmanager:5" ; then
+ elog
+ elog "Install kde-plasma/kwallet-pam for auto-unlocking after account login."
+ elog "Install kde-apps/kwalletmanager:5 to manage your kwallet."
+ elog
+ fi
+}