summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-02-08 14:29:22 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-02-09 11:02:33 +0100
commita5e3a9b1114f82bb8aacf31a2d0fe6b30b315ddb (patch)
treeb53596ccad77fcfaa8953aca1c7cead6db71b608 /kde-frameworks/kwallet
parentsci-visualization/veusz: cleaning old (diff)
downloadgentoo-a5e3a9b1114f82bb8aacf31a2d0fe6b30b315ddb.tar.gz
gentoo-a5e3a9b1114f82bb8aacf31a2d0fe6b30b315ddb.tar.bz2
gentoo-a5e3a9b1114f82bb8aacf31a2d0fe6b30b315ddb.zip
kde-frameworks: Add KDE Frameworks 5.67.0
Package-Manager: Portage-2.3.87, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kwallet')
-rw-r--r--kde-frameworks/kwallet/Manifest1
-rw-r--r--kde-frameworks/kwallet/kwallet-5.67.0.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/kde-frameworks/kwallet/Manifest b/kde-frameworks/kwallet/Manifest
index 819867dd0b16..34b7a004e2c8 100644
--- a/kde-frameworks/kwallet/Manifest
+++ b/kde-frameworks/kwallet/Manifest
@@ -1,2 +1,3 @@
DIST kwallet-5.64.0.tar.xz 293828 BLAKE2B c42a0c325eb3b5b1cbeb107dd6d302ba257ae73a9c17b7a79a49a0daf978473fa5f9b8229dd4ad6ae742e8834d8b83a8922fbae8de9f56a81e16857b57800b40 SHA512 78a4f2b5587f6bbdbc4b6473083246c6b9f68b4e47093d5061cee1c91b855b1822bdc72437dc25259728ce8cff3d8849d4b343d2fc3921cd05beac1c00159d6d
DIST kwallet-5.66.0.tar.xz 294596 BLAKE2B f26137c54b344c2727844bdb2abf556e8bd91ad11d3d19c8fdced970d2c4ebf549df1a20c27a54587a1f71b35ccff6f2f30c6248de9e0331ec198a8b174884b6 SHA512 7a1513ca64e0532d8a2ad73118a365b50dddf9751c13d7bb889db1683a08ae05d655fab15dc1496398eb650dde27c36796c76a19eb6e25c9397d13ca86a55f3b
+DIST kwallet-5.67.0.tar.xz 296096 BLAKE2B 621eccad10b4f070a8ce20c9ba65eec6886a3891e2e412ec3bf68d9fb5a5c3d5efb1f5fc9f876bb00f49a4fd00b7d8c7346ae84a28a1b9391709d0beed46da40 SHA512 d71f29c476a7eaef05cfcd345e2569352dc5da11000bff7200dadea026d2a8f725cd777806dee99eb88944050566b630ef7904c250dddba0f68102fc320cf889
diff --git a/kde-frameworks/kwallet/kwallet-5.67.0.ebuild b/kde-frameworks/kwallet/kwallet-5.67.0.ebuild
new file mode 100644
index 000000000000..d14ca3b72e7f
--- /dev/null
+++ b/kde-frameworks/kwallet/kwallet-5.67.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.12.3
+inherit ecm kde.org
+
+DESCRIPTION="Framework providing desktop-wide storage for passwords"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="gpg +man"
+
+BDEPEND="
+ man? ( >=kde-frameworks/kdoctools-${PVCUT}:5 )
+"
+DEPEND="
+ dev-libs/libgcrypt:0=
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/kdbusaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+ =kde-frameworks/kservice-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+ =kde-frameworks/kwindowsystem-${PVCUT}*:5
+ gpg? ( >=app-crypt/gpgme-1.7.1[cxx,qt5] )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package gpg Gpgmepp)
+ $(cmake_use_find_package man KF5DocTools)
+ )
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ if ! has_version "kde-plasma/kwallet-pam" || ! has_version "kde-apps/kwalletmanager:5" ; then
+ elog
+ elog "Install kde-plasma/kwallet-pam for auto-unlocking after account login."
+ elog "Install kde-apps/kwalletmanager:5 to manage your kwallet."
+ elog
+ fi
+ elog "For more information, read https://wiki.gentoo.org/wiki/KDE#KWallet"
+}