summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-02-14 19:17:36 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-02-14 19:24:44 +0100
commit7ffc8899e9225ffe933bacb50f3f558f6c783341 (patch)
tree13796984bafbc97c60c89cd8dba80f8ed5574400 /kde-misc/kio-gdrive/kio-gdrive-1.1.1.ebuild
parentx11-misc/kronometer: 2.1.4 version bump (diff)
downloadgentoo-7ffc8899e9225ffe933bacb50f3f558f6c783341.tar.gz
gentoo-7ffc8899e9225ffe933bacb50f3f558f6c783341.tar.bz2
gentoo-7ffc8899e9225ffe933bacb50f3f558f6c783341.zip
kde-misc/kio-gdrive: 1.1.1 version bump
Package-Manager: portage-2.3.3
Diffstat (limited to 'kde-misc/kio-gdrive/kio-gdrive-1.1.1.ebuild')
-rw-r--r--kde-misc/kio-gdrive/kio-gdrive-1.1.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/kde-misc/kio-gdrive/kio-gdrive-1.1.1.ebuild b/kde-misc/kio-gdrive/kio-gdrive-1.1.1.ebuild
new file mode 100644
index 000000000000..3e204fbe0fa4
--- /dev/null
+++ b/kde-misc/kio-gdrive/kio-gdrive-1.1.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_HANDBOOK="true"
+KDE_TEST="optional"
+inherit kde5
+
+DESCRIPTION="KIO Slave for Google Drive service"
+HOMEPAGE="https://phabricator.kde.org/project/profile/72/"
+
+if [[ ${KDE_BUILD_TYPE} != live ]] ; then
+ SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz"
+ KEYWORDS="~amd64"
+fi
+
+DOCS=( README.md )
+
+RDEPEND="
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_qt_dep qtwidgets)
+ dev-libs/qtkeychain:=[qt5]
+ >=net-libs/libkgapi-5.3.1:5
+"
+DEPEND="${RDEPEND}
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+"