summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-02-13 01:22:33 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-02-13 01:24:15 +0100
commitd0a50000822f006e630f7e72981f6598fb7057a7 (patch)
tree6a6bc9dfc68fb2ebfb5ee91d0b25b54b9cb7ae94 /kde-misc/kmarkdownwebview
parentsys-libs/gwenhywfar: Add USE=libressl (diff)
downloadgentoo-d0a50000822f006e630f7e72981f6598fb7057a7.tar.gz
gentoo-d0a50000822f006e630f7e72981f6598fb7057a7.tar.bz2
gentoo-d0a50000822f006e630f7e72981f6598fb7057a7.zip
kde-misc/kmarkdownwebview: 0.5.1 version bump
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'kde-misc/kmarkdownwebview')
-rw-r--r--kde-misc/kmarkdownwebview/Manifest1
-rw-r--r--kde-misc/kmarkdownwebview/kmarkdownwebview-0.5.1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/kde-misc/kmarkdownwebview/Manifest b/kde-misc/kmarkdownwebview/Manifest
index b8ae7095bcc0..f8b0dc032396 100644
--- a/kde-misc/kmarkdownwebview/Manifest
+++ b/kde-misc/kmarkdownwebview/Manifest
@@ -1 +1,2 @@
DIST kmarkdownwebview-0.4.0.tar.xz 57728 BLAKE2B 7149f13987d1e204071ad6a030a40371065c016b94a56e7d4688b7d806ea1eee6cd543498d38ae540fc48fadd7fcbdd55842546a5f9ad337599d5edfec728a34 SHA512 3ea108441e6f35d04156b567b0aed25ce6a6f96311b69e6a6f3cfc71a4eb9b9613d36a127da19fc71dfe5118f14064f725a994dd667560699b33830482c2d380
+DIST kmarkdownwebview-0.5.1.tar.xz 58876 BLAKE2B d5bcf612844050f0877dbfea9140379315c63ee882327b40196bbf2d4071c0cdc4c14d911c94e6e01ae7928268e8909efc792f99f0fc51b49943d282e9c84b59 SHA512 4ce47765265f15e623aeb2f9a76dba284510dadd5fc31d238387fc0c2104c8ac8613b25eee982f3dba1672128557e5b54fae7aa7c3b16583eb1a94264a10f5d7
diff --git a/kde-misc/kmarkdownwebview/kmarkdownwebview-0.5.1.ebuild b/kde-misc/kmarkdownwebview/kmarkdownwebview-0.5.1.ebuild
new file mode 100644
index 000000000000..4a3e6df449f9
--- /dev/null
+++ b/kde-misc/kmarkdownwebview/kmarkdownwebview-0.5.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="KPart for rendering Markdown content"
+HOMEPAGE="https://frinring.wordpress.com/2017/09/14/kmarkdownwebview-0-1-0/"
+SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz"
+
+LICENSE="!webkit? ( BSD ) LGPL-2.1+"
+KEYWORDS="~amd64"
+IUSE="webkit"
+
+DEPEND="
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ webkit? ( $(add_qt_dep qtwebkit) )
+ !webkit? (
+ $(add_qt_dep qtwebchannel)
+ $(add_qt_dep qtwebengine 'widgets')
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_QTWEBKIT=$(usex webkit)
+ )
+
+ kde5_src_configure
+}