summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-07-15 21:24:51 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-07-15 22:51:56 +0200
commit7cee66328f8e9db5bfdb66eb0ed12fb23ad860de (patch)
tree2a2878329d292cf2e26971bf2c341dfe81a88fa6 /kde-misc/wacomtablet/wacomtablet-3.1.1-r1.ebuild
parentnet-libs/libktorrent: EAPI-7 bump (diff)
downloadgentoo-7cee66328f8e9db5bfdb66eb0ed12fb23ad860de.tar.gz
gentoo-7cee66328f8e9db5bfdb66eb0ed12fb23ad860de.tar.bz2
gentoo-7cee66328f8e9db5bfdb66eb0ed12fb23ad860de.zip
kde-misc/wacomtablet: EAPI-7 bump, HOMEPAGE, DESCRIPTION
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-misc/wacomtablet/wacomtablet-3.1.1-r1.ebuild')
-rw-r--r--kde-misc/wacomtablet/wacomtablet-3.1.1-r1.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/kde-misc/wacomtablet/wacomtablet-3.1.1-r1.ebuild b/kde-misc/wacomtablet/wacomtablet-3.1.1-r1.ebuild
new file mode 100644
index 000000000000..87b034ac93ac
--- /dev/null
+++ b/kde-misc/wacomtablet/wacomtablet-3.1.1-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_HANDBOOK="forceoptional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="System settings module for Wacom tablets"
+HOMEPAGE="https://userbase.kde.org/Wacomtablet https://store.kde.org/p/1127862"
+SRC_URI="mirror://kde/stable/${PN}/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+BDEPEND="sys-devel/gettext"
+RDEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kglobalaccel)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep plasma)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtx11extras)
+ >=dev-libs/libwacom-0.30
+ >=x11-drivers/xf86-input-wacom-0.20.0
+ x11-libs/libXi
+ x11-libs/libxcb
+"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+ x11-libs/libX11
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-xlib-optional.patch" # bug 681674
+ "${FILESDIR}/${P}-gcc9.patch" # bug 686822
+ "${FILESDIR}/${P}-correct-width-height-values.patch" # KDE-Bug 407712
+)
+
+src_test() {
+ # test needs DBus, bug 675548
+ local myctestargs=(
+ -E "(Test.KDED.DBusTabletService)"
+ )
+
+ kde5_src_test
+}