summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-07-31 10:35:26 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-07-31 10:46:30 +0200
commit29d6e13d345178bf0449c275bb5d4b5dbaf13cac (patch)
tree127a3177156b64aa11471a7d7868b39dd0b9bc11 /kde-misc
parentsys-kernel/vanilla-sources: Automated version bump to {4.14.135,4.19.63,5.2.5... (diff)
downloadgentoo-29d6e13d345178bf0449c275bb5d4b5dbaf13cac.tar.gz
gentoo-29d6e13d345178bf0449c275bb5d4b5dbaf13cac.tar.bz2
gentoo-29d6e13d345178bf0449c275bb5d4b5dbaf13cac.zip
kde-misc/kdeconnect: 1.3.5 version bump
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-misc')
-rw-r--r--kde-misc/kdeconnect/Manifest1
-rw-r--r--kde-misc/kdeconnect/kdeconnect-1.3.5.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/kde-misc/kdeconnect/Manifest b/kde-misc/kdeconnect/Manifest
index b7b2813d59fc..597c33766d87 100644
--- a/kde-misc/kdeconnect/Manifest
+++ b/kde-misc/kdeconnect/Manifest
@@ -1 +1,2 @@
DIST kdeconnect-kde-1.3.4.tar.xz 286724 BLAKE2B bf3353c317ebbb98e770a1c408940cb4ff5884f1e4a6a7ec4add5e26edf280c723af60f05ece904e624035f214757a8c8b7aeda578479bb6626c848a02155ee3 SHA512 286620cd5ed8da7a0f237710467f12be41ae139b14127b7049ee72c8a7042f67b599b642eb7c3e10a3504f1df11f5a9778db80fba4ac2e2fcd2ab4e8cafccfb9
+DIST kdeconnect-kde-1.3.5.tar.xz 292248 BLAKE2B 9f3cf111f7ed6ed0fd5790e3de19a4f60aea464b7048da423051475824f73ac8ea47f909a88d831e2372c650dcb62cbc845dc519f597f5932c6f973f0ae734b1 SHA512 ddcc8fb9707618e1dadf03fd74d4561c91fe944e72aefa2e6b488efc2fc4803e1f12d889b15aad56582e48bcd0f219b450d6c68e40b5f01d6b0ae109ef45a99d
diff --git a/kde-misc/kdeconnect/kdeconnect-1.3.5.ebuild b/kde-misc/kdeconnect/kdeconnect-1.3.5.ebuild
new file mode 100644
index 000000000000..613caa6a61b9
--- /dev/null
+++ b/kde-misc/kdeconnect/kdeconnect-1.3.5.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="true"
+KMNAME="${PN}-kde"
+KDE_SELINUX_MODULE="${PN}"
+inherit kde5
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ SRC_URI="mirror://kde/stable/${PN}/${PV}/${KMNAME}-${PV}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Adds communication between KDE Plasma and your smartphone"
+HOMEPAGE="https://kde.org/ https://community.kde.org/KDEConnect"
+LICENSE="GPL-2+"
+IUSE="app bluetooth mousepad wayland"
+
+DEPEND="
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtx11extras)
+ >=app-crypt/qca-2.1.0:2[qt5(+),ssl]
+ app? ( $(add_frameworks_dep kdeclarative) )
+ bluetooth? ( $(add_qt_dep qtbluetooth) )
+ mousepad? (
+ x11-libs/libfakekey
+ x11-libs/libX11
+ x11-libs/libXtst
+ )
+ wayland? ( $(add_frameworks_dep kwayland) )
+"
+RDEPEND="${DEPEND}
+ net-fs/sshfs
+ app? ( $(add_frameworks_dep kirigami) )
+ !kde-misc/kdeconnect:4
+"
+
+RESTRICT+=" test"
+
+PATCHES=( "${FILESDIR}/${PN}-1.3.0-no-wayland.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DEXPERIMENTALAPP_ENABLED=$(usex app)
+ -DBLUETOOTH_ENABLED=$(usex bluetooth)
+ $(cmake-utils_use_find_package mousepad LibFakeKey)
+ $(cmake-utils_use_find_package wayland KF5Wayland)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst(){
+ kde5_pkg_postinst
+
+ elog "The Android .apk file is available via"
+ elog "https://play.google.com/store/apps/details?id=org.kde.kdeconnect_tp"
+ elog "or via"
+ elog "https://f-droid.org/repository/browse/?fdid=org.kde.kdeconnect_tp"
+}