summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-05-04 23:41:32 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-05-05 00:56:46 +0200
commit3812549fcaa4f4e19d67b8286c9d07320c422297 (patch)
tree86d352784bbc24f8770c1433b68fdfc0d64ab569 /kde-misc
parentapp-office/libreoffice: 7.1.3.2 version bump (diff)
downloadgentoo-3812549fcaa4f4e19d67b8286c9d07320c422297.tar.gz
gentoo-3812549fcaa4f4e19d67b8286c9d07320c422297.tar.bz2
gentoo-3812549fcaa4f4e19d67b8286c9d07320c422297.zip
kde-misc/kdiff3: Fix build with GCC-11
See also: https://invent.kde.org/sdk/kdiff3/-/merge_requests/28 Upstream commit 0476b1daa73159aec411c7f10da6f313294f0e38 Thanks-to: Holger Hoffstätte <holger@applied-asynchrony.com> Closes: https://bugs.gentoo.org/788058 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-misc')
-rw-r--r--kde-misc/kdiff3/files/kdiff3-1.9.0-gcc11.patch24
-rw-r--r--kde-misc/kdiff3/kdiff3-1.9.0.ebuild2
2 files changed, 26 insertions, 0 deletions
diff --git a/kde-misc/kdiff3/files/kdiff3-1.9.0-gcc11.patch b/kde-misc/kdiff3/files/kdiff3-1.9.0-gcc11.patch
new file mode 100644
index 000000000000..581b487503ea
--- /dev/null
+++ b/kde-misc/kdiff3/files/kdiff3-1.9.0-gcc11.patch
@@ -0,0 +1,24 @@
+From 0476b1daa73159aec411c7f10da6f313294f0e38 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Holger=20Hoffst=C3=A4tte?= <holger@applied-asynchrony.com>
+Date: Tue, 4 May 2021 19:21:46 +0200
+Subject: [PATCH] Explicitly include <limits> for compatibility with gcc-11
+
+---
+ src/TypeUtils.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/TypeUtils.h b/src/TypeUtils.h
+index c072681..f0ab9c2 100644
+--- a/src/TypeUtils.h
++++ b/src/TypeUtils.h
+@@ -9,6 +9,7 @@
+
+ #include <stdlib.h>
+ #include <type_traits>
++#include <limits>
+
+ #include <QtGlobal>
+
+--
+GitLab
+
diff --git a/kde-misc/kdiff3/kdiff3-1.9.0.ebuild b/kde-misc/kdiff3/kdiff3-1.9.0.ebuild
index b9bac1df1bdd..adedf33c00cb 100644
--- a/kde-misc/kdiff3/kdiff3-1.9.0.ebuild
+++ b/kde-misc/kdiff3/kdiff3-1.9.0.ebuild
@@ -39,3 +39,5 @@ DEPEND="${COMMON_DEPEND}
RDEPEND="${COMMON_DEPEND}
sys-apps/diffutils
"
+
+PATCHES=( "${FILESDIR}/${P}-gcc11.patch" ) # bug 788058, git master